Diablo® III

FPS - A Letter To Blizzard

(Locked)

Allright.. I've got an early 2009 macbook, the random one that came out with two graphics cards - Nvidia 9400M and 9600M GT.I have to switch between them.

When I play on "low performance" (9400M) I have to have 800x600 res, and then it's sort of playable. It's ridiculous though because I'm so slow in some parts that I'll have died before I even see any enemies... NOT COOL!. Some boss fights I literally can't do anything (all of act IV pretty much) because I'm too slow to be of any use to my party.

When I switch to "high performance" (9600M GT) then I get about 10 seconds of great 1440x900 awesome sweet smooth gameplay - and then it freezes. Woohoo! I have to wait about a minute for it to tell me I either got disconnected or the whole program quits.

I've done everything - Reset the SMC, repaired disk permissions, quit all but the essential programs, I've even done a complete fresh install of lion, all the updates, the combo update, did I mention it's all on a SSD? So there should be no read time issues..

I understand bad resolution with the 9400M, but what's the deal with the 9600M GT? I don't get why it keeps freezing up. Please help Blizzard! I love this game! and want to be able to play it and be useful.
What could you really do to improve our FPS? Like most people here I can't afford a new mac just for diablo because of university so I'm stuck with 9400m :(
I've had pretty decent fps up until today. I think it may just be that the skill runes for the demon hunter add a lot more effects to the attacks, now I'm having drops down below 10 FPS when I would normally have 30-50.

I'm running an intel hd 3000 and a core i5 Mac mini upgraded to 8 gigs ram
I've seen several responses from blue. I don't understand why some people are unable to find them. I have very limited time to search but 10 minutes was enough time for me to find that blue is actually aware and responsive to the situation. Patience is good. After all this is one of the biggest releases in recent history so you have to expect some hiccups along the way, especially since a lot of people have been raging about the delays in the release. Just chiiiilax.
Yea I know, I'm glad blue has been responsive. I think what a lot of people need to realize is these things take time. Patches aren't written in a day
@S4d1k, regarding the machines with 9400ms, I think it is important to note that when I first started playing the game I actually had pretty decent framerates (20-30) at highest resolution (most settings low or medium) even in heavy groups of mobs. It was only after periods of extended play that the framerates went to absolute hell, so I feel like its less of an issue of whether or not our hardware can handle the game and more an issue of yall's optimization for us.
Just fyi I have a Macbook pro 15 inch 2.2ghz 4gb memory with a AMD 6750M 512mb (late 2011)

My framerates with full resolution(1400x900 - shadows off, everything else high) were around 45fps, not bad. But expected better.

But with display port my FPS drops (with around the same resolution and same settings) and ranges from 20-30, sometimes a bit lower. Is this normal? Not sure how many of you are using display ports. Anyway.. hopefully theres a fix soon.

Also, does anyone have any benchmarks for bootcamping on windows 7? I keep hearing mixed results.
Edited by mikeezy#1349 on 5/18/2012 11:39 PM PDT
I am very upset about this, just because of the fact that we purchased something on the guarantee of compatibility with our system. There is no reason for us to have to wait for a response and a solution, nor be here complaining/venting/posting about this issue, simply because this was something Blizz should have checked out before putting it out there and mostly because Blizz was notified about in the Beta! So they must have known at the very least like 6 months ago. I know i wrote in about this issue while playing the Beta and many more like me did as well. i simply figured "they'll fix this, this is a Beta its going to be glitchy and have some bugs, but there is no way they will let this hit the shelves as is" They knew about this yet did nothing, they released the game and we all paid the same $60 PC users paid and now instead of being able to enjoy ourselves with our friends we are here stuck spending hours troubleshooting and searching for posts on wether this has been fixed or if it is being addressed. it is simply appalling that Blue's response to this issue is "oh we didn't know, we will look into it and do the beast we can to fix it!" I'm sorry, but that just isn't good enough for me. You can't just take my hard earned money and give me a product you knew wasn't going to work and then act like you are working diligently to fix "my problem"

This reminds me of the time Ford decided to sell faulty exhibitions which were prone to roll overs (because of the tires i believe) and decided no to do a recall because it would cost the company more than just to pay those who suffered damages/loss of life. They ended up getting sued, paying for damages and doing a recall. Now obviously no one is in danger of a life threatening automotive accident over this, but I'm making a comparison as a sleazy business practice. I think a previous commenter put it best, we are funding their research and solutions for this issue. Blizz must get this issue resolved quickly and efficiently or i wouldn't be surprised if a class action law suit comes into fruition if people don't get their money back.
I am very upset about this, just because of the fact that we purchased something on the guarantee of compatibility with our system. There is no reason for us to have to wait for a response and a solution, nor be here complaining/venting/posting about this issue, simply because this was something Blizz should have checked out before putting it out there and mostly because Blizz was notified about in the Beta! So they must have known at the very least like 6 months ago. I know i wrote in about this issue while playing the Beta and many more like me did as well. i simply figured "they'll fix this, this is a Beta its going to be glitchy and have some bugs, but there is no way they will let this hit the shelves as is" They knew about this yet did nothing, they released the game and we all paid the same $60 PC users paid and now instead of being able to enjoy ourselves with our friends we are here stuck spending hours troubleshooting and searching for posts on wether this has been fixed or if it is being addressed. it is simply appalling that Blue's response to this issue is "oh we didn't know, we will look into it and do the beast we can to fix it!" I'm sorry, but that just isn't good enough for me. You can't just take my hard earned money and give me a product you knew wasn't going to work and then act like you are working diligently to fix "my problem"

This reminds me of the time Ford decided to sell faulty exhibitions which were prone to roll overs (because of the tires i believe) and decided no to do a recall because it would cost the company more than just to pay those who suffered damages/loss of life. They ended up getting sued, paying for damages and doing a recall. Now obviously no one is in danger of a life threatening automotive accident over this, but I'm making a comparison as a sleazy business practice. I think a previous commenter put it best, we are funding their research and solutions for this issue. Blizz must get this issue resolved quickly and efficiently or i wouldn't be surprised if a class action law suit comes into fruition if people don't get their money back.


This is exact how i feel. Word for word how i feel right now. IF they dont fix this issue, i will create and contact some how everyone with this issue, in hopes we can file for something and get a refund, but this is the worse part...i dont want blizzard to turn around and just give people there money back and not fix this. I want to play this game like many others and i hope this issue does get resolved since its pretty bad and i brought this game like many others on the basis that i meet the 'recommended' requirements.

Really hope this issue doesnt get forgotten and also hope if it turns out it wont work on the 9400, will they try and make a fix for the 9600 which is more than enough...
Edited by PoW#2597 on 5/19/2012 12:08 PM PDT
While I think it's important for people to be patient and civil, I think it's important nobody tell people to stop posting about the problem. The more people that post the more important fixing the issue becomes, they've got to know a huge number of people are dissatisfied.
05/19/2012 12:32 PMPosted by PandaGrahams
While I think it's important for people to be patient and civil, I think it's important nobody tell people to stop posting about the problem. The more people that post the more important fixing the issue becomes, they've got to know a huge number of people are dissatisfied.

QFT. If you do nothing else to help us with getting this fixed, just please go send them a service ticket. Don't rage at them, just tell them that you want to know what's going on and how displeased you are. Be civil with them, and they'll be more willing to help us I'm sure. You can express frustration and fury with more than caps lock and butthurt. Use your heads and your words.
i have an imac new as of 2011 december and it is running like crap...its not just older macs
I want to clarify my post as I don't want it to be misinterpreted, I think people need to send
blizzard a ticket and post on the forums so they can see the large number of people being affected by this oversight. My point was simple, We shouldn't HAVE TO do that after people had already reported this a very long time ago. This is affecting a huge number of Mac users and not just ones with older macs it's affected people with newer models, it's not just affecting the GeForce 9400 it's affecting the intel and AMD video cards as well. This game is just sitting in my HD taking up space and it took money from me that I could have used on something other than a useless game file, I would have loved to have been told that we might have a delayed release and kept my money so I can use It on other things while they fixed the bugs/glitches/issues and I would have been ok with that. Blizzard knew and they sold us a non properly working product to drive up their sales on release night and week, and that's what I can't stand.

We are a driving force for this industry, I don't think we need to be vulgar or threatening on these forums, but we should definitely speak up and not let a billion dollar corporation that we helped build screw us over like this
because if the odds are against a successful fix, we can just go buy a cheap new computer.
but if its a "definitely will be fixed" I can wait...

No, we can't. Aside from D3, my Macbook 6,1 works swimmingly. I'm planning on buying a computer in the next year or so, but if this isn't going to be fixed then in the meantime I'd like my $65 back so I can entertain myself with something else.
Strange, because I couldn't pay you "as soon as I could".
92 Tauren Shaman
16320
Posts: 136
05/19/2012 12:38 PMPosted by siXTyNiNe
Honestly... Why can't a multi-million dollar company (actually that's an understatement) invest a few hundred thousand dollars into making this issue affecting Macs go *poof*? Why not? It's obviously a coding problem -- it's not a problem with Mac hardware. It's something that could easily be fixed with rigorous analysis and testing on all older models which are affected.


Honestly I think it is because the older computers run the old OS, and therefore didn't get an invite to Beta testing which would have been the best place to fix this coding problem. My wife had to upgrade to snow leopard before it would even install.
on one of the other threads, i forget which one, but one of the blizz posted saying theyre working on short term solutions to the problem. the post was a couple days ago and for me, the first time i really had problems with slow fps was near the end of act 1. so theres a lot of us who didnt know this was an issue a couple days ago when blizz addressed the problem. but since then i havnt really been able to find out anything else. (if you know what thread im talking about, feel free to post it or correct me if i made anything up) id like it if blizzard could get in touch with all of us having this issue and let us know what theyre doing about it or planning on doing about it. i dont think blizzard would sweep this under the rug and i dont think theyll leave us in the dark a month. hearing some formal acknowledgement of the problem this week would be ideal, the earlier the better please. we just wanna play

edit: i got my macbook pro about two years ago and everything in it is standard.
Edited by Jahhweh#1800 on 5/19/2012 5:53 PM PDT
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]