Diablo® III

Online purchase problems

Problem experienced while purchasing online:

Bought it with my CC for my battle.net account the first time, the next day it says I only have a starter edition.

Received email:
This notice is being sent to inform you that we were unable to successfully complete your recent purchase on the Blizzard Store. The charge for that item on your order was not finalized.

Since we could not fully authorize this item’s purchase, it has now been deactivated. If it was applied to a play account, it will no longer appear, and the account will be left in the state it was in previously.


I bought it one more time and it has worked since (like 5 days).

I bought it for my GF, same problem, next day starter. Rebought it, then again, starter the day after.

I have since used my credit card to make many purchases (I use my credit card about twice a day at retail stores) and it works fine. I re-entered the information manually every time I made the purchase and this problem occurred on two different battle.net accounts. My second purhcase does not show on my online CC statement 5 days later, while every other purchase I have until about 2-3 days ago shows up. (however, the CC funds have been reserved on my CC)

Attempted to call Blizzard, the phone queue is full. It is not letting me wait, previously I called and it said 27 minute queue but I was busy. Now I dont even have the option of waiting so here I am with my sad GF who has been waiting to play with me all day :(
Reply Quote
39 Human Warrior
230
same problem. Happened twice now
Reply Quote
Same problem. I purchased the game and played about 3days and they suddenly my game was changed to the starter's version.
Reply Quote
same problem....twice
Reply Quote
i had this problem too. did u guys manage to solve it yet?
Reply Quote
yes, i got the same problem, any idea?
Reply Quote
need help >..<
Reply Quote
.
Edited by PacGamer#1759 on 7/27/2012 8:32 PM PDT
Reply Quote
I've had the same problem and they haven't gotten back to me via online support. Also the phone queue is full. Very very annoyed.
Reply Quote
I have an open support ticket on this right now. I'm having the same problem. I have tried re-purchasing numerous times. If I find out how to fix it I will let you guys know.
Reply Quote
Same problem here....
Reply Quote
Same problem here.....
Reply Quote
5 Days ago I purchased upgrade for my niece online. She has received notification that payment was received and validated, yet she is STILL unable to trade, pick up items dropped in party, nor can she use auction house! This has cost me $90 for a game that is only frustrating for us both!
Blizzard, PLEASE do something about this asap. Thank you
Reply Quote
MVP - Technical Support
View profile
Have her close the game then go to Account Management here on the website and change her password. That will force an account data refresh and should resolve the issue.
Reply Quote
Thank you for response. I'll convey your suggestion.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]