Diablo® III

Continuously Getting Kicked Out of Game

idk what is going on, but I can't stay in a game for longer than 5 minutes with out getting kicked out and telling me that the connection had a problem.. I've been playing Just fine up until today, now all of a sudden It's crashing on me and I can't play a single match for longer than 5 minutes.. Anyone know what's going on?
Reply Quote
110 Worgen Mage
15225
Posts: 4,884
Yep, gotta say that the disconnects are really killing my enthusiasm to play the game.
Reply Quote
It's been happening to me since the start.
I want to play the game, I want to like the game, but I am not happy playing in five minute increments.
When will this be fixed?
The one fix I read about which is to post in General Chat every minute or so to keep from being kicked does not work.
Reply Quote
Definitely, I'm having the same issue. Can't stand this...Fix please.
Reply Quote
ditto..... why do i keep getting booted out
Reply Quote
Support Forum Agent
Posts: 43,219
Bosco / Drty,

Could you let me know what type internet connection you're using? Does it happen to all of your characters or just one? Does it happen any particular time of day? Are you playing solo or multiplayer when it happens?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Edited by Omrakos on 6/7/2013 1:23 PM PDT
Reply Quote
Happens to me as well. Never happened before 1.08.

Using AT&T U-Verse 12mb down/1.5 up.
Doesn't matter what character I'm playing or if I'm solo / multiplayer.
Can't pinpoint a time of day since it seems to be really random, some nights I can play for hours without being disconnected, some nights I'm disconnected every 5 minutes, happens during the daytime randomly as well.
Reply Quote
Support Forum Agent
Posts: 43,219
Jetheth,

Are you using wireless anywhere in your connection to the net? Any other users on your network while you play?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Nope, wired in. Happens both without anyone else connected and with others connected, played for several hours tonight without being kicked off, hopefully it stays that way, but usually I get a few windows of playtime before I'm kicked out every 5 minutes and give up.
Reply Quote
This has been happening to me too. I'm in Aus on cable and it's only been happening the last month.

The game has been running fine, no lag or anything, when suddenly I'll get the "Connection Lost" message. Starting to piss me off cause I usually have a nice Nephalim 5 bonus going at the time.

I also play LotRo without any issues whatsoever, so I'd be surprised if it's my end.

And yes, it's with all characters, high and low end.
Reply Quote
Ah yeah, forgot to mention that. There's no lag or anything, my latency sits around 80ms usually and I never see it change, I notice no lag at all, I just get kicked straight out right away.
Reply Quote
Still having this issue.
Reply Quote
Bump..
Reply Quote
Support Forum Agent
Posts: 43,219
Jetheth,

There's really not much troubleshooting I can recommend. Getting kicked of suggests the connection wasn't able to be maintained, but none of the game logs are going to show a cause for that.

It might help if you could be running a 3D trace when the interruption occurs. This could possibly narrow down a problem to a specific hop or provider along the way from you to us.

http://www.d3tr.de/

Since you're getting game disconnections, it should be left running long enough to encounter a couple of occurrences of those issues.

Consult this support article to see what IP address you should be tracing to.

You'll be able to copy the results to your clipboard and then save the image, in Paint for example. Then you can upload the file to an image hosting site.

The 3D trace and List formats will be needed.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Thanks Omrakos, it has to be something to do with AT&T, whether it's an issue on my end or an issue with how AT&T is handling things sending your way I don't know.
I tested it out on a different connection while I was having issues and it worked fine (although very laggy since it was a bad connection.. still no disconnects at least.) ..

D3 is the only game I have any type of error in though, it just drops right away, no lag at all and it seems to be responding up until the moment it kicks me. I can pick up some loot a second before it kicks and I still have that loot when I get back in and I've never died from it leaving me in game either.

I'll give that a try and post back the results.
Reply Quote
Here are my results, started right after being kicked out of game and ran for a little while. Wasn't in game to confirm that it was still happening, but it looks pretty bad so I'd assume it would have kicked me.

3D Trace:

http://i.imgur.com/ucGzStz.jpg

List:

http://i.imgur.com/4nAXnVk.jpg
Reply Quote
Support Forum Agent
Posts: 43,219
Jetheth ,

The trace doesn't suggest any reasons for you being disconnected. It doesn't sound like you were playing and disconnected though when you were running the trace program?

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
No, I started it after being kicked out which usually means I'll be disconnected every 5 minutes for the next few hours. I'll run it again in the background until I've been disconnected a few times.

There's nothing wrong with hops 2/3/4/5 which don't always go through?
Reply Quote
Support Forum Agent
Posts: 43,219
Jetheth,

They're going through just fine. Hop 4 is the only one I'd be curious about but normally, the lack of data just means that particular router it's hitting is configured not to respond to the type packets being used in a trace route. That's what we do too on our servers which is why you never see results from the servers at our end, instead you see timeouts across the board.

_________________________________________________________
I'm available in the forums Monday - Friday, 12 pm - 8 pm Pacific Time
Please provide feedback! - https://www.surveymonkey.com/s/Omrakos
Reply Quote
Ok, had 2 days with no disconnects, didn't change anything on my end, but now it's started back..

Opened up the 3d traceroute and ran it in the background while I was disconnected 4-5 times.

http://i.imgur.com/xZ2H0QA.jpg

http://i.imgur.com/SrcuOJk.jpg
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]