Diablo® III

Unable to execute Diablo 3 launcher

Posts: 17
I have been able to play Diablo 3 since launch without any technical problem (on my part), but recently I am having an error that unables the launcher of the game to start.

I did a system restore today in the morning, because I encountered a problem with my firefox. Being the restore point yesterday and after that I have been getting the following message, which is kind of cryptic:

"the procedure entry point ?readWriteLock@QObjectPrivate@@SAPAVQReadWriteLock@@XZ could not be located in the dynamic link library QtCore4.dll"

I have been playing yesterday Diablo 3, so I do not think that the system restore is the problem.

So I uninstalled the game and tried to installed it again, but when trying to run the installer the same message pops up.

I have attached a picture of the Error. Hopefully someone will know what is going on. :(

http://imageshack.us/photo/my-images/513/errorpic.jpg/

or this link

http://img513.imageshack.us/img513/8232/errorpic.jpg

I can play any other game like Starcraft 2, the Witcher 2, Dawn of War II, etc.
Edited by HeavenlyKing#1282 on 5/25/2012 6:32 PM PDT
Reply Quote
I can't execute diablo 3 launcher either since the patch, still waiting for a solution
Reply Quote
85 Blood Elf Warrior
7555
Posts: 3
I have same problem...
I uninstall it...and try re-install using REAL CD
Nope, it still give me same message. Now, i can't even install the game
Reply Quote
Same problem, is says: The procedure entry point ?begin@QListData@@QBEPAPAXXZ could not be located in the dynamic link library QtCore.dll.
Reply Quote
Posts: 17
Blizzard help us !!!! :(

I also submitted a ticket but no one answers me ¬_¬
Reply Quote
Posts: 17
I did it !!! :D

I have the answer I search all around the web and what you have to do is to delete the Batlenet folder from c:programsdata. Is a hidden folder.

After you do that, run the installer of the game and after some updating, the launcher will run and begin to install the game.

YEAH!! XD

EDIT: I have not modified nothing. I just wanted to mentioned this in case a Blizzard mod reads. What I did is to just let the installer of the game to reinstall the launcher. :)
Edited by HeavenlyKing#1282 on 5/26/2012 1:38 PM PDT
Reply Quote
what you have to do is to delete the Batlenet folder from c:programsdata. Is a hidden folder.


THAAAAANKS FOR THE HEEEEELP!!!! damn have been trying for different solutions now i 2 days!!!! u are the man! cheers!!!!!
Reply Quote
Now I get Procedure entry Point ?begin@QListData@@QBEPAPAXXZ could not be located in the dynamic link library Qtcore4.dll

I do not have any Qt style program installed.
I have ran Service file checker and found no issues.
Repaired .NET Framework and Windows Visual C++.
I have googled this issue and cannot find a fix. One forum claimed to have fixed it but does not explain how.
I have ran Depends program and every file I download is missing IESHIMS.DLL. I sourced this and cannot find a solid fix (outside my programming knowledge)
Also tried a RegFix using Windows exe fix.
Contacted Windows help service personnel and claim there are more complicated issues with C++ and Framework.

My girlfriend's computer ran it fine with no issues. We both run ESET, Malewarebytes.
No Virus on my computer for years/no corrupted file potential.

Any ideas? I have no other leads to work on.
Reply Quote
Support Forum Agent
Posts: 42,458
ZIONROOTZ,

Could you try what's described in the following article please?

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS
Reply Quote
Posts: 2
IM HAVING THE SAME PROBLEM!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]