Diablo® III

BUG: Frame Skipping / Camera Stutter

(Locked)

If you alt tab, or windows tab out then back in. Does it still stutter? Just curious.
Yes it does.
Posts: 1,763
G-74 Here
I have the same problem. Mobs can spontaneously be on top of me with no travel time. One second they're on the far left of the screen. The next second they're on me and I'm dead. It isn't even lag, because everything else seems to be running fine, and my ping is 68-88 on average.
Halcyon,

Your issue is definately not what we are discussing here.

My post is about a stutter of the camera when the screen is panning. It is just like a 1/8th of a second frame skip/stutter. It would not cause what you have described.
Edited by Graysdir#1665 on 6/2/2012 11:14 PM PDT
There is a small amount of micro-stutter even with v-sync on in this game. Sometimes it is more noticeable than others, but it definitely exists.

I was messing with the FPS limiter today and 'broke' it somehow, it would not limit the frames correctly below 100, it would just get stuck at 50. It is still like this and apparently this bug plagues many other people too.

I just wanted to add that the FPS limiter breaking is what lead me to finding the smoothest configuration I've found yet, stutter wise, it just requires a couple 3rd party programs, which kinda sucks.

---------------------------------

To achieve this:

First open Diablo 3 and turn off the frame limiters (both of them) and turn on v-sync, in the options. After you do this, shut down the game.

Then, you want to use D3DOverrider to force 'triple buffering' and nothing else. (make sure it is not trying to force v-sync, as this is already on in the game, it can give you issues if both are on)

Next program I used is called EVGA Precision and that has a FPS limiter in the overlay settings section. I set this to 61 and the game is smoother than it ever has been for me. I experimented with 58, 59, 60 & 61, and this definitely has the best results on my machine. The reason to offset it by 1 FPS from your refresh is to mitigate input lag induced by having v-sync on. The game looks smooth and the response time is quick.

--------------------------------

Both of these programs consume minor resources, just leave them open in the background while playing the game.

It's a shame we can't do this in software because the game looks jerky and awful with the default setting of v-sync off on a flat panel monitor.

Another thing that may help minimize jerkiness in the game is to set your 'maximum pre-rendered frames' to 2 or 3 in the Nvidia control panel. (dunno if this helps with ATI as well..) Many gamers set this to 1 or 0 to get a very minimal increase in response time, but if you play around with the settings, in my experience, you will see it can induce some jerkiness when set to 1 (0 is a mystery to me, some studies have shown it is the equivalent of 3)

Just wanted to share whats been working best for me, but as always, your mileage may vary.
Hello Everyone !

Another post to say that I still have the same issue.

I've been reading quite a lot of forum posts and tried a ton of "possible fixes" without success. Graysdir PERFECTLY described the stutter I am experiencing. No matter what I do, the "stutter" described in the OP subsides.

I'm convinced this problem is Blizzard's fault ...

I experienced this in the Open Beta and from what I've read, this problem was already present in the Closed Beta. I've been following these forums since launch day and I have seen very little "blue posts" concerning stutter issues, and none (I'd be happy if someone could prove me wrong) concerning this stutter. They asked for "DxDiag" logs the first few days and that's it.
The sticky post CURRENT DIABLO III PERFORMANCE ISSUES in the technical forum doesn't help either ... nor does it give me hope.
We have a problem that has been in the game for many months and that hasn't been aknowledged by Blizzard. Even though this is going to sound mean, I hope we reach the "critical mass" of users having this issue so that it will be removed from the "Problems we have since the Beta but we won't try fixing because not enough people are complaining" list Blizzard has.

Sigh ...
Edited by RoedeOurm#2477 on 6/3/2012 1:50 AM PDT
I've mentioned this problem does not exist for me in multiplayer games.
I just found out why.

Whenever my friends and I play the game with skype running.
vsync on, foreground set at 60.
My fps will be running SMOOTHLY locked at 60fps!!

This is too weird.
How did I find out about this?
I was playing with my friends and fps stable at 60.
Once my friends hung up the call, fps immediately go back to 50 locked!

Damn no blues respond yet.
Edited by donysteal#3433 on 6/3/2012 7:11 AM PDT
Donysteal... if this problem does not exist for you in multiplayer games, then it is a different issue. Create a different thread if you need to, but I want this thread to stay on track please.

RoedeOurm... What are your system specs? That may help the devs.

I played Tribes Ascention for an hour today... smooth like silk. Played Path of Exile, a Diablo clone made by a very small Indie development team... smooth as silk, and even works great at 120hz.

I would sure appreciate a response from Blizzard on this issue. Just like many of you, I have waited for this game for years. I spent $3k on a new PC just to play Diablo. Now I have TWO systems that get this stutter. After dozens of hours of troubleshooting, I would hope Bliz would at least have the courtesy to tell us if they are aware of this issue and working on it.
Edited by Graysdir#1665 on 6/3/2012 11:54 AM PDT
Same issue here. I get a nice 60fps, yet the camera will just randomly start to jitter as I walk. I can alt-tab to windows and come back and it will be nice and smooth for a little bit, then it starts stuttering again.

I've tried everything I can think of.

i7-920
Radeon 5870
256GB Vertex3 SSD
Edited by BomarOrder#1400 on 6/3/2012 3:10 PM PDT
Same thing here i get like 60+frames but it keeps on skipping and i cannot play like it.
Good to hear I'm not alone... please bookmark this thread! Hopefully they will look into it soon.
If you are having this exact same issue, please create a support ticket:

https://us.battle.net/support/en/ticket/status

Also, link to this post so Blizzard can view the youtube videos I provided links for, get a full description of the problem, etc.
06/03/2012 11:44 AMPosted by Graysdir
Donysteal... if this problem does not exist for you in multiplayer games, then it is a different issue. Create a different thread if you need to, but I want this thread to stay on track please.


You should try reading what he wrote before dismissing him, he's on to something.
same thing for me! wondering if its related to all the rubber-banding we are having
Same problem here. I've done all I could to rid this issue. I've cleaned my video drivers with driver sweeper and reverted back to nVidia 296.10 which was working smooth when game deployed. I've upgraded all other drivers to include bios. Installed only video and phsyx drivers. Clocked system with multple settings (that work) in all my other games to include SWKTOR. Also tried the V-synch + Triple buffering forse ON. Tried forcinging fps to locked 60. There is definately a problem that Blizzard needs to address as this is just sad...

i7 - 2600k Sandy Bridge
eVGA GTX 560 1gig
16gig Vengeance Corsair
750 W PSU
Asus P8Z68-V
Ergophobia... I read his post. I didnt mean to dismiss anything, just trying to keep my post on track. In any event, his post is there, so if devs read it and it gives them ideas to try... then good!

Halfgodpro... I dont think it is related to the rubber banding. its not my character that is "jerking" around, its the screen whenever it pans. To be honest, I have never seen any rubber banding in Diablo. I am pretty sure if there was an offline mode, this problem would still exist. But who knows...

I'm not claiming to be an expert, but for what its worth, my wife and I are both in software development, and I was on the development team for a FPS game - we have both seen this type of issue before, and after dozens of hours of troubleshooting, we are fairly convinced that this issue is due to the way the engine is rendering the scene. I believe that if one of the developers who is familiar with the way the scenes are rendered was to investigate this, it would be fixed. They have some amazing talent at blizzard... all it takes is the right person to look into it.
Edited by Graysdir#1665 on 6/4/2012 10:07 AM PDT
90 Draenei Shaman
5690
Posts: 3
I HAVE FOUND A SOLUTION. I think.

My specs:

AMD Phenom Black 9950 X4
SLI GTX 260 x 2
6gb DDR2 1066
SSD (OCZ Vertex 2)
Sharp Aquos 52" - 1920x1080

Relevant in-game settings:

Everything maxed except Shadows at Medium
Fullscreen
V Sync ON
Frame limit at 60

I have been tracking down this issue since launch. Studying it. Trying to get a feel of it. Tried countless setting adjustments and stuff, including SLI related ones.

It haunted me endlessly and definitely gobbled up hours of gameplay just trying to narrow it down.

But I had pretty much given up hope by now.

Until I came back in the spider cave during my first Hell run.

The stuttering was just unbelievable, made the level very painful and frustrating to play in.

So again, I started toying around with settings and stuff. And then I noticed something.

If I walked a few steps up and down at one specific place (still in spider cave), thus bringing some environment stuff on and off screen, the FPS would go from 60 to 30. Yep that clean a cut. not 28, not 31. 30.

One spot stable at 60. Walk down 2 steps, stabilizes down at 30.

I was like, wtf, what's going on with these mushrooms that makes my FPS go down a whopping 30 FPS just by having them on screen?

So to the narrow down process. First thing I tried was bringing down (in-game settings) Anti-Aliasing, Clutter, Physics, in that order, one value at a time. No change. Still 30 FPS.

Then Shadows. Downed to Low, no Change. And then...

Shadows OFF. BOOM. FPS kicks back to 60.

OMG

Put Shadows to Low again... wham, FPS down to 30. Shadows to off again, and it kicks back to 60.

So there you go. On my specific setup, shadows are the issue.

My conclusion is that certain environmental decoration assets can be affected by shadows so much that it can make FPS jump from 60 to 30 in an instant.

So that 's bound to create stuttering wouldn't you think so? It means that this stuff going off and on screen when you move around makes your FPS alternate between 60 and 30 repeatedly and very fast, creating stuttering.

That being said... seriously? I have to turn shadows OFF to play the game flawlessly? I mean I don't have the most kick !@# rig but it's definitely not bad, in most games I played maxed out WITH shadows, sometimes at a lower setting like Medium since I don'T mind the minimal difference in quality, but NEVER before did I have to turn them completely OFF.

As a QA Lead for X game company, I am fairly certain that this is a fixable engine issue. It's just not normal to see that big of a difference between off and low by staying in the exact same spot with nothing going on except for slowly dangling mushrooms. I have seen and reported similar issues in other games, which usually were fixed by the engine departement in a matter of days.

Submitting a ticket with this info, already taken a screenshot of the spot, so hopefully this helps Blizz track this down and fix it :)
Hi Zhuge... The specific situation I am seeking help with has nothing to do with shadows. It sounds as though your stutter may be a different issue. I have shadows turned OFF on both of my PCs. By the way, the reason you see a drop to 30fps may be due to the fact that it will drop in certain increments. If your fps drops to 55, it may actually drop you to 30, so it is evenly divisble by your refresh rate. Alas, I wish it was as easy as turning my shadows off! I am glad that you figured out a way to resolve your own issue, though!

In my case, the FPS is very high, generally stays at 60 - except I get the occasional split second jump to triple digits even though 60hz vsync is on. Even with 4 players spamming spells, all graphics turned to max, it is smooth like silk... as long as I stand in one spot. As soon as the camera has to move, (even in a town with no other npcs or players nearby) I get a distinct skipping of frames every couple of seconds.

Thanks for your replies.
Edited by Graysdir#1665 on 6/4/2012 10:06 AM PDT
If you want to recreate this issue, to determine if you are having this exact same issue:

- Turn vsync ON. Lower graphics settings to a value that will allow your system to always run at a stable 60fps even in 4 player games with lots of action on screen. CTRL-R turns on your fps counter.

- Go in a full game, STAND STILL, and when there is tons of action on screen it should run smoothly as 60fps with no slow-downs. (this step is to ensure your system can handle the demands of the game, and it isnt an issue with FPS/horsepower!)

- Go to a private game with no other players, Go to Tristram, and run a couple laps to make sure all game assets are already loaded.

- Run laps around the waypoint in Tristram. If your screen "jerks" every few seconds whenever the screen is panning, then you are likely experiencing the same issue.

If you hit ctrl-r, you may also notice a rapidly spinning 60fps counter, with occasional jumps to triple digits, when your screen is panning.

Thats how it is on all 3 PCs I have access to. There are many different types of fps issues in Diablo, but this specific one I seek help with, is very easy to recreate.
Edited by Graysdir#1665 on 6/4/2012 10:47 AM PDT
90 Draenei Shaman
5690
Posts: 3
Yeah you made me realize it must just be Vsync. That's what's forcing the game to choose between 60ish and 30ish, to adjust to the screen's refresh rate, am I right? By disabling it, it drops a bit below 60 but not straight to 30.

And it's not the mushrooms after all. It's the transparent webs sometimes passing on the foreground in front of your character. So whenever you move around and a foreground web crosses the screen, that's what makes the game go down from 60 to 30. Well, that causes a drop that will make the game go to 30 with Vsync on of course.

And these webs are definitely problematic. By moving around and forcing them off and on screen repeatedly, the game stutters. When there are no webs, it's smooth at 60 (frame limited). As soon as webs come in, it immediately starts to stutter and it will continue to stutter inconsistently as long as they're on screen.

I'll try to see in other levels if other foreground elements cause this as well.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]