Diablo® III

BUG: Frame Skipping / Camera Stutter

(Locked)

Hi Zhuge... Yep, that is correct... but it depends on the game's implementation of vsync.

However I wont elaborate further, as I want to stay on topic.
Edited by Graysdir#1665 on 6/4/2012 10:59 AM PDT
90 Draenei Shaman
5690
Posts: 3
FIXED.

It believe it was a TV compatibility issue in regard to refresh rate not always being flat 60, but slightly lower like 59.94. Playing on a 52" DEL LCD so... might have created some "refresh-fighting" or something like that.

Now using these settings, playing near-flawlessly (drops with big action but I don't mind that, I just want to be able to run around without stutters) in spider cave:

- Screen refresh rate set to 59hz in nvidia control panel.
- Fullscreen
- Vsync ON
- Frame limit to 59 in-game
- Frame limit to 59 in EVGA Precision X app
- Everything maxed except Shadows at Medium
Zhuge; Please stop posting "FIXED" and... "I FOUND A SOLUTION" etc... your issue is different, and with all due respect, I want this thread to stay on topic. I don't want the devs to think this problem is solved.

If you could please edit your last post / remove it, I would appreciate it. Thanks for understanding.
Edited by Graysdir#1665 on 6/4/2012 12:46 PM PDT
Posts: 6
I have the exact same problem. I have been playing around with settings for days now and no luck in finding anything :( Everytime i am running around in New Tristram im experiencing camera stutter every 2-3 seconds. I have vsync enable with nvidia inspector and tripple buffering as well. Frames limited to 60, power management is set for performance, thread optimization is off. All my graphics are set to high, and i tried with and without SLi.

I have the latest gears since i just bought a brand new PC last month.

-ASUS P9X79 Deluxe ATX LGA2011
-Intel Core i7 3820
-16Gigs Corsair Vengeance CL8-8-8-24 Quad Channel Memorykit
-2x GeForce GTX 680 SLi enable
-SSD OCZ Vertex 4 256GB SATA3

Please Blizz help us to solve that issue!
Frostshade... Sounds like we have the exact same issue - I have a GTX680 in my Diablo rig as well, and a GTX280 in my old system, and both suffer from this camera stutter. I wonder if Bliz needs to work with nVidia to fix this. I know of a few ATI users that say they have it, but until one of them can confirm that they have followed my steps to recreate the issue, it is entirely possible that their stutter is different than ours.

Are you also seeing the rapidly spinning in-game fps counter with occasional jumps to triple digits while running around town? (vsync on). Not sure if its related but I dont see that in any other game I play, and the stutter might correspond with the blip to triple digits? The camera stutter only happens when moving, and the jump to triple digits also only happens when moving.
Edited by Graysdir#1665 on 6/4/2012 1:20 PM PDT
Never posted here before, but i have the exact same problem.

ASUS EAH6850 (Radeon HD 6850)
AMD FX-6100 6-core @ 4.0ghz
8GB Corsair Vengence RAM
Windows 7

It does exactly what your YouTube video showed. I thought it was my system until I played other games like DiRT 3. Googled the problem and found this thread.

I have played with settings continuously, and can confirm that this is a problem on ATI cards as well.

It's a Blizzard problem, for sure.
Zhuge:
- Frame limit to 59 in-game
- Frame limit to 59 in EVGA Precision X app


This is redundant, try disabling the in-game FPS limiter by un-ticking the box next to it and only using EVGA's. The implementation in their software is far better and less buggy than the in-game one.

FrostShade:
I have vsync enable with nvidia inspector and tripple buffering as well.


The "Triple Buffering" in nvidia inspector and in the nvidia control panel *only* effect OpenGL games, which Diablo 3 is not. To properly get Triple Buffering in Diablo 3, you need to use D3DOverrider or another program that can properly force Direct 3D games to have Triple Buffering.

I have the exact same situation going on as the OP, and I suspect it's just how the game is. I havent seen anyone who runs Diablo 3 completely smooth, we have 3 copies in my house on 3 different computers. All have micro-stutter, which most people won't even notice, but those paying attention will. There is a laptop with this issue here, my desktop with a nvidia 8800GT, and my roommate has a nvidia 480GTX and all exhibit this same trait, just to varying degrees.

There is a post on the first page I put up about how I found the best possible configuration for my machine to minimize this micro-stutter, and it does involve forcing Triple Buffering as well as using an alternative to Blizzard's in-game FPS limiter. The stuttering for me no longer goes off in regular 2-3 second intervals when the screen is panning, so the backgrounds do appear to move smoother, but there are still times where it will chug for a split-second.. and honestly we have to expect this with an online-only, always-connected game. There is alot going on in the background and I don't ever expect the game to run completely smooth, unfortunately.

Good luck everyone.
Edited by Mordecai#1331 on 6/4/2012 2:45 PM PDT
Good post, Mordecai... although honestly I do expect far more from Blizzard. The stuttering/frame skipping is really bad on both my systems, and does not happen in any other game; online or not. Gamers cant be expected to run d3doverrider, precision, etc just to make it playable. This is likely a frame rendering issue... it almost looks like the frames are being repeated, or skipped. Its a very distinct "jerk" every few seconds when the camera pans. I think this is fixable, if they just have the right person look into it!

Played a bit of act 4 today, and between all of the frame skipping, plus the intentional screen-shake that Blizzard is so fond of, the game was just a frustrating, stuttery mess. Then I played Path of Exile, a very similar, always online game with (imho) more demanding graphics, and it was smooth as silk. There is no excuse for this, it needs to be fixed.
Edited by Graysdir#1665 on 6/4/2012 4:14 PM PDT
Posts: 6
Graysdir,

I've just tried what you asked me and indeed i see an occasional jumps to triple digits while running in town. Triple digits fps and camera stutter seems to be related. Well this is a good start.

:) I will continue to look into the problem.
80 Tauren Hunter
0
Posts: 85
Graysdir,

I've just tried what you asked me and indeed i see an occasional jumps to triple digits while running in town. Triple digits fps and camera stutter seems to be related. Well this is a good start.

:) I will continue to look into the problem.


It's caused by inaccurate v-sync.

I've found two ways of fixing it on my AMD gpu (may or may not help with NVidia cards):

1) Running in fullscreen windowed mode, Aero on, vsync on, frame rate limiter off. This helps because AERO provides it's own vsync routine that is more accurate. Aero gets disabled in fullscreen exclusive mode so that's why it has to be in fullscreen windowed.

OR

2) Running in fullscreen exclusive mode, vsync on, and using an external frame rate limiter program like MSI Afterburner and setting it to 60fps. Some people say 61 fps, but for me 60 fps was best. The external frame rate limiters work much much more reliably than the in-game frame rate limiter. There's likely something similar out there to MSI Afterburner for NVidia cards if that's what you have

Personally I prefer solution #2. The game runs and looks better in fullscreen exclusive mode, especially since you can actually control the gamma, whereas in windowed mode you are restricted to your desktop gamma (which is way too bright). Not to mention the Dark D3 shaders will only work in fullscreen exclusive as well.
Edited by MyKillK#1335 on 6/4/2012 5:34 PM PDT
Hi Graysdir, I am also experiencing the same issue as you. Everything is smooth when I stand still and there is lots of action on the screen. Once I start moving there is an intermittent stutter (character freezes for a micro second or two before continuing on its way). It is very distracting to the point that I'm trawling the forums looking for a fix! Wow runs smoothly on med-high on my system so why not this? :(

I'm posting my system specs in the hopes that Blizzard would be able to resolve this.

Dell Studio XPS 1647 - laptop
Windows 7 Home Edition (Ultimate?)
i5 M520 2.4GHz processor
4GB of RAM
500GB 7200RPM HDD
ATI Mobility Radeon HD 4670 - 1GB

Programs running in background (if this helps) - Avast! Antivirus
Posts: 6
Mykillk,

I have installed MSI Afterburner and set FPS limiter to 60. Now i have a steady 60fps in-game. That triple number fps bug is no more, BUT sadly, the problem is still there :( FPS isnt moving at all and camera stutter occur less often, but still happen.

Well that was a nice try! Lets keep it up.
This issue was brought up in the Beta bug report forums as well. A blue post in that thread said it would be fixed it the release build, obviously its not fixed and still effecting people.
Mykillk,

I have installed MSI Afterburner and set FPS limiter to 60. Now i have a steady 60fps in-game. That triple number fps bug is no more, BUT sadly, the problem is still there :( FPS isnt moving at all and camera stutter occur less often, but still happen.

Well that was a nice try! Lets keep it up.


play around with the number you lock it to in Afterburner. Try 58, 59 and 61 and see if you get more favorable results with any of those, as thats really the area you want to aim for.

Also see if correct triple buffering for D3D has a positive effect, using it alone with v-sync can net you up to 50% fps gain if you fall under 60 at any time as well.. I am still baffled that huge companies like Blizzard are too lazy to implement proper triple buffering in their games.
(deleting post)
Edited by Graysdir#1665 on 6/4/2012 8:49 PM PDT
Posts: 6
Mordecai,

Thanks for your suggestion, in fact i tried it all... and i still have no improvements. The problem is not about my fps "dropping" ... actually, it seem the game is running at more FPS than it is supposed to. Inaccurate v-sync happen when your game should be running at 60fps maximum and then having micro FPS burst. Now with MSI Afterburner Frame limiter, that burst doesnt seem to happen anymore in theory. But in-game the "camera stutter" still happen. I tried with 58-59-60-61 fps limit, vsync enable or not, forced triple buffering with D3DOverrider. No gain yet.

I feel like the problem is game-engine related. I remember back in the days when Starcraft 2 first come out "I hade 2x GTX 480 SLi back in time" and a similar problem was happening. When i was playing on a river map ( with water reflection on ) the camera stutter bug occured as well. If my memory is good, it took about 4 months for blizz to release a patch that solved this issue.

I just hope we can find a fix to this problem soon. Help us Blizz!!!
It must be a fairly common problem if all 3 PCs I have access to are afflicted with this exact same issue.

I spent a lot of time and money trying to fix this problem just so I can play Diablo, and will be a very disappointed fan if you don't even look into the problem.
I've had this since beta too. I get a single slow frame render every few seconds.

http://imgur.com/YcZu7

The resolution and frame rate limit I use doesn't make any difference. There are always frames that take an extra ~20ms to render. For example, limited to 20 FPS I'll see frames spike from ~50ms to ~70ms. Normally, with a limit of 60 FPS, even the slow frames render inside ~40ms.

I haven't tested anything thoroughly since beta, but I tried every possible fix under the sun back then (even some desperate things); ramdisk, affinity, sound, overclock GPU, underclock GPU, fresh OS, FPS limits, 160Hz CRT monitor, RAM timings, every nvidiaInspector setting on the planet, and many other things.

They just need to find the dev that blinks in sync with the slow frames in that graph I posted and review his code. Problem solved. Lol.
What are your system specs, Wesley?

I have to admit, I am only a few days away from removing this game from my system. Tried playing a bit today, and the stutter was so distracting that it wasnt fun at all.

At least if Blizzard would let us know they are working on it... but since this has been reported for 6 months, I can only assume that they dont care, or they cant fix it.
Try setting the CPU Affinity to 1 Core and turn off Hyperthreading.
http://www.addictivetips.com/windows-tips/how-to-set-processor-affinity-to-an-application-in-windows/

You can certainly leave Hyperthreading on but since you're limiting the process to 1 core the Hyperthreading will only server to slow that 1 core down. However hyperthreading is controlled by your BIOS so if you don't know how to turn HT off don't fight with it too much.

Also fix the frame rate to 90% of what your system is capable of. If you get 30fps set it to 24. If you get 100 set it to 90.

D3 has a problem like most games with Multicore. I suspect it's False Sharing, and any advantages to running it on multiple cores is being eaten away by the overhead it's causing.

Doing this will cause a few artifacts to appear in the Videos since the Video Decoder is optimized for multicore but the game is not.

This will stabilize your frame rate and if done properly then it will usually keep your frame rate constant or nearly constant.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]