Diablo® III

BUG: Frame Skipping / Camera Stutter

(Locked)

^^ Even if it works, it's nothing more than a lucky band-aid, it is not an acceptable solution. It is not worth trying.
lol.

This solution works perfectly for me, I have no more stuttering, and it's not worth trying?

I guess having Firefox in the background is too much for you.
Again, it's not a solution. It's a lucky side effect that does not address the problem in any way.

Workarounds are not acceptable. Proper software is.
Edited by Wyloch#1646 on 6/7/2012 12:46 PM PDT
Oh boy...

You call it what you want, but it does fix the problem, I don't really care what causes this, or if it will ever be solved. It's gone now, that's all that matters.

Ever played a game in which you had to edit a config file to change something because it wasn't in the option menu?

That's a fix, period.

Edit: If you're really too lazy to open Firefox, Teamspeak 3 also fixes the problem, you don't even have to connect to a server.
Edited by Euphytose#2269 on 6/7/2012 12:52 PM PDT
Euphytose:

"Well what you described is exactly what I had so... You might want to give it a try. "

I DID try it. On both systems. It didn't make any difference at all. I appreciate all suggestions, and was more than happy to try it... however this is a coding issue.
Edited by Graysdir#1665 on 6/7/2012 12:58 PM PDT
Oh boy...

You call it what you want, but it does fix the problem, I don't really care what causes this, or if it will ever be solved. It's gone now, that's all that matters.

Ever played a game in which you had to edit a config file to change something because it wasn't in the option menu?

That's a fix, period.


It does not fix the problem. It hides the problem. You have very low standards for your $60, and I have no problem with that. Glad you're satisfied.

I expect a polished, functioning product. This issue makes the game almost totally unplayable. The only possible problem that could affect playability worse than this issue would be excessive lag.

This is not a semantic argument, much as you'd try to make it one. This particular issue has to be forefront on the "must fix" list for 1.0.3. And if it is not addressed, we'll need to keep this thread alive and bumping to the top every day until they fix it.

I saw blue earlier in this thread, but it did not concretely acknowledge this particular issue, which as the OP stated is NOT related to disk seek or lag (or anything else, for that matter).
Edited by Wyloch#1646 on 6/7/2012 12:59 PM PDT
Then I don't know what you mean.

I do have some stuttering when the game loads assets, but after that it's really smooth.

I get the occasional rubber-banding effect but that's it.
Oh boy...

You call it what you want, but it does fix the problem, I don't really care what causes this, or if it will ever be solved. It's gone now, that's all that matters.

Ever played a game in which you had to edit a config file to change something because it wasn't in the option menu?

That's a fix, period.


It does not fix the problem. It hides the problem. You have very low standards for your $60, and I have no problem with that. Glad you're satisfied.

I expect a polished, functioning product. This issue makes the game almost totally unplayable. The only possible problem that could affect playability worse than this issue would be excessive lag.

This is not a semantic argument, much as you'd try to make it one. This particular issue has to be forefront on the "must fix" list for 1.0.3. And if it is not addressed, we'll need to keep this thread alive and bumping to the top every day until they fix it.

I saw blue earlier in this thread, but it did not concretely acknowledge this particular issue, which as the OP stated is NOT related to disk seek or lag (or anything else, for that matter).


But that's wrong, it does fix it.

If I wanted to change the FoV in Borderlands I had to create a script, so what? It gave me the FoV I wanted, problem solved, I even played 157 hours on this game.

If there were no way at all to solve it, yes, but that's not true. You want a perfect game? Fine.

Just a little tip though, in case you hadn't guessed yet: It doesn't exist, and never will.

" This issue makes the game almost totally unplayable. "

And please, constant 50 fps is perfectly playable. It's really annoying, and not enjoyable, but it's playable. What's not playable is a constant change in fps, going from 20 to 50 and vice versa for example.
Edited by Euphytose#2269 on 6/7/2012 1:05 PM PDT
UPDATE:

I tried on a FOURTH system today. I setup my HTPC with a velocirator 10k RPM hard drive, a fresh install of Windows 7 Home Premium, and an ATI RADEON card that I use to play Path of Exile with.

So I can now confirm with 100% certainty that this problem DEFINATELY occurs on Radeon cards. The stutter was absolutely identical to my other 2 computers that use nVidia cards. ALL of these systems exceed the recommended system requirements. (Heck, one of them is brand new, with a GTX680, 16GB RAM, SSD, etc!)

Path of Exile runs on my HTPC flawlessly. Smooth like butter.

Installed Diablo 3, and it is a jittery, stuttery mess. Running repeated laps around Tristram, it would stutter & jerk the screen every 2-3 seconds, exactly like it does on my main gaming rig, and exactly as it does on my GTX280 based system.

All 3 of these computers run all of my other games smoothly.

I have updated my original post to include these new details. Also, I did some testing last night, and something is definately occuring to cause these stutters.

My test: First I'd run around Tristram several times to make sure all assets were loaded. Then I would go to the Healer, and run towards the inn. Just before the inn, there are 2 NPCs standing there, and it almost always stutters a couple of times beside them, then a few times as I run around the bend where the Inn is, and then it's smooth all the way to Radek. Right past Radek I get 1-2 stutters, and then 1 more as I reach the cellar where Haedreg's wife was kept. The stutters are not in identical spots, but very close. I cannot see why that would be asset loading though; because all assets should be loaded by the 10th time I've ran past them. Perhaps there is still an issue there, though. Maybe assets are being re-loaded? The issue ONLY happens when the screen is panning. If I stand still, there can be 4 players spamming spells like mad, and my FPS stays high, and smooth. As soon as the camera pans, the screen "jerks" every 2-3 seconds.

In any event, clearly, after installing this game on 4 PCs, and seeing the identical frame skipping on all 4... and considering all 4 PCs play all other games smoothly; this is an engine issue and coders need to fix it.

I've had more than enough testing - *IF* someone is having this exact issue, there is nothing they can do to fix it on their own.

Grays
Euphy: Please stop arguing with people in this thread. I do not want it closed by a moderator. Your solution did *not* work for me. Your solution worked for you because you have a *different problem*. I tried your solution, it didn't work for me, I said thank you. There is nothing more to be said.
Edited by Graysdir#1665 on 6/7/2012 1:10 PM PDT
But I'm not arguing over whether or not it fixed your problem, I'm arguing with another guy who's saying he'd want the game to have everything perfected on launch day, which is impossible.

Anyway I'm out of this thread.
Edited by Euphytose#2269 on 6/7/2012 1:11 PM PDT
But that's wrong, it does fix it.

Fine. You're really not getting this, so fine. You're totally right.

If I wanted to change the FoV in Borderlands I had to create a script, so what? It gave me the FoV I wanted, problem solved, I even played 157 hours on this game.

Non-sequiter, has nothing to do with this conversation, and neither did your earlier example about changing a config file.

If there were no way at all to solve it, yes, but that's not true. You want a perfect game? Fine.
Just a little tip though, in case you hadn't guessed yet: It doesn't exist, and never will.

Never once said I did. Base functionality does not imply perfection.

" This issue makes the game almost totally unplayable. "
And please, constant 50 fps is perfectly playable. It's really annoying, and not enjoyable, but it's playable. What's not playable is a constant change in fps, going from 20 to 50 and vice versa for example.

Uh...have you even been reading? That is exactly what I am experiencing. Instantaneous changes in frame rate (<0.1 seconds) causing a stutter every 1-2 seconds.
Graysdir - For what it's worth, have you tried testing this in other areas? I only ask because, for some reason New Tristam seems to be the absolute worst with trying to get the game running smooth. I was doing the same thing you were (laps around New Tristam) and it actually made me nauseous. Eventually, I gave up trying to get everything smoothed out with all of the suggestions in this thread, and left town to play the game. While I still get the occasional triple digit spike, and what seems to be frame skipping, the game is infinitely smoother (for me) in areas like Graveyard, Cathedral, Cave of the Betrayer, etc. yet when I go to New Tristam, the first couple quests in A4, etc. the amount of frame skipping is ridiculous and rather consistent. I'm not even talking about with enemies on the screen or fighting them, just running through those areas. Also, I don't know when it happened, but some time during Act 1 in the past hour or two, my frame rate broke the "50" barrier and started consistently capping at 59-60. Regardless of that fact, whenever I returned to town, I still noticed the stutter.

If you can, try a few of those areas, or just brighter vs. darker in general, and see what you get. While I don't have a fix for the issue, I'm curious if you notice any changes either.

Oh, and I'm running a 1GB GTX 260m, for what it's worth, and no amount of graphical setting change, using EVGA Precision, or the nVidia control applet has helped me at all. It might also help to mention that my monitor is in 16:10 mode, rather than 16:9.
Edited by ShadowHado#1348 on 6/7/2012 2:26 PM PDT
Yes, it happens EVERYWHERE.

I noticed the same things as you though. It is worse in some areas. For me, any town is really bad, and almost all of act 3 and act 4 is so stuttery it gives me a headache. dungeons arent as bad... not sure why. It skill skips, and stutters, but nowhere near as bad as Tristram or Hidden Camp.

FWIW, I have 1920x1200 on one system, 1080p on another, and those are both 60hz monitors. I also have a 120hz monitor, but sonce that feature does not work in Diablo, I cannot test 120hz. (Diablo always forces me to 60fps even when it should lock at 120fps like other games do)
Edited by Graysdir#1665 on 6/7/2012 3:33 PM PDT
BTW - I mentioned I'm having this issue in Crossfire mode, just wanted to confirm that disabling Crossfire does not help.

Also, let's not confuse framerate issues with (micro-)stutter issues. Stutter occurs when the time between frames is irregular / too long due to bad engine or driver and it has a lot to do with how V-Sync is implemented and whether the OS / drivers work well with the game engine, how big the data that has to be transferred between cards in multi-GPU setups is (e.g. you can have no stutter on 1920, but that may change on 2560 due to the size of the frames), etc. It's complex. Theoretically, though, you can have stutter at 100 FPS - if the time between frames is > 16.7 ms your brain will be telling you the FPS is < 60. In my case I do get bouts of terrible stutter (not too often, thankfully) while at the same time RadeonPro (which probably measures FPS differently compared to the game) shows pretty much constant 60.
Without V-Sync the 6950 X-Fire goes up to 200-230 FPS. That would mean that the cards can process the frames very quickly and stutter shouldn't be an issue at all.

There is a very nice article on stutter on Tech Report - google 'inside the second'.

All of that said - I would bet good money that it's the V-Sync implementation in conjunction with the fore-/background FPS settings in the game that we're having a problem with. For one we're seeing the upper foreground FPS limit flash as an FPS value momentarily (which is when that game stutters, as we've established) even when the foreground setting is unchecked! Also, unless I'm imagining it, if you open your inventory quickly when that game starts stuttering it goes away. If that's confirmed we can pretty much start staring disapprovingly at Blizzard right away... ^^
Edited by ltkAlpha#2243 on 6/7/2012 3:46 PM PDT
+1 for fix.
80 Tauren Hunter
0
Radeon 6950 1gb Crossfire and I'm experiencing the exact same issue.

Fullscreen Windowed mode does not fix this in my case, if anything it makes it worse, as the FPS meter goes crazy a bit more often in my experience.

Forced DirectX Tripple Buffering via RadeonPro, it helps slightly, but the bouts of stuttering still occur.

Setting Flip Queue Size to 0 + Agressive API Detection + High Process Priority + Tripple Buffering has the effect of a) completely eliminating the worse periods of stutter, when probably half the frames get dropped, however it b) forces frames to get dropped regularly instead - when moving sideways you can almost count to it - 1, 2, 3, drop, 1, 2, 3, drop - regardless of what's being displayed on screen and where in the game you are - pretty much exactly like in the youtube videos the OP linked to. If you can live with this it's probably the most viable, or at least predictable, fix for AMD users (not sure whether Overrider has the same options), but it still annoys me...

P.S. Tested again and I don't think Tripple Buffering actually gets applied, with or without Agreesive API Detection


Triple Buffering is working for me using Radeon Pro

Radeon Pro + triple buffering (settable in Radeon Pro) + only 2 cores out of 4 affinity (settable in Radeon pro) + increase priority for executable (also settable in Radeon Pro) + MSI After Burner and set frame rate limiter in the After Burner service to 60 + disabling D3's in-game frame rate limiter + enable in-game vsync is the complete sum of things I've done to eliminate the vsync stutter on my AMD 5770. It's ridiculous to have to do so much, but it is what it is....

The MSI Afterburner frame rate limiter seems to be the most critical piece.
Edited by MyKillK#1335 on 6/7/2012 5:38 PM PDT
+1

Graysdir, Excellent post. I'm experiencing the exact same issue as well.

Q6600 Quad Core @ 2.40GHz
Windows 7 Ultimate 64 bit
4GB RAM
EVGA NVIDIA GeForce GTX 550 Ti (Have x2, tried SLI and not and it makes no difference)
Dell 2408WFP @ 1920x1200 32 bit 59/60Hz
Driver Version WHQL 8.17.13.142

Submitted a ticket before I found this thread. Blizz support closed it and I reopened after explaining that "No ... I didn't have too many apps running in the background."

:-/

I will point back to this post to help highlight the issue. Keep the faith.
+1 HD 6990 M
Thanks Brotality... Hopefully if enough people post, and bookmark the thread, we'll eventually see this issue resolved.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]