Diablo® III

Diablo 3 graphics/lag FIX!!! edit config inst

Guys, after tons of research and messing with settings I finally came across something that has really improved my diablo 3 fps. Its nothing major but its EASY, FAST, and it WORKS!!!!

You need to edit your diablo 3 config file. The location is for windows 7:

located in /Users/My Documents/Diablo III

Now there is alot of options, and i've tested them but do NOT change PreferencesVersion because you WILL CRASH.

With that being said here is the quick optimization: Scroll down thru your config file and find these 3 lines and make changes if necessary.

DisableTrilinearFiltering “1”

MaxForegroundFPS “60”

HardwareClass "2"
Now this one is "iffy" and you will have to choose what works best for your system. Personally I think it has to do with what version/directx its going to run. For instance 0 will make the game crash out and not load with a direct x number. I keep mine at 2. 1 seemed to speed it up, and 0 wont load.

Thats it!! I have a monster desktop with a radeon 6950 and a DV6 A8-3500m radeon 6620g laptop. My desktop screams thru the game but my laptop was jerking/stuttering all over the place.

I hope this helps someone. Please!!!! if either of these worked for you put down your VIDEO CARD MODEL and if it worked or not so we can help others.

Hopefully enough people see this and can squeeze enough performance out of diablo 3 to actually enjoy it. ALSO: If your system just seems laggy, dont fret turning down all the settings to LOW. To be honest you wont notice much but the shadows gone :)

Wrain


Hey dude i was hoping if you could help me out, i got spikes/lags while im playing D3 i didnt had them at the beginning dont actually know when and why they started.

I play on my laptop and this is my conf :

Processor - i3-2330m 2.2ghz
Memory - 4gb
Graphic - geforce 520m

Everything was perfect i was playing on high and stuff but i started to spike. I tried your settings helped a bit but still lags.
Edited by Lustt#2648 on 7/20/2012 5:30 PM PDT
Reply Quote
worked like a charm thanks a lot!

Nvidia GeForce GT650m
Reply Quote
it seems that my settings for hardware class keeps resetting every time i restart the client. is this normal?
Reply Quote
running this on an i7 2600k 3.5ghz, installed to SSD, using an overclocked radeon HD7970... game fricken lags... what a joke. will try these settings tonight
Reply Quote
So far this worked perfectly for me. I say so far because other settings have worked in the past and then its gotten laggy again but I tried this today and everything was pretty damn smooth. Thanks a million. I love this game but it was starting to get unplayable with all the lag and stuttering.

Intel core i3 530 2.92 ghz
Geforce gtx 550 ti

P.S.
To those who may be inexperienced as I am, what I had to do was copy that file in the same folder and rename the original doc something else. Otherwise the changes don't save.
Reply Quote
90 Pandaren Shaman
12410
Posts: 206
Didn't work for me, ill just play something different.

GTX 670 SC
Ivy 3570k 3.4
Reply Quote
86 Blood Elf Paladin
7015
Posts: 6
THis also worked for me aswell, im on a Laptop with Windows 7 and my card is

AMDM880G with ATI mobility - Radeaon HD 4250

Thanks again!
Reply Quote
Posts: 4
I get a decent framerate (around 50-70) on low settings. I have tried the fix with the non-in game settings except for the "iffy" one.. and gamer booster 3 but I still get lag. It's bizzare. Don't know what to do.
Reply Quote
Went from 5-50 FPS stuttering to 50 stable FPS after changing to hardwareclass 2 and set nvidia 550 ti as PhysX gpu default. Why the PhysX setting helps i have no idea. But FINALLY! it is playable and the gpu isnt constant overheated!

Very good tip!
Reply Quote
Yet another work around that did not work for me :(

http://us.battle.net/d3/en/forum/topic/6552145353
Reply Quote
Worked Great for me, usin an Nvidia GeForce 240M thx man!
Reply Quote
85 Blood Elf Paladin
8550
Posts: 21
This was not working for me UNTIL......

HardwareClass "5" <----- that worked.

Radeon HD7770 Ghz
Reply Quote
i7 6-core, 12GB RAM, dual GTX580, Win7/64.

This made things dramatically worse for me. On top of the usual lag deaths, got a lot of stuttering and tearing. I thought it was just WW Barbs but apparently it's everyone. Since it's been getting progressively worse, it feels like server capacity is being rolled BACK. Maybe the game is being cash-cowed at this point.

Good try, but users should not need to tweak all the systems settings. I get zero lag in WOW, POE, TL2, or any other application and at max graphics settings.
Edited by Rocketman#1372 on 9/18/2012 7:41 PM PDT
Reply Quote
Hey Wrain, I just wanna thank you because this really worked for me!
My gaming experiance just improved massively!

So yeah, Thanks man :D
Reply Quote
DisableTrilinearFiltering “1”

worked! thanks man!
:)
Reply Quote
worked like a charm.. i can finally join a game without being frozen for 30 seconds
Reply Quote
I just started playing and could not get past meeting Leah in the bar moving to level 2. following your fix finally got me going. Its not the first time I've had to go into the config files for a game but its not something I like to do. Lots of praises for people like you to help us through rough times. I am running 2 bridged gtx 260's. Again thank you.
Edited by blessed#1787 on 11/10/2012 9:10 PM PST
Reply Quote
thx for this post, helped a lot =)
Reply Quote
well, i cant find the config in my diablo 3 folder. Is it just called config??
Reply Quote
HD7700 graphis and did nothing for me
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]