Diablo® III

Diablo 3 graphics/lag FIX!!! edit config inst

I have an Intel 3770K, 16 gb Ram, and a GeForce GTX 670 on my desk top. During gameplay I can happily walk around with my barb with it winding up to over 100 fps. During multiplayer and with heaps of spells being cast, it lagged to the max and I had to lower the FPS to around 70.

Will try the above suggestions and see how it goes.

My Hardware Class was originally at 6??
Reply Quote
No joy here. Two GTX 580's in SLI. For those of you still having issues, it may be unrelated to some of the FPS issues others are having. In my case, I get severe lag EVERY time I move the mouse pointer. If I don't touch the mouse, I easily get 60FPS or higher at max settings. As soon as I start moving the mouse, that drops by 50 to 75%. Might want to check that. Be sure to enable the FPS display using CTRL + R in game. I've put this in a separate post here:

http://us.battle.net/d3/en/forum/topic/7163736370
Reply Quote
There is a thread for NVIDIA users somewhere. In the global settings turn on VSync to Adaptive and disable it in game. I will try it.
Reply Quote
90 Draenei Shaman
8470
This worked for me, using Radeon HD 6780
Reply Quote
It didn't totally fix the problem. It did help somewhat though :) I approve of this (sort of) fix! :D Also when I tried it I found my first legendary xD Horrible Pus Spitter but still the first one I have ever found :D

Edit. Forgot to mention. Using ATI Mobility Radeon HD 5470.
Edited by MessyAbyss#1731 on 11/25/2012 2:08 AM PST
Reply Quote
Helped with 99% of the problem. Must be something will trill filtering.

Nvidia MSI GTX 560 Ti
Reply Quote
Wow, thanks! Didn't eleminate but greatly improved.
ATI Mobility Radeon HD 4250
Game is now at least playable on multi player when everyone is spamming skills.
It used to be play, lag lag lag lag lag play lag lag lag lag lag lag
now it's more like play play play lag play play play lag.
Reply Quote
Hey, thanks for the info dude worked for me and my card is
ATI Radeon HD 4350
Hope everyone is enjoying the game.
Reply Quote
Hey it worked great for me thanks a lot!

blizzard isnt doing anything so great that you took time to find a fix!
Reply Quote
Since i bought this game ive never ran into any issues with it. run it all on high, any res i want, have multiple background applications, heck always had it on windowed mode while i watch youtube videos, but about a month ago i started having crazy lag out of nowhere, tried posting on tech forum, googled almost every day, tried soooo many different methods, and this one was perfect

i suggest anyone having issues out of nowhere ( not from the start of you playing-thats probably just because your connection or computer cant handle it imo) definently try this,

worked for me

EDIT: GeForce GTX 260M
Edited by PointBlank69#1460 on 1/13/2013 9:07 AM PST
Reply Quote
man thank you, this greatly improved my performance, kudos,
Reply Quote
I have been to the far depths of cyberspace and I have returned victorious!

Diablo 3 has been totally UNPLAYABLE since about patch 1.05. My latency sits around 250ms in town and when fighting normal monsters. As SOON as a rare/champion comes into range, I might as well just ALT-F4 is so bad. Being a Wizard with the little life I have, you can only imagine my frustration when I'm at the point I can't afford to repair my items!!!

I have finally conquered this beast! Installed Windows Server 2008 R2 64Bit, Awesome desktop OS! :P Under Disk Management, I created a MS VHD (Virtual Hard Drive), allocated 3GB of free space from each of my 6 Drives. I then published these drives onto the network using iSCSI Software Target. I installed Microsoft iSCSI Initiator and created a loopback for the drives. Having these drives now in Disk Management, I converted them to dynamic disks and then created a RAID 5 array from the "Published Virtual Network Drives". With a 15GB RAID array, Diablo 3 fitted perfectly :P Tested the transfer speeds, around 40mb/sec.

Straight up copy of D3 from my C: to the RAID and ran the game... NO LAG? ITS GONE ?!# IMPOSSIBLE ?!@#?@!?

Load the game from my C:..... LAG!?!? WTF ?!

Before u say, aaah crap hard drive etc...
This is my OS drive, my pagefile is split across 2 OTHER drives aswell:
Western Digital WD RE4 WD1003FBYX 1TB 7200 RPM 64MB Cache SATA 3.0Gb/s 3.5"

Explain ?#!@
Reply Quote
HardwareClass

Hardware Class for diablo 3 just turns on and off different special effects and or renders some special effects in a different way. Eg mage shield.
Reply Quote
90 Human Paladin
4380
no luck for me. still lagging in only during a full group of 3-4 people killing things. 1-2 i never lag. this lag didnt start for me till after the latest patch.

I play on a G74 ASUS laptop. graphics card is a Geforece GTX 560M 2GB have 8GB ram with 4GB on Readyboost through the SD Card slot.
Reply Quote
im suprised. im seeing results with this. good work thanks for the fix!
Reply Quote
thx, worked for me
core2 duo 7300 2ghz, 4gb ram, ati mobility radeon 3430 256mb
Reply Quote
Thanks a bunch bud worked great 71 fps M18x GeForce 560m 3.0g 8gig ram Intel core i-72630 @ 2.40Ghz
Reply Quote
HOLY MACARONI!!! <3<3<3<33<3<3<3<3<3<3<3<3 this is how one freaking post can change your entire game experience!!! You can't imagine how often I died to those fire explode !@#$ers in act 3 the keep depths 2 since it lagged like crazy!

THANKS SO MUCH! Have my childs dude! daaaaamn so stoked right now :))
Reply Quote
THANK YOU! For once, someone actually gives advice, unlike everyone else whose comments go something like this: turn down all the graphics, hurr durr.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]