Diablo® III

Crossfire and AMD Radeon HD 6990 (performance

Hi,

The page at http://us.battle.net/support/en/article/D3supportedvideo says "Diablo III does not support either SLI or Crossfire configurations". I have a radeon HD 6990 (dual GPU) card and catalyst 12.4 drivers. I'm not sure how to disable crossfire or check if crossfire is disabled. I can't easily find anything on google about it.

At the bottom of the "Gaming/3D Application Settings" page there's a section for AMD CrossFireX(tm) Mode for 3D Applications, but it has a large exclamation icon for warning saying "This setting applies only to user-defined application profiles." I can change it from the default "Default Mode" to "Disabled" (other modes are: "AFR Friendly, Optimize 1x1, Use AMD Pre-defined Profile"). However, this setting seems to get forgotten after reboot, and I'm not really sure it works or how to use application profiles.

I do experience severe framerate drops during fights in 4 player co-op. On max graphic settings, during heavy fights in Act 2, the framerate momentarily drops below even 10 FPS. Setting settings to lowest possible and disabling AA seems to help a little with it, but during very heavy fights the framerate still drops below 30 FPS. During normal "quiet" game play framerate stays constantly capped at 60 (VSync enabled).

I have a Phenom X6 1090 running 6 cores at 3.6GHz with 8GB of RAM running at 1600MHz and Windows 7. Catalyst 12.4 drivers for AMD Radeon HD 6990.

Also, is there a way to run some sort of timedemo to check performance? Having to gather up a 4 player party and get them in a fight every time I want to test a new driver/clock configuration is kinda cumbersome.

EDIT: looking at CPU usage graphs from task manager, it seems that the game isn't maxing out one core of the CPU.
Edited by goblin#1785 on 5/19/2012 4:05 AM PDT
Reply Quote
Ah, looks like crossfire might actually be enabled... In the Catalyst's systray icon, I selected "Show AMD CrossFireX(tm) Status Icon (where applicable)" - about the only CrossFire option that I could find. Now when I run Diablo III, I get an icon saying "AMD CrossFireX technology" in the top-right corner of the screen (overlaid on top of Diablo). Not really a status icon as it doesn't say if it's on or off, but my guess is "on".

How to disable it? How to check if it's disabled for good?
Reply Quote
I ran into the same problem as you. Until AMD release a Crossfire profile for D3, I use a program called RadeonPro, which makes it easy to disable Crossfire for single applications (click "add new profile", add D3, click on the "tweaks" tab, slide the "MVPUMode" bar to "turn off CrossfireX")

Hope this helps.
Reply Quote
@Goblin

I don't know why you have your CPU overclocked, but it is not necessary as the .04 difference is not enough to make a noticeable difference when playing games. Also it will produce a little more heat, Just keep it at the Default 3.2 and you'll be fine. I have the same CPU as you and only 4GB ram, but I have a Hybrid Phys-X system. Running 2 video Cards, an ATI 5830 by Gigabyte, and an Nvidia GTX 560 and everything is running at stock speeds and all games run medium to high graphics and I still get good gameplay.

Also you right Diablo III Doesn't tax any of the core's of the CPU to it's max.

To others reading this I thought I would throw this in the mix to let you know that I observed that Diablo III at least for me uses the Second and Third Core of the CPU more then the other ones.
Reply Quote
@MariusRogne, I've created a profile in AMD's drivers and I think I managed to disable crossfire for diablo3 with it, but the framerate crippled. It was much worse than with crossfire enabled, so I re-enabled it.

@DarkAngel I have my CPU overclocked for various reasons. I normally get a huge FPS rate in the game, usually capped to 60 because of vsync. However, during big fights especially in Act 3 with lots of monsters and 4 players casting their spells, the framerate often drops below 10, which is quite unplayable. Friend with an i7 clocked at 4.7GHz and some Nvidia card also reported this problem.

My system is way over blizzard's recommended specs, and yet the game still slows down below playable framerates during big fights (which is when the framerate is really needed). Hope this gets fixed.
Reply Quote
Having similar issues. Game runs great for most part even in some full groups but if we have a wizard or two casting blizzard or large AOE spells then the game drops down to unplayable level. I've tried fps fixes floating around and have latest drivers etc. Everything is running at stock speeds.

Intel i7-2600k
AMD 6990
8 gigs of ram

Tuning down all graphic options/disabling crossfire has no effect. Curious if anyone found a solution for this yet?
Reply Quote
This was new to me??? I have been using crossfired 6870's since launch with no issues and have experimented with disabling crossfire to see how the cards scale with the game and I do in deed double my framerate with crossfire enabled.

I don't use Vsync however and have the foreground FPS cap unchecked because it's wacked. I run a 120hz monitor so I just spend all my extra FPS on eye-candy effects in CCC to get it near 120 FPS.

No screen tearing if you can get it close.
Reply Quote
i have a lenovo z575 notebook that is amd a6 3400+hd6650m crossfire x
when i play with this notebook i found the wizard armor effect is very simple
than any single display card

and i can't find a way to make it normal
i try to make it just run the 6520g display also same but frame is slower
this notebook can run on 1366x768 50~60frame/sec

do any one found this problem ?
Reply Quote
The post now actually says:

SLI and Crossfire (Multiple Graphics Cards)
Diablo III is designed to be compatible with Crossfire and SLI setups. Be advised however that multiple-GPU systems have additional variables that can affect game performance. If you encounter performance issues with Diablo III, try temporarily disabling SLI/Crossfire as part of your troubleshooting.

But, to disable Crossfire:

Close Diablo. Open up Catalyst Control Center. Find the section for creating Application Profiles. Create one, selecting the Diablo3.exe - careful here, do not select the Launcher.exe. Towards the bottom is a drop down for Crossfire modes and disabling it is one of the options there. Save - may get a warning that a profile already exists - just select to continue saving the user defined one. Save, apply, reboot for good measure.
Reply Quote

I don't use Vsync however and have the foreground FPS cap unchecked because it's wacked. I run a 120hz monitor so I just spend all my extra FPS on eye-candy effects in CCC to get it near 120 FPS.


Try this. During beta the max foreground FPS toggle was causing trouble with some high-end AMD cards. Not sure if it's still happening since I unchecked it right away after the game launched. It was giving my 6970 problems. Once I unchecked max foreground FPS all my problems went away.
Reply Quote
Customer Support
I have a very similar rig (2x6970) and am able to utilize CrossfireX without issue. As others have noted, we do now support CrossfireX and SLI, although we recommend disabling them when doing troubleshooting.

I've found the best way to determine if CrossfireX is running correctly is by looking at GPU usage, but I rely on a 3rd party program to graph that information. It's also important to note a commonly encountered restriction of CrossfireX: it only works in Fullscreen (NOT Windowed Fullscreen).
Reply Quote
need ur advice... i'm currently running the following, and gets random freeze in Crossfire mode. even with the lastest AMD driver and profile installed.

My PC config, no overclocking done.

AMD 1090T
Asus M4A89GTD Pro mobo
Powercolor PCS+ HD5850 X 2
LG IPS236 monitor
AX850 PSU

pls let me know the best display setting possible, thanks
Edited by Dynaway#6220 on 2/16/2013 10:36 PM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]