Diablo® III

"You have been removed..." Error 316704

(Locked)

92 Human Paladin
7025
Posts: 14
Works for me too. Thanks!
Works for me

only
"setarch i386 -3" before "wine Diablo\ 3.exe" is necessary, the rest of the options are optional
any progress for ppl running windows?
I believe my wife's mac has a similar issue, but it just doesn't get disconnected. The prior sysmptoms the Mac started out playing just fine then a few min in the frame rate dropps to a crawl. I believe it's the same issue, Warden trying to do the impossible and eating up all the processor power to do it.
Cross-posting command that fixed things for me...

setarch i386 -3 -L -B -R wine ~/path/to/Diablo\ III.exe


I have a laptop and desktop. Each have a partition running 64-bit Ubuntu 12.04 and a partition running 64 bit Windows 7. Each linux partion has both a patched 1.5.3 install and a seperate playonlinux install. Both Windows partitions have an install.

All of my linux installs have had the exact same problems as everyone else. Both of my Windows installs have not had any of these problems, so clearly the problem is in wine only.

I did try the setarch fix and this did nothing for me. I can log in, but i get disconnected after about 30 secs.

EDIT: I take it back, this seems to be working for my patched wine 1.5.3 version. It must have just been a fluke or legit network drop the first time i tried it...

It would help to see what build people use when it started working for them.
Edited by bitzero#1679 on 6/7/2012 8:09 AM PDT
Please keep all LINUX related issues in the LINUX issues thread:

http://us.battle.net/d3/en/forum/topic/5592457019

Thank you.
I stopped checking this thread about the time when everyone thought the maintenance fixed things, so I didn't know the problems were back so quickly. It looks like there is a fix now in the setarch command, which I'll try on my 64 bit system, but I just wanted to confirm that 32 bit Ubuntu 12.04 was working for me (which is also why I didn't know the problems were back so quickly). If the setarch command isn't helping for some people, maybe a real 32 bit installation would still work.
- Technical Support
Posts: 2,047
View profile
for anyone using PlayOnLinux, found this in their forums

neptoess:

Alright, a little background. Here's my hardware:
MSI GT725-075US:
-C2D P9500 (2.53 GHz Dual-Core)
-4 GB RAM
-ATi Mobility HD 4850

Software:
-Fedora 17 XFCE Spin x86_64
-XFCE 4.10
-Xorg 1.11.4
-Catalyst 12.4

Anyone who wants to know how to get 12.4 working under Fedora 17 can check my wiki entry on cchtml.

Here's how I got it working:
-Install via PlayOnLinux
--This installed fine, but then crashed upon clicking Play
--I solved this by:
---Opening a terminal
---export WINEPREFIX=$HOME/.PlayOnLinux/wineprefix/DiabloIII
---winetricks --no-isolate vcrun2008
--To fix graphical glitches in the game:
---Set DirectDrawRenderer to gdi under PlayOnLinux's Configure->Display
---I also use Fullscreen, NOT Fullscreen Windowed
---If I see graphical glitches on the login screen, I change to windowed fullscreen but click cancel when it asks if I want to keep the settings
-After the latest patch, I couldn't get past authenticating credentials
--Open a terminal
--setarch i386 -3 playonlinux
--To make it simpler, I just edited my DiabloIII.desktop file and prepended
setarch i386 -3 to the Exec= line

Everything works perfectly now!


And happily that setarch thing inside the DiabloIII.desktop file has also DRAMATICALLY improved performance generally. It screams now as it would if I were running it in windows on this machine (dual quad-core xeon X5355, GTX 260, 20GB ram, RAID5 filesystem)
06/07/2012 09:16 AMPosted by hal8999
And happily that setarch thing inside the DiabloIII.desktop file has also DRAMATICALLY improved performance generally. It screams now as it would if I were running it in windows on this machine (dual quad-core xeon X5355, GTX 260, 20GB ram, RAID5 filesystem)


Indeed I too have seen a slight performance increase, also it isn´t much being that i´m running with a NVIDIA Geforce 210 :|.
- Technical Support
Posts: 2,047
View profile
Sounds like it's time to up your video card ;)
Please keep all LINUX related issues in the LINUX issues thread:

http://us.battle.net/d3/en/forum/topic/5592457019

Thank you.


Send all Windows issues intended for this thread to DancingBear's inbox
Edited by WAY2QUIK#1751 on 6/7/2012 11:16 AM PDT
Same error for me.

Archlinux, catalyst, wine 1.5.5 patched

Works fine until today :/
Edited by dcarol#2473 on 6/7/2012 1:26 PM PDT
Same error for me.

Archlinux, catalyst, wine 1.5.5 patched

Works fine until today :/


Follow the solution here: http://us.battle.net/d3/en/forum/topic/5592457019?page=1
100 Draenei Shaman
8070
Posts: 6
If anyone is still having problems using the setarch command i found that i had to kill the wineserver since i had already attempted to login as soon as i turned my computer on.

terminal:
top
kill PID# (for wineserver)

hope this helps. Thanks to whoever figured out the setarch!
06/07/2012 09:16 AMPosted by hal8999
And happily that setarch thing inside the DiabloIII.desktop file has also DRAMATICALLY improved performance generally. It screams now as it would if I were running it in windows on this machine (dual quad-core xeon X5355, GTX 260, 20GB ram, RAID5 filesystem)


Yessss, this finally got me back in business as well. Thanks!
I can confirm this is working fine for me on Ubuntu 10.04 64bit. I run Diablo 3 with Play on Linux at the moment and I launch it from a shell as I'm a command line junky. I'm using:

setarch i386 -3 playonlinux ~/.path/to/Diablo\ III\ Launcher.exe

With my CPU affinity set to 1 core of my CPU I'm finding good performance without this error or any large spikes in FPS/CPU use. My Windows 7 64bit install works 100% fine, which makes me curious as to what Warden and WINE exchange in information to have Warden think that we're boting or what have you and be kicked out. Is there something that needs tweaking with WINE to report proper details to Warden?

A side note, I'm not sure if this would help given the memory issue mention for 64 arch types vs 32, would this performance enhancement be worth it?

http://us.battle.net/d3/en/forum/topic/5235703994?page=6#109
http://us.battle.net/d3/en/forum/topic/5235703994?page=7#134
Seems to be fixed with Playonliux and wine package 1.5.5-DiabloIII_v3
I'm glad that this is working for people, but I'm not as, uh, computer-literate as many of you seem to be. Does this fix work for Windows machines too, or only Linux? If it does work for Windows, could someone explain how to actually do it, or is it too complicated to start from the beginning? I'm getting really tired of playing 2 minutes at a time and getting nowhere, and Blizz being useless in fixing it.
06/08/2012 08:22 AMPosted by Aquaticko
I'm glad that this is working for people, but I'm not as, uh, computer-literate as many of you seem to be. Does this fix work for Windows machines too, or only Linux? If it does work for Windows, could someone explain how to actually do it, or is it too complicated to start from the beginning? I'm getting really tired of playing 2 minutes at a time and getting nowhere, and Blizz being useless in fixing it.


The workaround is specific to Linux; I'm not aware of any equivalent for Windows. I'd be interested in finding out whether your issue is indeed related to what we encountered. If it's affecting Windows users too, then I'm sure Blizzard's dev team would appreciate the troubleshooting legwork we've done here.

1) What version of Windows are you running? Is it 32-bit or 64-bit?
2) Walk us through what's happening to you. You start up Diablo III, and then what happens? The more detail the better.

If your symptoms match ours, I'd like to walk you through a few diagnostics to confirm.
I'm having the same issue on Mac. It's miserable.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]