Diablo® III

"You have been removed..." Error 316704

(Locked)

90 Tauren Druid
0
Posts: 472
I hope this is not some sort of anti-hack hotfix which is going to hurt play on Wine...
Posts: 2
Yeah I'm getting the same thing.

wine-1.5.5
Same story. Patched Wine-1.5.5 git://github.com/simcop2387/wine-diablo3.git. It was OK just yesterday.
Same problem. Patched WINE 1.5.4.
I just started receiving these errors tonight.

INSANELY ANNOYING when trying to farm inferno.

I have been reading and accumulating data through these posts and it seems to me that this is either a server side connection issue, or a flaw in the coding of D3.

Seem's REALLY fishy that it all of the sudden just 'starts' happening out of seemingly nowhere.

Now i'm not one to flame or anything, but the lack of Blue posts on this is rather annoying. However something happened tonight that caused this to happen to many, many people, so atleast we have some...

progress...

Anyway, I really hope they figure out what the hell is going on with those servers. The disconnections are making this unplayable!
Edited by archbrisingr#1707 on 6/5/2012 1:58 AM PDT
Posts: 5
Same thing happening over here, worked flawlessly for a week and now i can't play for more than five minutes without getting a "You have been removed from the game" message, extremely irritating. I invited a friend to my game and the same thing started to happen to him and he is on Windows 7. Am running through wine 1.5.4 on openSUSE 12.1.
Same thing here. Everything worked fine the last time I played. I log in today, and I get kicked out of my game within a few minutes. Any attempt to return to my game gets me "Error 316704. There was an error creating the game." If I try to switch characters or exit the game, it hangs and I have to kill the process. My profile is empty, and the profiles of my friends are unavailable "Error 300005. There was an error retrieving the player's hero profiles." I have no problems logging on to, creating characters on, and playing on the European realm. Just the Americas one. I am using Ubuntu + Wine and the game has been running just fine up to now.
Happened to me yesterday on W7, not on linux.
European servers are OK
Just bought the game last night and have had this issue non-stop. Using wine.

Edit: Just tried Euro servers. Not only did the problem stop, but the game actually runs smoothly now. I thought my computer couldn't handle the graphics, but it seems it was strictly a network issue. Weird.
Edited by miluda#1996 on 6/5/2012 4:01 AM PDT
Glad it's not just me :)
90 Blood Elf Paladin
10055
Posts: 10
Same problem word for word. Ran normally, then all of a sudden yesterday I got the "removed from game" error. Couldn't make a new game, couldn't select a different character or server. Has happened about 5-6 times.

Ubuntu 12.04, wine-1.5.5

edit: wine is unpatched
Edited by jellognome#1352 on 6/5/2012 5:31 AM PDT
Posts: 4
Same here. 64-bit Ubuntu 12.04 + crossover's Wine 1.4. Was working fine yesterday. Now this is happening every 15 minutes or so, randomly. /proc/sys/kernel/yama/ptrace_scope is 0.

Edit: I just tried the asian servers, and having no problems there.

PS: I play hardcore..
Edited by Ruien#1753 on 6/5/2012 6:41 AM PDT
Posts: 94
Same experience here. I am running Ubuntu 12.04 LTS Wine 1.5.5 and the game is no longer working even though it was fine the day before. I log in and start playing and within a minute or so the game gets ridiculously choppy and frame rates that are normally 40 - 80 drop to 8 - 11. Occasionally the game would recover and run well again, but most of the time after the game got choppy, I would get booted off and get the same error. Checking stats returned a not found error and switching Heroes would freeze. As others have experienced the game will not exit. It must be forced in the system monitor.

Haven't tried running on another server yet. Will try tonight. Seems really strange that the American servers have run so poorly compared to all the others. Almost seems like its intentional. I wonder if this is the "fix" they have implemented to help alleviate the underestimated connection capabilities. If so, I am not pleased.

What's going on Blizzard?!

PS Anyone on Ubuntu/Linux not having this problem? Anyone on the US servers?
Started happening to me tonight.
Disclaimer: I'm playing on Ubuntu 12.04 with an up-to-date WINE (1.5.5) in Win7 mode. The problem with closing D3 might just be for me?


I am playing on debian sid + WINE, was wondering if this was some strange client issue that is popping up in wine. Are any of the others who are getting this error in windows?

Yes I to have to completely kill diablo and reload it to get anything to work once what ever bug hits.


I'm with you. On gentoo linux and this error started at some point after yesterday morning and is persisting into today.
Diablo seems to work fully well on the other servers. It's the Americas server that keeps prompting the error to occur. It's probably some server problem. I'll wait until the next server restart/maintenance or patch and it should hopefully clear up by then. Bad idea to have a main char on that server :( hehe. Ubuntu 12.04 LTs wine 1.5.5 as well but it seems to be happening across windows and mac esp in the other forum threads so I don't think it's an OS problem.
Edited by Bubbles#6562 on 6/5/2012 5:29 AM PDT
I'm another wine user experiencing the same problem. The game was fine for several hours yesterday, but today I get about 5 minutes before being kicked out of my game back to the character screen. I'm using xubuntu 12.04 with wine 1.5.5, unpatched. Other internet traffic is fine and I also had no problems when switching to the European D3 servers.
92 Human Paladin
7025
Posts: 9
Same issue, Wine 1.5.5 Ubuntu Precise. Can't enter a game after that.

Issue only happened today, some signs of it happening include games slowing down before getting booted. Within 5 minutes of game play each time.

Upon encountering such issues, the game client will not exit cleanly.

Internet connectivity : Singnet
Edited by HolyJade#1643 on 6/5/2012 10:28 AM PDT
same thing here.

created a post here as well.

http://us.battle.net/d3/en/forum/topic/5642267300
Posts: 23
hey i'm was one of the first few posters on this, but since everybody else has volunteered it i may as well also note that i'm playing under wine on linux.

however, just like all the other posters have said, everything had been working up until this problem started and no changes were made on our end.

i can also confirm, playing on EU servers works fine (if not better than americas ever has)

oddly enough though, when i play on my roommates computer, running windows 7, but on the same network / behind the same router & firewall, that i CAN stay in a game -- albeit it suffers horribly (frame rate drops to 2-3 fps) anytime there's a single monster on screen, and it's not the graphics card or system -- runs in EU just fine w/ intense fights and lots of commotion.

wtf blizzard?
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]