Diablo® III

"You have been removed..." Error 316704

(Locked)

Getting alot of these lately after patch
This the first time i get this error...never before the patch :( Experiencing some unusual lag spikes and then it seems to disc me.
I'm seeing a lot of "me too" posts on this thread, with little to no information that would be helpful in troubleshooting. Here are my assumptions going forward:

  • There is a bug which is disconnecting players within ~5 minutes of logging in
  • It is affecting a small minority of players
  • Blizzard is unaware of, or is unable to reproduce the issue in their test lab


There are many possible reasons to experience disconnection problems, many of them user-side. To rule that out, and to identify patterns that would help Blizzard reproduce the problem, we need concrete information. If you think you're affected by this, reply to the thread with the following information:

* Operating system (e.g. Windows 7)?
* 32-bit or 64-bit?
* Graphics card?
* Processor?
* RAM?
* Which realm are you connecting to (America/Europe/Asia)?
* Does it happen in other realms? If so, which?
* Can you authenticate successfully?
* How long can you stay logged in before getting disconnected?
* Does this happen every time you log in?
* When did it start happening?
* If you are in a game, does it kick you out? If so, what error message is displayed?
* After you are disconnected, does it send you the login screen, or to the main menu (start/resume game, change quest, etc.)?
* If it sends you to the main menu, do any of the menu options work (Start/Resume Game, Change Quest, Switch Hero, Logout, Exit Game)? If not, what error message is displayed?
* What happens if you log in, but don't join a game? Do you get disconnected, or do the menu options stop working after some amount of time? If so, what error message is displayed?
* Is the disconnection accompanied by an abrupt increase in CPU usage by Diablo III or any other system process?
Posts: 2
This would all go away if blizzard would just let people like me (who like to play solo) PLAY OFFLINE! I have no issues logging on until I do it during 8-9 pm at night...when alot of people want to log on...this is not a user related issue, it's a "our servers suck" issue. If Blizzard ever wants Diablo 4 or SC3 to be succesful, they better damn well pay attention to this and FIX IT!
Macbook Air,Mac OS 10.7.3,Intel Core i5 1.6G Hz, 4G Ram, this error has been happenning for one week. Disconnection wll make application dead and forceful quit.

Another is Windows 7 Home Edition,32 bit,Intel Core i3 2.5G Hz, Nvdia Gforce GT 425M, has the same problems.

with both can login successfully.
I am so unbelievably fed up with this..... 17/06 and this is still not resolved. i can only play the same room so many times before i jam my laptop shut. Im playing ACT 2 Hell and trying to find Kuels body.... i progress through the RANDOMLY GENERATED room and with in 3 minutes i will notice im running but my Templar isn't following me... then boom "Error 316704". Might i point out there is nothing wrong with my internet connection as im trolling right now trying to seek a remedy for this BullS*!#. lets try and start the game again... wait up still getting error 316704.... might have to make a coffee and wait for the Diablo Client to fix itself before trying again. day after day after day. Blizzard you inherited this error when you took out offline play... all i want to do is play solo i couldnt care less about the achievments and medals but now im stuck with a screen that looks at my character and thats it... i don't get logged out of my account i only get booted from my game. poor Kuels body is going to be lost forever

I am playing on a Automobili Lamborghini Asus running 64 bit Windows Ultimate with 16 gig ram and 3 gig dedicated NVIDIA
Edited by Laingsta#6756 on 6/17/2012 6:34 AM PDT
I get this all the time now also, . I don't experience this with any other game, including Battlefield 3 and Starcraft 2. I had this problem in the beginning right after launch, then it was fine - up until latest patch in June.

I am running Windows 64 bit, with pimp enough PC to run all on max. I turned off all firewalls and all torrent traffic, and nothing else is running on the network. Im running constant pings towards US websites, and not a single packet was lost.

If Blizzard can't reproduce this error in a lab, contact me and you can remote control my machine and run any test you like. I doubt that will ever happen, as it seems Blizzard are nowhere to be seen in forum threads talking about actual problems.
Gnurkel or Laingsta,

Would either of you be able/willing to install Wireshark (www.wireshark.org), use it to capture the network transactions of a game that errors out, and email me the output?

Both of you are running 64-bit windows, and I'm trying to confirm whether some 64-bit windows may be running into the same issue that 64-bit linux users encountered. (If it's the same thing, we have some valuable troubleshooting information that would help Blizzard resolve this issue.)

Let me know, and I'll provide instructions. You can reply here, or contact me at my gmail address (same username as here.)
same same same.
Alright, here goes nothing: I have this problem as well but i may have come up with a work-around for it. this is for windows users.. i don't know about Linux or Mac's sorry, your screwed i guess...

Windows XP/Vista/7 x86 AND x64: Goal - stop the retarded server from kicking you (I believe based upon keep alive response times and DNS resolution.) so basically if you are behind a firewall that stops blizzard from obtaining your computer's name, Mac address, etc. the network shuts down and kicks you. (this happens due to certificate and "mal-formed" packets sent by blizzard that get mangled along the way). To attempt to resolve this issue i took the following steps: (This will not work on a domain or business network, you will no longer be able to share or remote into computers on your own network)

1.) open network settings/network center and choose "change adapter settings"
2.) right click on your network adapter (your internet connection) and click properties.
3.) in the resulting window make sure the following items are unchecked
QoS Packet scheduler
internet protocol version 6 (TCP/IPv6)
4.) select: Internet Protocol Version 4 (TCP/IPv4); right click and choose properties.
5.) in the window that appears click the radio button next to "Use the following DNS server Addresses:
6.) Fill-in the squares as follows:
Preferred DNS server: 8.8.8.8
Alternative DNS server: 8.8.4.4
(these are google's public DNS servers and allow for a better and quicker connection to battle.net)
7.) apply and ok to all windows to close them out as necessary. then proceed below.

Windows XP: click start> run > type cmd into the box and hit run
Windows Vista/7: click start type cmd in search when command prompt or cmd appears right click and hit "run as administrator"

>at the command prompt type the following:
ipconfig /flushdns
ipconfig /registerdns

> close the window (you may restart for good measure if you wish but it is not required.

These steps help to minimize problems in network connectivity due to a Firewall or Router that cannot handle corrupted packets. because we channel the DNS configuration through Google you will receive "corrected" packets through their DNS addresses. Post back if you still have problems and i will continue to monitor the issues, you may also PM me if you wish.
06/18/2012 01:50 PMPosted by Kalzin
Alright, here goes nothing: I have this problem as well but i may have come up with a work-around for it. this is for windows users.. i don't know about Linux or Mac's sorry, your screwed i guess...


Actually, we Linux users found a workaround a couple weeks ago, and the game has been running flawlessly ever since. In our case, it was an issue with the anti-cheat code. I'd be very curious to find out if the same issue is affecting Windows users as well.

If it turns out your workarounds aren't successful, see my previous posts (#383 and #388), and contact me by email if you're willing/able to run some diagnostics.
Anybody still having this problem (disconnections within ~5 minutes of logging in, every single time) after the 1.0.3 patch, or did the problem magically go away?

Based on past experience, things start working immediately after a patch/maintenance, but stop working later in the evening (after roughly 5-6PM Pacific time.) So test now, then test again later, and report back here!

I'm currently running 64-bit Linux without the workaround, and things are working fine for now.
I have had connection issues with Diablo III (ERRORs ranging from 3003, 300008 to 316704). I tried everything ranging from firewall tweaking to port forwarding on ZyXel P-660HN-F1Z ADSL modem/router. Then, I said "let's try one more thing". Doubtful, I switched my wireless from "b/g/n" mode to "b/g" mode and voila! everthing is working again.

I don't know what changes are applied to wireless N mode so it would make some games including Diablo III cannot connect but it is a serious fault, in my opinion, as far as gamers are considered.

Just wanted to give you guys a heads-up about a possible solution on the issue.
I am running 64 bit Ubuntu 10.04. Looking at achievements the last usable game I played was around June 2 when I hit level 40. I usually got failed to join game 300008. The game played in slow motion when I could create a game. The game would freeze when I tried to exit. My messages in chat would not show up. My Social list would be empty even though people could see me. The slow motion made it where the game was completely unplayable.
setarch i386 -3
Fixed it for me. The game is back to what it was.
Hadn't played in a while after getting tired of grinding Inferno. Logged in this evening after DLing the patch. Played for about 3 min before this error halted my attempts. Pretty much sums up my D3 experience thus far.

Maybe I'll try again in a few more months.
90 Human Warrior
8005
Posts: 8
I also have been having this issue and amazingly enough for the lenght this thread is there's no bluepost by Blizzard... about this problem...
They are happy to throw the problem to us and say it's a problem on our end and loose players. Apparently whoever is monitoring these threads is not caring about this one.

Don't tell me it's my problem when I can play any other internet game out there in the world without connection issues even Wow!!!
Edited by Primme#1698 on 8/22/2012 10:02 AM PDT
This started to happen after the patch. Nothing has changed on my end, haven't install or uninstall anything.
Sigh - sad to say I am in the same boat. I got tired of getting 5 stacks and then booted.
i get that too and im on win xp. game been running crappy for a while too even at lowest gfx (and i could run it at max before)
86 Blood Elf Mage
6420
Posts: 3
This is happening to me. i just downloaded it and went to go play, picked my toon and got in and 3 seconds latter it did it to me and know i cant join back in.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]