Diablo® III

"You have been removed..." Error 316704

(Locked)

Posts: 2
Yet another "me too"
well, warden or not, i paid for 3 (keys), 2 dvd's and 1 network install (1 copy mine, 1 wife, 1 kid), and should be able to play it on the 1 desktop or the 2 laptops i own that run win XP or Vista regardless and all those systems meet the requirements listed on the box from gamestop.

then why am i forced to play this in linux?

just blows... i feel cheated no warden here at home except for the wife.
Edited by drblackross#1303 on 6/5/2012 6:31 PM PDT
Posts: 10
I fear that Blizz is triggering something really subtle in Wine in an effort to smoke out bot programs that are spamming for goldsellers. it's a real shame that the game is held hostage to stuff like this. I know there will be a fix eventually, but it's pretty frustrating being a second-class citizen like this. I've been playing Blizzard games under wine for years, Diablo 2, Warcraft 3 and expansion, Starcraft and Starcraft 2, Wow, and now this one, and I know I'm not the only one who's been a very loyal customer and a bit of an evangelist for a company that makes very good games that almost always work under wine. Here's hoping they'll figure out a workaround sooner rather than later.
06/05/2012 05:15 PMPosted by Smoolak
All the problems you have since yesterday are due to Warden (Blizzard anti-cheat), yesterday Blizzard triggered a file called "scan.dll", which is loaded through the interface of Warden. At that exact same time all the people on linux started to have problems with D3. It's not a coincidence.


Assuming this is true and coincides with the start of the issues, one *possibility* is: Upon joining a game, the server issues a warden challenge; running under wine, the diablo3 client thread responsible for running the scan gets stuck, therefore unable to respond to the warden challenge. Because it's stuck on "scan.dll", it's unable to respond to subsequent heartbeat packets (because they're queued up behind the warden challenge.)

Of course, that's just guessing, but it's very plausible that warden is involved in this.
Exactly the same symptoms here... Frame rate tanks over a few minutes... then Removed from game... then Error 316704.

One thing I noticed in capturing packets between my host and d3 bnet hosts, is that the traffic level is 2-3 times what it was yesterday, and once the "Removed from game" happens, there is NO communication, zip... both streams are FIN (which probably explains the Error 316704... you aint connected anymore so you can't do !@#$.)

This has to be one of the worst game launches in recent memory. How apropos it nearly coincided with one of the worst IPOs ever (FB)... baaahahahah
Yet another "me too" with Ubuntu 12.04 and PlayOnLinux (Wine 1.5.4 patched). Worked fine the evening of June 3rd and hasn't worked since at least the evening of the 4th EST.
Same issues as stated.
a me to post. I was able to play all day yesterday till 12pm central. Then this morning 9:00 am I ran into this error. I am running KUbuntu 4.8.3 wine 1.5.5 with AcceptEx patches through GIT. My guess is a security hotfix from Blizzard Entertainment.
Posts: 10
Same issue here, but just one correction I wanted to make to keep the record straight. If you wait another five minutes or so after attempting to exit, the game WILL close successfully (Agent.exe stays, however). This is perhaps a logical extension to the speculation in voltara's Bugzilla post that the client might be waiting to hear a response from the server to some "logout" signal---it just takes awhile before it times out and closes anyway.

And just a point when watching WINE console debug output: the place you need to be watching is not when the disconnect happens, but when that "keepalive" packet is received. Being removed from the game is---from the program's perspective, obviously---absolutely correct working behavior. A WINEDEBUG=trace output at the exact moment of the unacknowledged packet receipt would be most enlightening, but I know how painful those are to collect.
Posts: 3
Same problem here on gnome this have start yesterday when i heard they start a anti bot call warden cant play since then. Hope they fix it soon for all the linux lover out here :D euro server work find i dont think they got the anti cheat using POL whit wine patched 1.5.5 diablo v2 was working since the launch...
Posts: 7
If it really is a Warden triggering a scan.dll thing, then I would have hoped there would be some debug output from wine when it happens, I haven't seen any output from wine indicating any sort of error. Because scan.dll would have to still make the normal win32 api calls to do anything in Windows or depend on other libraries.

It is possible that the error is in the scan.dll's logic based on some win32 or other library calls return value or side effect from those library calls being different in wine due to the system setup in wine in which case I guess it is even harder to debug because I doubt they will tell anything about what scan.dll is really doing.
85 Blood Elf Priest
3560
Posts: 6
I'm trying to confirm i'm hitting the same issue by looking at a tcpdump, but I don't seem to see the 20 second keep alive packet that is being sent at all. Perhaps I am following the wrong stream.

In my output, I see a ping every ~10 seconds, followed by a couple of extra packets at the end followed by a FIN issued from the bnet server. or perhaps i'm reading the output wrong all together.

http://pastebin.com/uEs0BwLL

in any case, each time i log into the game, i last around 180 seconds before i'm removed.
Edited by wNz#1499 on 6/5/2012 6:56 PM PDT
85 Worgen Mage
2230
Posts: 1
I have been a faithful blizzard customer for years. I have used wine for every game they produce and I have never had problems until now. Why does this to the community have to suffer? if you are worried about hacks and exploits via wine release a linux client. I would love to see a linux client hell even a ubuntu only client would be a great step. Sure its not prefect but at least it could be something. With all the work you put into this game do we not deserve to have an enjoyable experience with it as well? I find it hard to believe wow, sc2, diablo 3 all run on windows servers? Why if you choose *nix to run your back end games do you not allow a *nix client? I know your no longer Blizzard but some activision monstrosity but please listen to your user base of faithful linux users.
Thank you to those posting debugs, logs and captures. please continue to do so and post your findings here as well as the wine bug report here: http://bugs.winehq.org/show_bug.cgi?id=30849
Edited by DancingBear#1791 on 6/5/2012 6:56 PM PDT
i hate you blizzed
Posts: 7
Looking at the log from the bug report

http://bugs.winehq.org/show_bug.cgi?id=30849

and log

http://bugs.winehq.org/attachment.cgi?id=40402

listing I wonder if it has anything to do with

err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail

where they are using ssl to connect back for warden purposes. Not sure though. I am not really very familiar with wine code base.
Posts: 10
Looking at the log from the bug report

http://bugs.winehq.org/show_bug.cgi?id=30849

and log

http://bugs.winehq.org/attachment.cgi?id=40402

listing I wonder if it has anything to do with

err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail

where they are using ssl to connect back for warden purposes. Not sure though. I am not really very familiar with wine code base.


That error is pretty ubiquitous in every WINE program. Good idea, but unlikely the issue in this case, sorry to say.
Same here. Running Arch Linux 64-bit. Wine 1.5.5 (no custom patches). Was working fine for me since 2 days after launch until June 4, 2012. Same issues as everyone else, play for up to 5 minutes at a time then "removed form game". Have to kill the client and restart before I can play again. Already added comments to the bug at winehq:

http://bugs.winehq.org/show_bug.cgi?id=30849
Posts: 7
Been getting the same issue all day. Running patched 1.5 wine under PlayOnLinux on Gentoo. I had played 20 hours previously with no issues and I get no issues in SC2.

In fact, immediately after connecting I have obviously lost a connection. I can maybe connect to other chat channels, but I can't seem to talk and my friends are not receiving my messages. Given that I can communicate to Battle.net in SC2 (in unpatched 1.5 wine) without any issues, I suspect this is a Diablo specific issue.

It does eventually time out when I try to log out, but I don't believe it took 5 minutes.
Posts: 7
Actually, when I try to log back in after failing to play a game and logging out, it thinks I'm still logged in and just hangs for a while.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]