Diablo® III

Problem with my Diablo II Installation.

(Locked)

85 Night Elf Warrior
5835
Posts: 4,107
Hello! I recently aquired the Collectors Edition of Diablo 3 and it came with a nice little trinket that housed Diablo II.

Now, I followed the instructions and installed both Diablo II and LoD but I've hit a snag.

Whenever I try to launch the game, I get an error message. It says:

Error 1: Diablo II is unable to proceed. Please run D2VidTst and try again.

What should I do? I don't know what a D2VidTst is......Diablo 2 Video Test?
Yes it is the Diablo 2 Video Test. Run that and the game should run.
85 Night Elf Warrior
5835
Posts: 4,107
05/21/2012 12:45 PMPosted by Kraze
Yes it is the Diablo 2 Video Test. Run that and the game should run.

Where do I go to do that?
Start -> All Programs -> Diablo II - Diablo II Vid Test
My buddy is having this exact same problem, but the vid test is not fixing it. any other ideas?
Right click on Diablo 2 shortcut under Compatibility tab check Run this program in compatibility mode for Window xp service pack 2; Check disable visual theme; Check disable desktop composition; Check disable display scaling on high DPI setting; check run this program as an Administrator.
90 Dwarf Shaman
5500
Posts: 2
Says My Computer Cannot Run Diablo 2... Why not
Diablo 2 is a classic . I think it's even 16 bit. Newer operating systems don't like that .

Try changing the colors to 256 mode by right clicking > properties > computability > 256 mode and also select 640 resolution.
90 Dwarf Shaman
5500
Posts: 2
I'm having the same problem. None of the above solutions helped. Also updated all related drivers... completely stumped right now. Please help!
I'm not sure then.. Have you guys tried downloading the patch for Diablo 2 off of blizzards website before launching? Try that
Had to troubleshoot the vidtest itself. All of the other stuff now works.
Edited by Ganymedes#1439 on 9/13/2013 6:23 PM PDT
How did you fix the vid test? I am having the same problem.
I am also haveing this problem, please help!
I'm also having this same problem on windows 8.1...

I tried messing around with compatability and colours etc but no dice.

Also my vidtst doesn't even seem to want to run at all...

If anyone has a solution please post step-by-step, thanks!
85 Undead Priest
1470
Posts: 1
I have Windows 8.1 updated fully as of this date.

I had the same problem described above and d2vidtst was not working but I did get it to work. Here is how...

1. Follow everything Warblade said.
12/30/2012 02:08 AMPosted by Warblade
Right click on Diablo 2 shortcut under Compatibility tab check Run this program in compatibility mode for Window xp service pack 2; Check disable visual theme; Check disable desktop composition; Check disable display scaling on high DPI setting; check run this program as an Administrator.

2. Right click on D2VidTst
3. Click 'Troubleshoot Compatibility'
4. When the box comes up click 'Try Recommended Settings'
5. It should then pop up again saying you should run D2VidTst in compatibility mode with Windows Vista (Service Pack 2). Click on 'Test the program...'
6. Another pop up comes up. Click on 'Run Test'. The screen with run through a few things testing out your graphics card and drivers. Let it run its course.
7. Then it will have a pop up describing your video card and options to choose. Make sure the best one is checked, preferably one that says 'Direct3D' and not' DirectDraw 2D' and click 'Ok'.
8. Then it will ask 'Troubleshooting is completed. Is the problem fixed?'. Click 'Yes, save these settings for this program'.
9. You have finished. It should tell you its fixed and good to go. Click 'Close' or 'Close the Troubleshooter'
10. Run Diablo 2 and have a blast.
Posts: 1
02/20/2014 12:08 PMPosted by Atickd
I have Windows 8.1 updated fully as of this date.

I had the same problem described above and d2vidtst was not working but I did get it to work. Here is how...

1. Follow everything Warblade said.
12/30/2012 02:08 AMPosted by Warblade
Right click on Diablo 2 shortcut under Compatibility tab check Run this program in compatibility mode for Window xp service pack 2; Check disable visual theme; Check disable desktop composition; Check disable display scaling on high DPI setting; check run this program as an Administrator.

2. Right click on D2VidTst
3. Click 'Troubleshoot Compatibility'
4. When the box comes up click 'Try Recommended Settings'
5. It should then pop up again saying you should run D2VidTst in compatibility mode with Windows Vista (Service Pack 2). Click on 'Test the program...'
6. Another pop up comes up. Click on 'Run Test'. The screen with run through a few things testing out your graphics card and drivers. Let it run its course.
7. Then it will have a pop up describing your video card and options to choose. Make sure the best one is checked, preferably one that says 'Direct3D' and not' DirectDraw 2D' and click 'Ok'.
8. Then it will ask 'Troubleshooting is completed. Is the problem fixed?'. Click 'Yes, save these settings for this program'.
9. You have finished. It should tell you its fixed and good to go. Click 'Close' or 'Close the Troubleshooter'
10. Run Diablo 2 and have a blast.


I got all the way to the first half of step 10, then as it launched it then went into a poor resolution window with the alert saying "UNHANDLED EXCEPTION: ACCESS_VIOLATION {c0000005)" and once I hit ok, it just closes it back down, I did manage to run the D2VidTst with the above instructions and still nothing, been bashing my head on the wall for a while to make D2 work on my pc, and I know the rig can support it lol.

Any additional advice that could help?
Edited by pwner0fn00bs#1316 on 3/29/2014 10:03 PM PDT
I got all the way to the first half of step 10, then as it launched it then went into a poor resolution window with the alert saying "UNHANDLED EXCEPTION: ACCESS_VIOLATION {c0000005)" and once I hit ok, it just closes it back down, I did manage to run the D2VidTst with the above instructions and still nothing, been bashing my head on the wall for a while to make D2 work on my pc, and I know the rig can support it lol.

Any additional advice that could help?


I was having that problem too, but when I used the 2D instead of 3D, it started working fine.
best way to play d2 is with a glide wrapper.

Go here:
http://www.svenswrapper.de/english/

unzip the files in your d2 directory.
run vid test > select glide.

This will emulate a 3DFX voodoo card, and D2 will run allot better, and look better too.
You can even enhance some settings like resolution ( it will stretch to your desktop resolution)
And also gives much better performance then D3D or DDraw ever did.
Because this wrapper uses OpenGL it still works, and DDraw and D3D from the Windows 98 era might give some problems on Windows 8.1.
Edited by Phroster#2174 on 5/5/2014 7:16 AM PDT
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]