Diablo® III

How to fix patch looping - Aussies

i'm sorry but no. I did this and it went back to doing the same thing after changing it back.
Reply Quote
this might sound like a silly question, but when all you guys say 'it worked' do you mean the patch update worked.. or the patch update worked and your in playing the game right now as we speak?
Reply Quote
It's a good question. I used the fix and my game is now saying it's version 1.02 but I'm still looping
Reply Quote
ReiJin's method worked
Reply Quote
OK my bad, the fix that worked the other day no longer works, and neither does the OP's (created two new files...)
Reply Quote
It doesn't work for me. I am still getting that silly patch loop. =(
Reply Quote
Works! Thanks :D
Reply Quote
I tried it and got the corrupted file message also. Didnt think of just moving the file and now Im re-installing luckily it doesnt take to long.

I'll try the language thing if I have the same issue.
Reply Quote
bleh tried this trick twice, did both the monkey magic forum dudes tricks aswell...

update bar comes up, dls 100% but yeh when the menu screen comes up its ver. 9749 and not the new one.

after you guys claim 'its worked' is it actually the new patch? or have you guys gotten past the 100% bar and just gotten stuck?

IS ANYONE FROM AUSTRALIA ACTUALLY PLAYING RIGHT NOW? o_O
Reply Quote
Worked for me, updated and able to play the game.

Thanks for doing Blizzard's job for them.
Reply Quote
Thanks Reijin. followed your instruction and it done the job smile
Edited by Toothferry#1855 on 5/31/2012 6:04 PM PDT
Reply Quote
Did not work for me.
Reply Quote
I've just got it to work by renaming the .agentdb.

Was: .agent.db
Now: ren.agent.db

and it worked a treat (which is weird, I was hoping it would say "can't find file, downloading another")
Reply Quote
90 Orc Shaman
0
Thanks ReiJin, worked a treat.

For thos still having trouble make sure you open the file in wordpad and save after the changes!. Also the first and last instance of http://enUS.patch.battle.net:1119/patch were correct for me, with the middle entry about halfway down the page reading as http://enEU.patch.battle.net:1119/patch which i changed to US.
Reply Quote
You're all welcome.

In regards to anything I've done, and does it work so I can play?

I have an Aussie version of D3, Collectors Edition. Bought it from EB. Play on the US servers.

The changes I listed are the only changes I've made.

I am currently in game and able to play with my level 44 Demon Hunter.

If it didn't work for you, I'm sorry, but it worked for me and others. If you need more help, I'd suggest sending an official request to Blizzard.
Reply Quote
85 Undead Death Knight
2580
Got it working! For those of you who still struggle: after you changed the Agent.db file, save it, and then, DO NOT start your game from desktop, start it from the windows menu and it will work!
Reply Quote
just got mine working.
game refused to update when opening through steam (non-steam game). changed the enSG's to enUS's, etc. opened through the actual game .exe, and it updated.
Reply Quote
Patch downloaded and now playing again. TYVM
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]