Diablo® III

How to fix patch looping - Aussies

that worked thx :)
Reply Quote
I just waited 1 hour and the patch came time to play
Reply Quote
http://blizzard.vo.llnwd.net/o16/content/d3-pod-retail/NA/8370.direct/Updates/d3-0-9558-Win-final.MPQ

http://blizzard.vo.llnwd.net/o16/content/d3-pod-retail/NA/8370.direct/Updates/d3-0-9749-Win-final.MPQ

Download these two files, place them in your "C:\Program Files (x86)\Diablo III\Updates" folder replacing the other two update files already there. This should manually update your client, if you installed correctly there really shouldn't be any reason to edit your agent.db file (Unless the version sold in stores defaulted to the wrong region. :\ )
Reply Quote
Posts: 185
theres a much much easier fix for the people who cant follow the stops above or just dont want to.

http://us.battle.net/d3/en/forum/topic/5596252061


This worked for me after trying all the other fixes, probably the easiest way to fix it, thanks!
Reply Quote
Thanks to you, now I can play.
Reply Quote
Posts: 157
Anyone else having this problem again with new patch?

I'm not sure what to do about it (my SG was already changed to US in those thread values) :/
Edited by EMT#6206 on 6/6/2012 8:40 AM PDT
Reply Quote
Blue qoute from tech forum

The 1.0.2b patch has not actually been released yet. We'll release it soon, and in time for this morning's conclusion of the server maintenance at 11 am Pacific time. Thanks for your patience and understanding!

We'll keep you up to date in this sticky:

Scheduled Maintenance - June 6

http://us.battle.net/d3/en/forum/topic/5573705607
________________________________________________
Support Information
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Posts: 157
thanks
Reply Quote
90 Goblin Warlock
6160
Posts: 113
when i go to log in it says there is a patch available exiting game to auto update bla blah then when it closes the current game to the launcher it says Diablo 3 is allready running and closes

help please?

ps just got home from work... there a shutdown or somthing?
Edited by DrFunk#1214 on 6/6/2012 9:13 AM PDT
Reply Quote
Mine is still stuck in the loop. Any ideas/news to when this will stop?
Reply Quote
Worked for me, thank you!
Reply Quote
THIS WORKS!!! MUACKSSSSSSSS
Reply Quote
i add to switch my game to america to get the patcvh how stupid they are wtf
Reply Quote
85 Blood Elf Paladin
7045
Posts: 2
Worked for me too thank you!!!
Reply Quote
This only worked for me when I did the following (I'm a Mac user)
Opened text edit
Opened agent.db file in text edit (searched for it)
Changed the 3 urls as mentioned at the beginning of this post to include "US" instead.
Saved and exited.
Then I opened the battle.net folder from spotlight.
I opened the agent folder.
Then i deleted everything in that folder excluding the agent.db file

Finally it works!!!
Goodluck!
Reply Quote
Posts: 1
Worked for me - thank you!
Reply Quote
wow~~2.64GB to download@@
Reply Quote
worked for me

be sure you only alter the component with the full path e.g
http://enSG.patch.battle.net:1119/patch to
http://enUS.patch.battle.net:1119/patch

enSG appears a number of times without the full path leave these as they are if you change them then the patch will not work for some reason

the best way to do this is copy the above line and use replace in wordpad
Reply Quote
Change language to spanish.. it loads automatically.... easy as
Reply Quote
85 Blood Elf Mage
8590
Posts: 2
Just changed the language in the game (before log gin on) and its now finally downloading the patch. Thank you AresHelix! no stupid patch agent file stuff.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]