Diablo® III

How to fix patch looping - Aussies

So changing the language seems to do the trick i guess but still reading alot of loop problems servers still not up or is it just "us" aussies?
Reply Quote
Thanks EndlezCoffee, changing the language worked for me, downloading now.

EDIT - allowed me to download the patch but as others have said, once changed language back to English to play got caught up in the loop again :(
Edited by Hypatia#6769 on 7/11/2012 6:07 AM PDT
Reply Quote
changing the language doesnt work man, tried it before. You will download the patch, but once you switch back to ENGLISH, same problem loops again
Reply Quote
90 Tauren Hunter
5650
Posts: 1
If you go into the agent.db file, you can change a few keystrokes so that it will update for you.

You'll find the file here...
Win7 & Vista is in C:\ProgramData\Battle.net\Agent
WinXP is in C:\Documents and Settings\All Users\Application Data\Battle.net\Agent

Just type that link into your Internet Browser and select the Agent database file, then open it with wordpad.You'll be looking for the following sequence:
http://enSG.patch.battle.net:1119/patch

Change it to:
http://enUS.patch.battle.net:1119/patch

There will be three instances of it, you need to update all of them.


thank you so much, i have been looking everywhere on forums trying to fix my error 740.
did this and worked first time. thank you
Reply Quote
start your game go to options change language, to anything but english it will restart and download new patch then change language back to english . TADA!!!!!
Reply Quote
nice...it's now updating....
Reply Quote
help, where to find this agent.db file? i had chg to enUS.patch.battle.net:1119/patch...pls help
Reply Quote
where i canfind this ? WinXP is in C:\Documents and Settings\All Users\Application Data\Battle.net\Agent
Reply Quote
WTF is the patch really 2gb...sounds really absurd. (change language method).
Reply Quote
Guys, had chg the agent files, but still can't play..pls help
Reply Quote
The language switch method DOESN'T work. I think what you are downloading using this method are the language files, not the patch itself. Trying to log in through both the different language AND back in English doesn't fix the problem.

GG Blizzard.
Reply Quote
How do I change the language back to English, whenever I run Diablo 3 now it goes to the patcher and the language is now in Spanish.

Edit: Solved by uninstalling Diablo 3 and following http://us.battle.net/d3/en/forum/topic/5870687669
Edited by aNOOBis#6232 on 7/11/2012 8:38 AM PDT
Reply Quote
Reijin you are LEGEND wait for it DARY. Blizzard needs to pick up their slack, kind of ridiculous that we have to things like this with an automatic downloader. If they want us to do things manually just make it that we have to patch manually and remove the automatic downloader -.-
Reply Quote
I am having this problem, and I tried to fix itwith the info up top. But still looping....any ideas?
Reply Quote
MVP - Diablo III
Posts: 8,051
View profile
08/22/2012 08:25 PMPosted by LadyKisargi
I am having this problem, and I tried to fix itwith the info up top. But still looping....any ideas?


This thread is abit out of date, but the info still stands, if you modified all 3 instances of the patch server to enUS and it still isn't working there is something more too it, you could download the enUS client and that will fix it if you have the quota.

You can see the current thread here with info on the patch loop and info on fixing it: http://us.battle.net/d3/en/forum/topic/6368568732
Reply Quote
hi im still having trouble with installing the new patch im on windows 7
Reply Quote
MVP - Diablo III
Posts: 8,051
View profile
08/23/2012 01:21 AMPosted by scudfish
hi im still having trouble with installing the new patch im on windows 7


1. Open the file C:\ProgramData\Battle.net\Agent\agent.db (in wordpad)
2. Change all references of http://enSG.patch.battle.net:1119/patch to http://enUS.patch.battle.net:1119/patch (there is 3 of them, then save and close)
3. Run game client

This will fix it.
Reply Quote
It doesn't fix if you want to play on the Asian server.

After editing all three occurrences of http://enUS.patch.battle.net:1119/patch,
then trying the language change fix and downloading an unacceptable 2.6 gigabytes of patch, it still wont let me log into the asian server, then re-installing the game on my PC, I give up. If it isn't fixed soon, Blizzard is going to lose a heck of a lot of Aussie customers.

A shame: a promising game... it was.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]