Diablo® III

Extreme graphical lag after patch 1.02

Same issue here
i7 920
nvidia geforce 590 gtx
12gb ram
Same with me, im getting bad lag, when before patch all was ok... can't even play its so bad!!!
Same here... My laptop is not that fast but it did run the game fine until the patch :( I am so sad because i can no longer play and I am about to email Blizzard for my money back.

GT 335 M no longer runs the game...

WE ARE BETA TESTERS !!!!!!!!!!!!!!!!!!!!!
Stuck at 15 fps on high, all low settings 25 fps
40-60C

Specs
  • i7 2600k @ 4.5ghz
  • 16 gb 1600mhz ddr3 ram
  • Geforce 580 gtx
  • **Update**
    Fixed!
  • Go to your Documents folder.
  • My path on Windows 7 looks like this C:\Users\Username\Documents
  • Find the Diablo 3 folder and open D3Prefs.txt.
  • Find HardwareClass (line 39) and change the value to “1″.


  • Think this works for most ppl
    Edited by gnuhest#2112 on 6/6/2012 4:14 PM PDT
    Refund on the way! See you guys in Torchlight 2!
    Posts: 63
    Why hasn't Blizzard addressed this?
    Posts: 20
    @gnuhest didnt work for me
    90 Orc Shaman
    0
    Posts: 13
    same problem here, game was running 100% correctly yesterday. i try to play today and there horrible graphical lag, its just unplayable. i have a gtx 460with updated drivers. i dont know what's blizzard doing , but they are doing it wrong
    Posts: 213
    I try everything i can try bu nothing works for me...
    what a joke...
    The game started lagging really bad for me today also. It was fine until today.

    I have nvidia gts 450
    Posts: 213
    Blizzard ytou !@#$ed up a game that nobody could have failed more then you! It's impossible that a game like diablo will be the worst game of the years just because of all the error that appear every times you try to fix one...failllll

    Sorry, but i feel better now!
    Posts: 213
    It's getting wost and worst...
    90 Blood Elf Mage
    11790
    Posts: 3

    After that, let's try doing a quick soft reset of D3 itself. Navigate to your Documents -> there should be a D3 folder here -> delete the folder itself. Next:

    - Go to your Control Panel -> Folder Options -> View tab -> Advanced Settings -> Hidden Files/Folders -> Show Hidden all.
    - From there navigate to your C drive (from something like Computer/My Computer). A new folder called ProgramData should appear
    - There should be a Battle.net folder in here, delete it

    Try reloading D3 and see if the game gets any smoother =). The game should overall recreate a few folders/files on load up which is normal.


    Try this guys.
    85 Draenei Priest
    3320
    Posts: 260
    GTX 560 Ti with old drivers (295.73) and im having no issues.
    Posts: 238
    to the people this hasn't worked for, that sucks but for anyone else try running older videocard drivers. fixed my problem.

    using 295.73 nvidia drivers for my GTX470 with no issues.
    Edited by Systemtrend#1438 on 6/6/2012 4:54 PM PDT

    After that, let's try doing a quick soft reset of D3 itself. Navigate to your Documents -> there should be a D3 folder here -> delete the folder itself. Next:

    - Go to your Control Panel -> Folder Options -> View tab -> Advanced Settings -> Hidden Files/Folders -> Show Hidden all.
    - From there navigate to your C drive (from something like Computer/My Computer). A new folder called ProgramData should appear
    - There should be a Battle.net folder in here, delete it

    Try reloading D3 and see if the game gets any smoother =). The game should overall recreate a few folders/files on load up which is normal.


    Try this guys.


    Will this affect any in-game thing. (Character, progress, account, etc.)
    I have a GTX570HD Video card

    And when i patched the game and started it up, it was getting stuck at 12 FPS...

    Here is what I did -

    Deleted the Documents > Diablo III Folder
    Deleted the ProgramData > Blizzard Entertainment & Battle.net Folders
    Deleted the Temp Folder that is found in the Users > ProfileName > AppData > Local > Temp

    (something else i did because it kept showing up, not sure if it was related but I went to services and disabled the "Adobe Acrobat Update Service")

    and then RESTARTED THE COMPUTER - IMPORTANT - when you do changes RESTART UR COMPUTER!

    Hope this may help someone!

    Regards,
    DaOpa @ twitch.tv/daopa
    Edited by DaOpa#1137 on 6/6/2012 5:15 PM PDT
    80 Worgen Warrior
    0
    Posts: 1
    I have a GTX570HD Video card

    And when i patched the game and started it up, it was getting stuck at 12 FPS...

    Here is what I did -

    Deleted the Documents > Diablo III Folder
    Deleted the ProgramData > Blizzard Entertainment & Battle.net Folders
    Deleted the Temp Folder that is found in the Users > ProfileName > AppData > Local > Temp

    (something else i did because it kept showing up, not sure if it was related but I went to services and disabled the "Adobe Acrobat Update Service")

    and then RESTARTED THE COMPUTER - IMPORTANT - when you do changes RESTART UR COMPUTER!

    Hope this may help someone!

    Regards,
    DaOpa @ twitch.tv/daopa


    Worked for me, must do the reboot.
    http://forums.nvidia.com/index.php?s=0530e4ae7963504a78d13b0c57500b29&showtopic=229953&st=240&p=1415519&#entry1415519

    There is a bug in all 3xx Driver from Nvidia for overclocked Chips, whitch reduces the core clock. Maybe this is the main problem. If Diablo 3 stutters, try GPU-Z or any other monitoring tool and check the sensor stats.
    This topic has reached its post limit. You may no longer post or reply to posts for this topic.

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)

    Reported!

    [Close]