Diablo® III

"patch required" problem

(Locked)

last night, I had this problem as they clumsily patched NA. I was able to play in EU this morning (NA time), BUT, I get home this evening, and what to my surprise, there is ANOTHER patch...I am able to play my NA account, but getting this stupid loop when I try to play my EU account. Apparently, blizzard says they are AWARE of NA players trying to play on EU servers and getting this garbage TWO DAYS AGO, but they seem to be doing very much about it.

I am not being dramatic here; Blizzard, get your act together or I am getting my 60$ back and never buying your products again.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Diablo III.exe
Application Version: 1.0.2.9858
Application Timestamp: 4fbecbcb
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.17725
Fault Module Timestamp: 4ec49b8f
Exception Code: c0000005
Exception Offset: 000222b2
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: c2a8
Additional Information 2: c2a8c718731fef45c93d04acf896c02f
Additional Information 3: 46aa
Additional Information 4: 46aad5e624085cf44bbef005f357d7e7


This is 100% due to the fact that Blizzard staggers their patching among the regions. EU servers don't have the 9858 build on them yet, so your 9858 client can't be played there until Blizzard updates it. I agree that this system is an epic failure for anyone who plays on a server outside the region they live in. Blizzard probably just doesn't give a damn because the % of people who do that is relatively low.


oh great now we have to wait for them to update the server? well might as well go sign my willl and stuff..i'll more then likely be dead before they update it might take eons..lol (joking)
same problem
Using The Americas and South Asia

but in Europe it says connection error only. ggrrr....
100 Draenei Shaman
12465
Posts: 48
I'm having the same issue. I did read somewhere the other day that people in Australia who have downloaded the game have the launcher set to Europe servers even though they may have selected Americas for the game. I'm trying to find where I can re-download the launcher without the rest of the game.
Same issue here guys, I installed teh new patch last night and it worked, 12hrs alter game not working
05/31/2012 05:01 PMPosted by Myranne
I'm having the same issue. I did read somewhere the other day that people in Australia who have downloaded the game have the launcher set to Europe servers even though they may have selected Americas for the game. I'm trying to find where I can re-download the launcher without the rest of the game.


im american on EU and im having the same problem..so it's anybody who's playing on a server that's not where they live.
Posts: 7
You must edit your Agent.db file within C:/programdata/battle.net for the patch to apply. I play on enUS servers and I still needed to edit this file. Ctrl+F and insure that all the lines reading "http://enUS.patch.battle.net:1119/patch" begin with enUS, there were 3 lines in mine and one of them began with enGB, changed it and the patch is now applied. Hope this helps.
Posts: 17
Same!!!! Can't play the game... again! At first it was the horrible disconnects, then the retarded account locks for days and now this crapp... grrrr Blizzard
Honestly....you would think....after 11 years (but who's counting) and billions of dollars from the end-user from previous blizzard games.......they could actually hire staff to fix this. Maybe Blizzard doesn't really value what our hard earned dollars are supporting. I don't know about the gaming marketing/sales scenario, but when I endorse a product, I want that to be completely optimal with quick solutions.......instead of pushing a product out that's going to make you fall flat on your face....yet again Blizzard. How many games/complaints/excuses does it take to listen to your targetted consumer and to do things right? It seriously isn't an issue of money or technology and there are plenty of people skilled enough in the world that are looking for work to hire appropriately. We aren't talking about splitting the atom, or something projected into half a million sales......millions. Where is this money going? Why isn't it getting any better? Why are we waiting an hour on the Blizzard phone support lines?

I'm not complaining or even considering the slander scenario, just asking a very simple question....when is it going to get better? I am tired of the band-aid fix-its that come into play. My time is just as precious as everyone else's and when I have time to sit down and relax, I don't want something that isn't available when I want it. Would we all drive cars that only worked when somebody else got around to it? I wouldn't buy it. I want something reliable and there when i need it, I also understand that it needs maintenance once in awhile to keep it running smoothly.......not just a "Fix for now" solution. Blizzard, you are costing me time and money. Take our money and just get the job done already. Clear direction.......HANDLE IT!
05/31/2012 05:03 PMPosted by Nuka
You must edit your Agent.db file within C:/programdata/battle.net for the patch to apply. I play on enUS servers and I still needed to edit this file. Ctrl+F and insure that all the lines reading "http://enUS.patch.battle.net:1119/patch" begin with enUS, there were 3 lines in mine and one of them began with enGB, changed it and the patch is now applied. Hope this helps.


nope just gonna wait it out.lol,too much work -yawns-
http://us.battle.net/d3/en/forum/topic/5152415037?page=1 fixed bru
Hi,

I had the same problem but I was able to have it fixed. However I am from Australia but I play on The Americas Servers.

Anyone having the same issue where it tells you to that the game needs a patch and restarts but says its up to date instead will find this very helpful.

go to
1. C:\ProgramData\Battle.net\Agent

2. then open agent.db file with note pad

3. replace http://ensg.patch.battle.net:1119/patch with http://enus.patch.battle.net:1119/patch

there should be only 3 to replace.

hope this helps some of you.


It patched after doing this. Great job you're a genius!
LOL looks like im not the only one...this is BS
100 Blood Elf Paladin
15810
Posts: 27
This is 100% due to the fact that Blizzard staggers their patching among the regions. EU servers don't have the 9858 build on them yet, so your 9858 client can't be played there until Blizzard updates it. I agree that this system is an epic failure for anyone who plays on a server outside the region they live in. Blizzard probably just doesn't give a damn because the % of people who do that is relatively low.


They need to give a damn, as the problem likely affects most people playing in Australia. When an Australian player is presented with the choice of US or Asian servers, 99% will choose US. Then we find out that for some stupid reason we are lumped in with the Asian region. Australia is not part of Asia.

It would be pretty easy for Blizzard to host the patches on the D3 website and allow us to download them. It would be better if they built some Australian servers, but the Blizz exec's are too busy having a money fight in the boardroom to do that.

But soon, soon, my army of Koala bears will be ready to deploy to Irvine CA. Aint no one !@#$s with Koala bears... Aint no one.
Hi,

I had the same problem but I was able to have it fixed. However I am from Australia but I play on The Americas Servers.

Anyone having the same issue where it tells you to that the game needs a patch and restarts but says its up to date instead will find this very helpful.

go to
1. C:\ProgramData\Battle.net\Agent

2. then open agent.db file with note pad

3. replace http://ensg.patch.battle.net:1119/patch with http://enus.patch.battle.net:1119/patch

there should be only 3 to replace.

hope this helps some of you.


Citroo30
My Launcher is patching right now, I just dont know if i would have the same problem when i log in. Hope this will solve it.
Still cannot login...
Same. Quite a disappointing way to spend a day off from work.

And I'm not even interested in a RMAH. Is this the price we have to pay for it?
Tried, still no dice! Thanks for the effort!
now it won't even connect to the server..why..D3..why? do you enjoy hurting me? -cries-
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]