Diablo® III

Need some help please

Is it the AMD system monitor or AMD catalyst manager I have to uninstall? If not I cant find it :p

Could it be that it was messed up when they were instsalled? because it says they were released on 4/25/2012 and version 12.4 but dxdiag says 04/02/2011 version 8.832.0.0
Edited by SgtSackEm#1582 on 6/7/2012 9:39 PM PDT
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
AMD Catalyst Manager
Reply Quote
Will I need to get USB drivers and Audio drivers again aswell?
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
No, this should only uninstall graphics driver

Check to ensure only graphics driver and catalyst control panel is getting uninstalled
Edited by Ehrengarde#1143 on 6/7/2012 9:42 PM PDT
Reply Quote
For the DriverSweeper, Do I only want to clean the AMD-Display, or do I also want to clean Intel-chipset, Nvidia-chipset, Nvidia-display, Nvidia-Physx?
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Only AMD - Display. Leave rest unchecked.
Reply Quote
Well that didnt work too well. Installing the graphics drivers didnt work, shows nothing in dxdiag and in device manager it has that yellow triangle with the "!" on it. what should I do? xD
Edited by SgtSackEm#1582 on 6/7/2012 10:09 PM PDT
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Did it install completely in the end, or did it quit with errors?
Reply Quote
Pretty sure it finished, but I think it said something about errors at the end
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Yellow ! icon, but saying that it finished completely?
I always get that error but works fine for me.

Did you reboot after installing?
Reply Quote
Yea I restarted after, Should I just try it again? or what should I do?
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Uninstall using control panel -> CCC manager
Reinstall again

During installation, it detected your hardware and didn't say anything about not finding AMD hardware?

If it doesn't work again, try with drivers found here:
http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-98292-1&cc=us&dlc=en&lc=en&os=4063&product=5128772&sw_lang=
Edited by Ehrengarde#1143 on 6/7/2012 10:29 PM PDT
Reply Quote
I'm not sure, wasnt really paying attention to it, ill watch more closely this time.

I tried those drivers before I asked for help on the forums, didn't work.
Edited by SgtSackEm#1582 on 6/7/2012 10:32 PM PDT
Reply Quote
Well it said it finished successfully that time.
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Reboot and see what happens
Reply Quote
No good. Still says there's nothing in dxdiag, and still has the yellow triangles with the "!" in device manager.

Oh and I forgot to ask, will leaving my laptop plugged in ruin the battery or will it just run off the power from the outlet?
Edited by SgtSackEm#1582 on 6/7/2012 10:45 PM PDT
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Download and run GPU-Z, does it report which GPU?

Also, it'll just run off the power from the outlet
Reply Quote
It shows them both on GPU-Z, The Radeon HD 6520G & the Radeon HD 6750M
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Then it seems to be installed correct if GPU-Z can detect them with no problem.

Try running a game now.
Reply Quote
Tried Diablo 3. It won't start up, the launcher will open and after i press play that loading thing with diablos face will pop up, but the game doesn't start. Also cant change any graphics settings, like the crossfire and stuff. It only shows power settings and things like that.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]