Diablo® III

Diablo 3 Launcher won't start...

90 Human Rogue
7260
Posts: 27
I'm afraid I've tried the installer from cd, client download, and the setup.exe in the program data/battle.net folder
Reply Quote
100 Troll Death Knight
14680
Posts: 12
Sweet i can't wait to get off work and go home and try this! Thanx
Reply Quote
Don't know if this will help, but this is exactly what was happening to me and I was able to fix it through a (somewhat annoying) workaround.

Several hours of googling and scrounging led me to believe it is caused by something called side-by-side permissions for Launcher.exe. I was able to successfully install and run the game by creating a new user on the computer.

Note I said *on the computer* meaning in the control panel. I gave it administrator privileges, but I'm not sure if this is necessary.

If anyone knows more about Windows application permissions, especially this "side-by-side permissions" thing, please add your own input.


Worked for me.... have to use it with another Login but game runs....
Edited by Sporkman#6245 on 6/13/2012 7:44 PM PDT
Reply Quote
90 Human Rogue
7260
Posts: 27
@Sporkman: Thank you for bringing this up. I did find that post awhile ago and sent a link to that thread so they may join mine and see if there is anything useful here should they have problems still. To find this other thread where the issue is quite similar to my own but maybe more so to someone else you can go here: http://us.battle.net/d3/en/forum/topic/5794930462?page=1#4
Reply Quote
Hey guys, Iv been surfin these threads for answers to the same issue. I have no gotten anywhere with it either. Uninstalled the game deleted all the battlenet info and still "Updating Setup Files.." Fails 3/4 of the way through i let it sit for 4+ hours and nothing happened. Im hoping this is only because im not on my home network. If when i get home (2 weeks) this issue has not been resolved. Im getting my money back for this game. Its not worth it to rage over something that seems so petty. I have over 160+ hours clocked...I feel your guys pain
Reply Quote
I did a scan on Norton, and checked a few things, turns out the file that's missing, it's a potential virus. It's quarantined. You all should check your computers for it.
Reply Quote
nightlux its probably not a virus included with bliz but a program to make sure no one is cheating but norton dubs it a virus. AFAIK - My updater is failing when it sends requests to one of the bliz servers. The bliz server is responding with resets. If anyone has a clue what I'm talking about then I know for a fact this is not my end. Their servers are jacked or something is gettin FKD up. Ill give this more of a go tomorrow if nothing happens and i get no results i quit. I want my money back somone can have my !@#$
Reply Quote
100 Troll Death Knight
14680
Posts: 12
I did all that was posted in the thread except the new user thing i will give that a go i suppose.. Ugh.. I hope this works. I am using a macbook pro and for those this "walkaround" worked for use windows, so i hope this isnt more time wasted. Thank you everyone who is in this thread. You make me feel like someone out there cares and im not the only one lol but really though guys thanks
Reply Quote
So i figured out "MY" problem. This may help others so i decided to post.
Do:
Windows button + R > Type CMD and hit enter.
now do: tracert us.logon.battle.net
This is what I had

Tracing route to us.logon.battle.net [12.129.206.130]
over a maximum of 30 hops:

1 2 ms 1 ms 1 ms campripley-sh-v50.r.state.mn.us [156.98.155.254]
2 4 ms 2 ms 2 ms stcloud3-hub-gi5-0-1-521.r.state.mn.us [207.171.120.22]
3 4 ms 5 ms 5 ms umn-lena-te3-4.r.state.mn.us [207.171.110.97]
4 4 ms 5 ms 4 ms umn-lena-te3-4.r.state.mn.us [207.171.110.97]
5 5 ms 4 ms 5 ms telecomb-gr-01-te-2-2-3002.northernlights.gigapop.net [146.57.252.194]
6 71 ms 200 ms 199 ms 66.162.50.106
7 12 ms 22 ms 17 ms 66.162.50.105
8 32 ms 74 ms 87 ms chi2-pr1-xe-1-3-0-0.us.twtelecom.net [66.192.243.138]
9 136 ms 315 ms 63 ms cr1.cgcil.ip.att.net [12.122.133.198]
10 140 ms 76 ms 64 ms cr2.dvmco.ip.att.net [12.122.31.85]
11 138 ms 102 ms 80 ms cr1.slkut.ip.att.net [12.122.30.25]
12 240 ms 229 ms 117 ms cr2.la2ca.ip.att.net [12.122.30.30]
13 212 ms 251 ms 201 ms gar29.la2ca.ip.att.net [12.122.129.241]
14 61 ms 60 ms 60 ms 12-122-254-234.attens.net [12.122.254.234]
15 61 ms 60 ms 69 ms mdf001c7613r0003-gig-12-1.lax1.attens.net [12.129.193.254]
16 12.129.211.34 reports: Destination net unreachable.

Trace complete.
Huge latency issues and the data was being dropped. The network is !@#$ty <- in short.
Maybe this is some of your issues too IDK. This worked fine and up until a few days ago just decided to stop working. I doubt this is your issue but..it may help some.
Reply Quote
Whent on holliday D£ working fine, come home it updates itself and now zero sweet buger all,
this is getting beyond a joke now. Spend less time trying make money from stupid auction house & get the game running. Cant believe they release a patch that kills the game dead. Thanks for nothing blizard.
Reply Quote
I played this game once on a friends computer and ran out and bought it I loved it so much, Then my computer wouldnt run it.. Needed a new graphics card, bought one, got it all set up, reformatted my computer, re-installed diablo 3 and now the launcher will pop up, the decal will show on my screen... then nothing... im soooo lost.
Reply Quote
Right... This is kinda stupid, but back when I was waiting for D3 to come out, and didn't want to play WoW anymore I was playing LoL...

Sometimes it had connection issues too, and I went on and read their FAQ.

Today I had:
Error with the launcher not wanting to start
Launcher started but made an error
Launcher started but play button unavaliable
Launcher started play button avaliable - login dcing me from battle.net or error 3003

So I decided to try play LoL... =O
The loginscreen there didnt work, so I did what I used to do when it didn't. And all of a sudden my D3 was working fine aswell...!!!!???

TLDR;
What I did was update my windows time (click the clock icon, settings, press the internet time tab on top, click settings and press update)

Hope that someone else will be able to get further from that aswell =)
Good luck!!
Reply Quote
Do you have to uninstall d3 from the original user then reinstall it on the secondary profile?
Reply Quote
3 Troll Shaman
0
Posts: 3
Just throwing this out there that I was having the "Update 0%, cannot click play" issue. I let it sit at that while I read through the three pages on this thread, and then a second window popped up in behind the launcher (saw a second Diablo app running in my task bar).

This said that there is an update for the launcher that would be applied the next time the launcher runs. There was a restart button and I think a cancel button. I clicked restart, the diablo launcher restarted, and now the launcher works, news shows up, and the play button looks clickable.....gonna click it and cross my fingers...

Yup, game launches....
Yup, I can log in....
Yup, I can actually play the game again.
Edited by BlueGlowBoy#1174 on 6/18/2012 6:40 PM PDT
Reply Quote
You folks have Nvidia cards? Same thing happened to me after Nvidia rolled out an update. I reverted back 2 or 3 versions from their website and haven't had any problems since. I know this was the issue for me because after the blizzard patch I played, then i updated my video card drivers, then it didn't work.
Reply Quote
85 Gnome Mage
0
Posts: 4
Well... its been about 2 hours of trying to figure this out... cannot get the game to launch... It looks like it patches then everything is green I click Play... And wait and wait and wait and let's not forget wait. Then after waiting more after that.. I disable absolutely everything restart computer. Then try launching again. Yep looks like it patched the game. Then click launch. Rinse and repeat. etc etc.tech support forums, YEP been there done that nothing helped.. So uhh is there a trick to getting the game to launch after this Patch 1.0.3?
Reply Quote
Almsy, did you try my suggestion just above? Blizzard made numerous graphics changes and fixes in this patch.
Reply Quote
this fcking problem is back again !!!

Fc!#!!#!!#!!#!!#!!#!!#!!#!!#!!#!!#!!#!!#!kk !!!
Reply Quote
Ok for those of you who can get the launcher running and get stuck at launching here's what worked for me. Close the launcher and hit:
ctrl+shift+del
end agent.exe and any other bnet related processes
go to the program files folder and delete EVERYTHING there
relaunch the launcher in compatibility mode with administrator privileges in XP SP3 mode
once the update is done hit launch nothing will happen, curse whatever god you worship but then open task manager and close agent.exe again.
you should see the process restart and diablo should launch.
Reply Quote
So, hello all.

Tried starting Diablo 3, launcher came up and everything was chill. However the launcher only gave me the option to Install the game, nothing else. Wondering what the hell is going on, any input would be great.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]