Diablo® III

Diablo 3 Latency Issues.

Having the same latency issues here even though my internet connection here (Philippines) seems ok. I had no problems accessing bandwidth-heavy sites, but when playing D3 I get red/yellow latency (400+ to 1k+ latency)

My tracert:

Tracing route to 12.129.209.68 over a maximum of 30 hops

1 3 ms <1 ms <1 ms 192.168.1.1
2 7 ms 7 ms 6 ms 100.76.0.1
3 6 ms 6 ms 6 ms 121.96.7.34
4 7 ms 6 ms 7 ms 121.96.7.34
5 7 ms 7 ms 7 ms 121.96.7.17
6 9 ms 8 ms 8 ms 121.96.7.21
7 10 ms 9 ms 8 ms 202.78.119.9
8 8 ms 8 ms 13 ms 203.208.30.177
9 24 ms 23 ms 23 ms 121.127.0.77
10 24 ms 23 ms 24 ms ge9-26.br03.hkg04.pccwbtn.net [63.218.252.241]
11 179 ms 177 ms 178 ms 192.205.35.145
12 184 ms 180 ms 186 ms cr2.la2ca.ip.att.net [12.123.30.190]
13 178 ms 179 ms 178 ms gar29.la2ca.ip.att.net [12.122.129.241]
14 179 ms 178 ms 179 ms 12-122-254-238.attens.net [12.122.254.238]
15 205 ms 257 ms 342 ms 12.129.193.250
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.
Reply Quote
+1 Somtimes it's fine, other times it spikes to 1000-2000.
Reply Quote
i tend to have this issue after playing for 2-3 hours.
what happens is i start getting small spikes occasionally, 350-450 every 15 minutes or so.

over time it escalates to 1-3k latency every 30 seconds, i'm really really tired of it and know it is not on my end, it only just started happening about one week ago.
Reply Quote
Just want to chime in and say that I am having the same problem that others have described in this topic. My latency frequently spikes up to well over a 1000. These spikes frequently lead to dropped games. The occurrences are so frequent that it has rendered me unable to play the game.

I had been successfully playing the game since its initial release. I am relatively certain that all of the problems have started since I downloaded the most recent patch. My internet connection is fantastic (both in speed and quality according to all tests I can find) and I have no problems with any other internet games or applications.

I have no real thought as to what may be causing the problem, just want to help Blizzard become aware of the magnitude of the problem. Hope it gets fixed up soon.
Reply Quote
Anyone using FixMyLag? I really want to try it but Im afraid that I might violate some terms of use. Blues cannot really help me in solving this lag issue.
Reply Quote
I have the exact same issue. Seems like when i start a game I "connect" to a specific server sometimes its horrid lag. All i do is exit out of game and restart and hopefully connect to a better server. I dont know how it works i just know that it works for me. Just keep restarting game until i get a non laggy one. What really pisses me off is getting these random disconnects when running with 5 stacks of NV.

This lag is 100% server side as I have 0 lag with any other game and all i play is online games. If I were to hazard a guess, location would be a factor and which server your being connected to.
Reply Quote
same problem. the game is unplayable. i hope they fix it soon or i will just have to move on to bigger and better things.
Reply Quote
90 Human Warlock
9630
has blizzard said anything about this yet?
Reply Quote
Response from Battle.net support rep:

Greetings!

Thanks for your inquiry!

It is indeed legal (as in, not a violation of the Terms of Use) to use a program that claims to lower your latency. Though, as a gamer myself, I doubt the legitimacy of such claims, the only software that would really endanger the safety of your account would be software that automates your character's actions/skills/professions, etc.

Thanks again for your question, and best of luck to you. :)
Reply Quote
Just echoing the complaints here so something can be done about it. The game had been working great for me up until this last patch (1.0.4) but within this last week or two the lag has gotten extremely bad, as everyone is saying. I've changed nothing on my end, so I don't think it's user error.

For me the lag seems to happen as soon as I encounter enemies, often within minutes of starting the game. My character is still able to run around, but not able to interact with anything. The first few times this happened it would eventually unfreeze after a minute or so, but now it stays frozen and I have to exit the game every time.

I hope this is something Blizzard can fix...
Reply Quote
I'm having the same problem. Please Bizzard fix it or else i'll be wasting my money for no reason.....
Reply Quote
I've been having the same issues. Early in the morning, i.e. now (8:35 EST) the servers are fine and I can play with not only a lag free experience, but with minimal game stutters (imagine that, the micro stutters are really created by lag). I login at 7PM and the game lags and so does my GFX. I run a direct connection, no router and nothing downloading in the background. The issue is Blizzard, not me.
Reply Quote
Still waiting for a reponse to this 17 page thread and the other 20 threads I've seen regarding this problem.
Reply Quote
Im having the same issue as well, but i got 1mpbs internet speed connection this started to happen about a week ago and now i still cant play it. i never got a green ping anymore only yellow or the red one
Reply Quote
having the same issue!!!!
Reply Quote
this thread is 5 months old continuing with the same issues.. that would clearly announce the problem is not our internet but rather their servers.. i have 100mb internet connection which i pay quite a bit for and if it dips below 70% of what i pay for they are here the next day to fix it.. though my ping usually stays in the green i do experience orange and sometimes red.. the last couple of days i have even noticed the error 3007.. i can instantly run a speedtest and pull accurate results and to double check if its correct by starting a dl off my seedbox(1gb bandwidth so 125mbps max) where i see 12.5mbps which matches a 100mb connection.. 100 / 8 = 12.5(max throughput).. i can say without a shred of doubt, the problem exists within blizzards server/game
Reply Quote
I have same problem, latency always 1k+
unplayable
Reply Quote
same here guys , I am frustrated! can't even play the game anymore
other games works perfect
people with lower internet speed have no problems
don't know what to do anymore
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]