Diablo® III

Need a video player that won't lag

When I play D3 and try to watch video on my second monitor, it's either choppy (Windows Media Player) or frozen (Zoomplayer). The audio is fine. The video works fine when D3 is not running or minimized, but does not work fine even if the game is running in windowed mode. Since the two players I've tried react differently, I imagine there should be one out there that will work, but before I go trying everything on the internet, does anyone know of one that works for certain?
Reply Quote
I had a similar problem and VLC does not fix it..... However, I did find that playing Diablo 3 in windowed-fullscreen mode (changed from the ingame menu) fixed the issue. I have been messing with this for a while and this is the only fix i can find
Reply Quote
100 Undead Priest
12790
Posts: 153
Windowed (Fullscreen) does not fix the issue. It never did that until one of the patches. I don't remember which one, but it was perfectly fine at release. I wish it would get fixed.
Reply Quote
I found a fix that might work for you as well.

When playing D3, my graphics card is maxed out (99% GPU Load according to NVidia Inspector) and I suspect that VLC uses hardware accelerated video output by default. It came to me that I might switch to another method that doesn't use hardware acceleration (ie. not using the GPU).

1. Start VLC
2. Select Tools => Preferences from the Menu
3. Click Show Settings: All (Bottom left of the Preferences Window)
4. Select Video from the list on the left side
5. Change the Output Mode from default to "Windows GDI video output"

Those steps stopped the problem for me: I can now watch videos with VLC and play D3. If it doesn't work, you should try out other modes as well. I don't know the default method used by VLC so the reason why this works for me is pure speculation.

I really hope this helps at least some people ;)
Reply Quote
I have the same issue.. Drag media player on my 2nd monitor (my tv) and the movie starts lagging, not the audio though.. also does it with certain other apps.. like closing chrome the other day initiated the lag.. really annoying..
Reply Quote
1. Start VLC
2. Select Tools => Preferences from the Menu
3. Click Show Settings: All (Bottom left of the Preferences Window)
4. Select Video from the list on the left side
5. Change the Output Mode from default to "Windows GDI video output"

I really hope this helps at least some people ;)


Luv! =)

J.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]