Diablo® III

Linux / Wine issues

Ubuntu 64bit 8Gb Ram

setarch i386 -3 playonlinux

Worked like a charm.
Reply Quote
Confirmed. Success logging in with setarch(8). Well done.
Reply Quote
Posts: 11
You saved the day! Can you give me a command to kill inferno belial now?
Reply Quote
90 Tauren Druid
0
Posts: 472
06/06/2012 10:34 PMPosted by Vaux
I know it's a lot to ask but if you're on a 64bit OS and have more then 2-4 Gigs of ram could you try to reduce your ram to less than 2 or maybe just less than 4.
I run on 2GB of RAM FWIW. Per above, 64-bit Ubuntu still gets stuck at login. The OS address space should not be visible to the 32-bit application anyway, yeah?

Edit: My D3 launch script is getting a little ridiculous :)
Edit2: For those who care, it is now:
WINEPREFIX="/media/ssd/Diablo III/wineprefix" taskset -c 0 setarch i386 -3 wine "Diablo III.exe" -launch
:D
"taskset -c 0"keeps the game on a single processor core, which removes a lot of stuttering. Does your game slow down for a second now and then? Give it a try.
Edited by mashdar#1871 on 6/7/2012 12:00 AM PDT
Reply Quote
85 Human Warlock
0
Posts: 45
Nice workaround. I wasn't aware of 'setarch', a very handy thing to know. Thank you.
Reply Quote
I commented on the wine ticket, and raised the question of whether this counts as a bug in wine.

This actually makes me curious if the same issue occurs under Windows if you use the boot option to enlarge its process address space from 2GB to 3GB:

http://msdn.microsoft.com/en-us/library/windows/hardware/gg487508.aspx

Is anybody with 32-bit Windows feeling adventurous enough to see if the "/3GB" flag in boot.ini makes the warden cry?
Reply Quote
90 Tauren Druid
0
Posts: 472
06/06/2012 11:48 PMPosted by Voltara
This actually makes me curious if the same issue occurs under Windows if you use the boot option to enlarge its process address space from 2GB to 3GB
This might also explain why some people were still having problems the "removed from game" bug after installing a 32-bit kernel.
Reply Quote
Posts: 7
Confirmed to work on 64bit Kubuntu / Wine 1.5.3
Edited by Sunstrike#1596 on 6/7/2012 12:09 AM PDT
Reply Quote
06/06/2012 11:48 PMPosted by Voltara
This actually makes me curious if the same issue occurs under Windows if you use the boot option to enlarge its process address space from 2GB to 3GB:

It shouldn't. That's what the -3 does in setarch.
Reply Quote
I could log in today, but I wasn't able to join a game. The setarch command is working for me as well.

Thanks!
Reply Quote
setarch i386 -3 playonlinux

Worked for me, 64-bit Ubuntu Lucid w/ POL.

I am seriously impressed with this community. Many thanks to the people who have been toying with this stuff!
Reply Quote
setarch i386 -3 wine "/path/to/Diablo III.exe" -launch

Works for me on Ubuntu 12.04 x64 4GB ram and 4x core AMD Phenom

Also have stable working on

taskset -c 1-3 setarch i386 -3 wine "/path/to/Diablo III.exe" -launch

(for three core limit)

client 1.0.2.9950 enGB and ruRU versions
Reply Quote
When I try to enter the command I only get: wine: cannot find '/path/to/Diablo III.exe'
please help me :(
Reply Quote
@Voltara
setarch i386 -3 playonlinux works like a champ :) Played for > 2 hours with no problems.

@Vaux & Mashdar
I run on 2 Gig of RAM as well.

@Dorminator
The command isn't literally "/path/to/Diablo III.exe" use whatever your path is. For example, my path is:

/home/kaos/PlayOnLinux\'s\ virtual\ drives/DiabloIII/drive_c/Program\ Files/Diablo\ III/Diablo\ III.exe

Yours is going to be different.
Reply Quote
Workaround Confirmed on Fedora 17 64 with wine 1.5.2.

I used:
setarch i386 -3 wine explorer /desktop=launcher.exe,1680x1050 ./Diablo\ III.exe -opengl -launch
Reply Quote
Thanks! :D diablo now works! made my day ^^
Reply Quote
Workaround appears to be working for me as well (latest Debian Testing 64bit with self-compiled patched GIT wine from May 7), many thanks to everyone that worked on finding a solution.

Edit: but albeit running fine, it doesn't seem to run as well as it did before, seem to have impacted performance a bit
Edited by Evanidus#1421 on 6/7/2012 5:14 AM PDT
Reply Quote
The problem has been fixed in PlayOnLinux.

http://www.playonlinux.com/en/commentaires-1058.html

(No longer need to use setarch)
Edited by Tinou#2490 on 6/7/2012 9:20 AM PDT
Reply Quote

@Vaux & Mashdar
I run on 2 Gig of RAM as well.

Someone else realized the problem with just removing the ram. Virtual Memory could be included as well, and who knows what else. Basically we know it's some number related to memory or a 64 bit arch that's being passed to warden and then it eats your processor. Probably becomes negative number and tries to loop up to that number from zero, or it has the entire number and tries to loop up to it with a 32 bit int so it can never reach it.
Edited by Vaux#1580 on 6/7/2012 6:28 AM PDT
Reply Quote
Works!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]