Diablo® III

patch required loop

did you make sure to move the diabloIII.exe out of the folder, and not the diablo III Launcher?
Reply Quote
HerMister, when you go into the .agent and change the "patch_url" value, change it to http://enGB.patch.battle.net:1119/patch
This is because you should be on the eu server not americas
Reply Quote
omg... same problem again........
Reply Quote
same problem now, hmmm
Reply Quote
The URL solution in agent.db doesn't work for me. I think this never works when the server in the America's is down.

I have been able to play the game, but stuck in the patch loop for the second time...

So please Blizzard, fix this.

It is becoming really annoying and it feels like 60 Euros on the game that doesn't work properly, has been too much.
Reply Quote
aaah it's happening to me also.. second time this month now... WTF?
Reply Quote
I can't play, tried the blue solution, still infinite loop. I installed the US client because at launch the EU one wasn't working for me. So, what now?
Reply Quote
Honestly this should be top of the list for things to fix, this is crazy.

I like all blizzard games never said a bad thing about them, but this is stupid.
Reply Quote
The URL solution in agent.db doesn't work for me. I think this never works when the server in the America's is down.

I have been able to play the game, but stuck in the patch loop for the second time...

So please Blizzard, fix this.

It is becoming really annoying and it feels like 60 Euros on the game that doesn't work properly, has been too much.


Totally agreed.

I did everything....it didn't work.

Just thinking why do I have to fix this problem...........so lame Blizzard.

IT's your damn fault.............and that post from staff didn't work either.

I am using SEA but I always play on USA server because SEA server is full since day one.

:/
Reply Quote
just make sure to replace all the patch urls accordingly int he agent.db file, apparently 2 were pointed to EU and one to US, after changing all urls to EU and deleting the updates folder game works for me.
Thanks.
Reply Quote
Are we really meant to be needing to go inside all kinds of folders and files to edit them to make the game work, every time there is a patch? I Have the same problem as last time with the patch loop. Last time I ended up downloading the client and reinstalling - I hope I wont have to resort to that today, but I fear the worst. This is ridiculous...
Reply Quote
Hi Guys,
I am new to this Blizzard world.

This morning at my location, i tried log-on to Diablo 3, i want to play it.
But Blizzard had an announcement, that AH has a new function, using real money in transaction.
So the patching process begun....

wait, wait, wait... patching and ERROR...

I could logged on to home screen, but when i put my ID and Password , press enter then an error occurred, it says "Patch Required" .....

Damn it is the second times i got this message.

The first was success passed by me, all i did was just uninstalled the game and installed it again.

Hope this error can resolve with this workaround....
Reply Quote
1. Navigate to your Diablo III folder.
2. Open the .agent.db file with WordPad.
3. Find the "patch_url" line and change its value to:

http://enUS.patch.battle.net:1119/patch

4. Save and close the file.
5. Now delete the Agent folder in the Battle.net folder: (don't skip this step)
Reply Quote
HerMister, when you go into the .agent and change the "patch_url" value, change it to http://enGB.patch.battle.net:1119/patch
This is because you should be on the eu server not americas


If you change it after you realize you get the loop issue, it's just to late, this wont work anymore, due to the fact that the client is already a step ahead compared to your version of the game.
Reply Quote
can i have a response on the fact if i change agent....file is considered like hacking cause i don't want to be banned lol
Edited by Sohigh72#1763 on 6/26/2012 3:53 PM PDT
Reply Quote
not for nothing but honestly, if your posting this fix, why cant Blizzard fix it? we paid for the game, i know i diddnt pay to go playing hopscotch with files to play....cmon guys get it together....
Reply Quote
This is a joke. Get your act together Blizzard. Seriously pissed off right now.
Edited by Steiny#6882 on 7/10/2012 5:46 PM PDT
Reply Quote
Komputer

Try this:

1. Navigate to your Diablo III folder.
2. Open the .agent.db file with WordPad.
3. Find the "patch_url" line and change its value to:

http://enUS.patch.battle.net:1119/patch

4. Save and close the file.
5. Now delete the Agent folder in the Battle.net folder: (don't skip this step)

Windows 7/Vista

C:\ProgramData\Battle.net

(Note that ProgramData and Application Data are hidden folders.)

6. Delete the Updates folder. (Diablo III\Updates)
7. Move the Diablo III.exe file out of the Diablo III folder.
8. Run Diablo III Launcher as admin by right clicking on the launcher and selecting "Run as admin".
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


Ok did everything it says and it just borked the whole thing. I then told me to Install, so I click Install and it said there was data missing and that I needed to download the digital installer. You have a screw loose if you think I am wasting my time and bandwidth when I purposely bought the DVD version (yes I did try installing from the DVD but same error).

These instructions are very irresponsible. Don't just tell people to go deleting files. At the very least tell them to back them up first.

I can't believe this is the best you guys can come up with. Seriously fix the damn problem.

I don't really have a problem with a short term workaround if that was going to get me in for now but this doesn't work and this bug has been around for a long time now.
Reply Quote
i did exactly what the Blue said to do aswell. however, after it poped up the install screen and i hit install it poped up another error. so i put the Diablo 3 exe back in the folder and tryed the launcher and worked perfect. so try to do this without mocing the D3.exe out of the folder and you should be good
Reply Quote


8. Run Diablo III Launcher as admin by right clicking on the launcher and selecting "Run as admin".
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


after i "Run as admin", theres 3 option appear: Install, manual, and exit. I click install? or manual?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]