Diablo® III

Stuck on Starter Edition when i bought game

Same problem!
6/20/2012 Diablo® III (Digital Purchase) $59.99 USD 1 Complete $59.99 USD

I started as a trial account and upgraded once I reached level 10/Beat the Skeleton King. After upgrading - All my quests were gone and I had to beat the Skeleton king all over again - and THEN IT TOLD ME TO UPGRADE. My account is already upgraded!

So I tried it one more time, going back into those retarded crypts, killing him, AND IT STILL TOLD ME TO UPGRADE AFTER I BEAT HIM. What gives? How do I actually play the game? Has anyone else had this problem? Blizzard you ripped me off.
Reply Quote
90 Tauren Druid
3010
I've been calling Billing Support for 2 hours, and I'm unable to even get into the queue for my call to be answered. My ticket is still open, with no response as well.

I've paid $120 now, and still have no game access. How is this not straight up theft? If this were Amazon or Newegg, my "ticket" would've been answered in minutes, and if no solution was found, a refund would be in my account within a few hours. I've been waiting for 2 days now to be able to play, and have only gotten one generic e-mail response as to what is happening.

Extremely disappointed, Blizz.
Reply Quote
I just upgraded my account from a friend's guest pass as well. I played last night, beat the Skeleton King, and upgraded when the game prompted me. I paid 60$ and my battle net account now shows I have the full version. Unfortunately, when I log in I cannot select any other quests than those of Act I. I beat the Skeleton King yet again and, much to my chagrin, I'm told to upgrade my account for access to further content. What the hell, Blizzard?!
Edited by Martel#1195 on 6/20/2012 4:16 PM PDT
Reply Quote
Having the same problem and just found this sticky thread: https://us.battle.net/d3/en/forum/topic/5889089807

About two hours old, not any reason given... this is ridiculous! I don't buy a digital copy of a game to wait to play it!
Reply Quote
in bnet i can see the game in my games as standart edition. but in game it works like is starter.

i've seen something that says you cannot see auction house if you are starter pack.

well i can see that and buy/sell !@#$. but i cannot go past leoric it says i need to upgrade the game.

i'm saying this again but thank you blizzard for suprisingly being worse than ea. i really couldn't be dissapointed more than this.
Reply Quote
Just happened to me too!!!
After reading all this above i'm pretty pissed off ><

Is there anyone who had this problem fixed at all??
Reply Quote
Yeah look at this here:

As of patch 1.0.3, when purchasing a digital version of Diablo III through the online store or your Battle.net Account, players are restricted to the Starter Edition for the first 72 hours (sometimes less). Players on Starter Editions have the following restrictions:

Act I up to the Skeleton King is available
Level 13 cap
Matchmaking available only with other Starter Edition players
No Auction House access (Real Money or Gold)
Global Play is not available.

Players attempting to connect to Diablo III Starter Edition in a region other than their Battle.net Account's home region will receive Error 12. See the Global Play support article for more information.

More information regarding the Starter Edition is available here:
http://us.battle.net/support/en/article/diablo-iii-starter-edition-guest-pass

If you are still encountering the Starter Edition restrictions over 72 hours past the date of purchase, please let Customer Service know: http://us.battle.net/support/en/article/contact

I fell kinda bummed...
Reply Quote
Why am I being penalized for purchasing a digital copy? Is this their idea of digital rights management?

All they have managed to do is disappoint and possibly deter an eager player.

They will be lucky if I ever purchase a blizzard game again...
Reply Quote
- Technical Support
View profile
It is not a penalty really, it is about preventing fraud with stolen cards which is what the gold sellers do. People did want that nonsense stopped and this..helps some at least.

I might be able to offer a bit of insight. This is just about making sure the transaction completely finishes. "Processing" on your statement does not mean it is done. It means that it is..in process. There are several verifications on both the bank's side and Blizzard's. If it fails at the Blizzard end then that pending charge will just drop off. They money will not be sent to Blizzard. This process can take from a few hours up to 72 at the worst. This is normal and when you purchase online goods..sometimes the "processing" part of your shipment is exactly this..verifying the purchase. That is why it can take a day or 3 to ship.

- They have used this system in WoW for a long time to combat hackers/gold sellers using stolen credit cards. When you upgrade from a trial account it can take UP TO 72 hours for all restrictions to lift. In many cases is is lots faster.
- Seems they are implementing it in D3 to combat fraud too. Not a bad plan but telling people at the time of purchase would be good.
Reply Quote
This is absolutely ridiculous! I have had the same thing happened to me. Why the f*** was there no warning, I would have went and bought it in the store.

BLIZZARD fix this f***** bug please or I want my money back!
Reply Quote
Good luck gettign your money back. you can't even contact anyone. The phone support is blocked, and you can't leave a message. They are well insulated from angry customers who just got ripped-off.
Reply Quote
I was about to pay $60 and upgrade my account right now, Then i heard there is a wait time from someone ingame.

Now i read this, Im wondering, Should i even buy this game?

Seriously Blizzard..

Btw, Anyone know if i ordered a Box version if i would get the same issue of waiting 72 hours?
Reply Quote
I am both relieved and angry to see this thread. Why does it take 72 hours to process a digital purchase of a game? Are they insane? Any other business can approve or deny a purchase in minutes. If blizzard cannot do the job efficiently perhaps they should use a third party to sell their digital copies of the game. Or how about a warning like this:

"72 HOURS IS REQUIRED TO PROCESS YOUR DIGITAL PURCHASE, PLEASE ENJOY THE STARTER EDITION WHILE YOU WAIT"
Reply Quote
Guys, Just use the Box edition to upgrade. Its the same price as the digital, And at least you get stuff with it.

Take the time to go for a ride and pick it up. I did, And i had my account active immediate. I'll be on the next difficulty before you guys get active.. So just get a box copy.
Reply Quote
same here what the hell i payed 60.00 for the full game not just to get to the skeleton king
Reply Quote
Same thing is happening to me... I think I've killed the Skeleton King a total of 9 times... I really wish i would have know about the 72 hour delay or i would of just bought it at the store. Blizz if you're reading this PLEASE WARN PEOPLE ABOUT THE 72 HOUR DELAY!!!!!
Reply Quote
85 Human Priest
4005
my friend had this same issue. try resetting your battle.net password. worked for my friend. once he reset password everything was unlocked. enjoy your game. blizzard has bad programmers.
Reply Quote
I also had exactly the same problem with my first character. When i killed the skeleton king and upgraded my account i needed to start all over again (luckily i did buy a box edition)
However right after i noticed that i needed to start with quest 1 a friend of mine wanted to play with me, > he then made a new game (he was party leader) and then all the quests i had done were back,.. so hope this helps..
Probably because you practiclly reset your game..
Edited by Tattersail#2702 on 8/17/2012 1:37 AM PDT
Reply Quote
I just managed to make it work by changing the region, I had also changed my password, but that didn't do the trick.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]