Diablo® III

Micro Stuttering Fixed

I had the Micro Stuttering Problem and i've managed to 100% fix it so i thought i'd share how. firstly lets look at what i tried -

These things may have helped slightly but did not fix, found from other threads with the same problem -

1) Opened D3Prefs.txt and changed HardwareClass "1" and DisableTrilinearFiltering "1"
2) Run in Compatibility Mode Windows XP Pack 3 and as Administrator
3) Task Manager, Show all Processes, right Click Diablo3.exe - Set Affinity....Turn OFF Core 0
4) Task Manager, Show all Processes, right Click Diablo3.exe - Set Priority High or Realtime
5) Freshly Reinstalled Graphics Drivers
6) Turn on/off indexing on my SSD Hard Drive
7) Changed and tried numerous settings in game / Nvidia Control Panel Settings
8) Performed various Windows 7 tweaks on my hard drive settings
9) Created a RAM drive and put some of the game files on it
10) Ran the game files from USB stick

Some of the above helped, but did not fix the micro stuttering.

I KNEW it was caused by access of game files and hard drive access.

No matter how many tweaks i tried, i could not ELIMINATE the stuttering until............................................

11) I simply turned off real time protection on my anti virus software. (microsoft security essentials).

Basically whenever the SDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.

Hope this helps some people, who like me, tried everything but the obvious.
Edited by Maccus#2282 on 6/5/2012 9:54 AM PDT
Reply Quote
Thanks alot, this solved my stuttering problem. :-)
Reply Quote
THANK you. Apparently it's the same effect with AVG's resident shield. BUMP TO THE MAX, and if blizzard could somehow fix this that'd be great. You are the man, Maccus.
Reply Quote
This completely solved my asset loading stuttering, awesome! you are the man
Reply Quote
This WORKS!
Reply Quote
MVP
Posts: 14,629
View profile
So this pretty much confirms what has been said all along...

The game's loading assets from the HDD instead of RAM...

I have 16gb of RAM, there's no reason the game can't load those assets into RAM for me. =(
Reply Quote
So this pretty much confirms what has been said all along...

The game's loading assets from the HDD instead of RAM...

I have 16gb of RAM, there's no reason the game can't load those assets into RAM for me. =(


Yeah I wish it would preload more stuff, but then again, 16 gigs of ram is still considered outside the norm (I also have 16 gigs). I'm thinking of rigging up a RAM disk again, and install D3 entirely to there. Current install size says a litte under 8 gigs, I got that to burn :D
Reply Quote
90 Worgen Priest
7940
Posts: 1,864
So this pretty much confirms what has been said all along...

The game's loading assets from the HDD instead of RAM...

I have 16gb of RAM, there's no reason the game can't load those assets into RAM for me. =(

This was confirmed months ago by a blue, but he also said the engineering team was working on technical fixes that would hopefully resolve these issues. The constant HDD accessing is the reason there are no load screens.
Reply Quote
thx, will try it!
Reply Quote
MVP
Posts: 14,629
View profile
08/22/2012 04:31 AMPosted by Lysiana
This was confirmed months ago by a blue, but he also said the engineering team was working on technical fixes that would hopefully resolve these issues. The constant HDD accessing is the reason there are no load screens.

Still, the code shouldn't be reloading an asset that's already loaded.

WoW's only loading screens are from continent to continent yet there's no stuttering there.

I would think they would know how to program an engine that isn't constantly streaming assets. =P
Reply Quote
33 Dwarf Paladin
340
Posts: 4,597
The only time I get stuttering is when I first start a game and use a skill for the first time (normally log in and fire off all my skills before seeing mobs.)
Reply Quote
08/22/2012 04:30 AMPosted by ArcanePariah
Yeah I wish it would preload more stuff, but then again, 16 gigs of ram is still considered outside the norm (I also have 16 gigs).

The norm is 4 GB, but still Diablo 3 uses less than 1 GB. There is absolutely no need to be so stingy on resources, especially when it negatively affects performance.
Reply Quote
what's the stuttering problem?
Reply Quote
- Technical Support
90 Human Priest
6220
Posts: 10,389
till, the code shouldn't be reloading an asset that's already loaded.

WoW's only loading screens are from continent to continent yet there's no stuttering there.

I would think they would know how to program an engine that isn't constantly streaming assets. =P


That depends Droth. If you're still using 10.6.8 in Mac OS X (some people have to because 10.7.x breaks many RAID cards), the stutter is insane. Stutter's gone in 10.7.x though due to updated drivers and better I/O kernel extensions. Sometimes it isn't "just" the game causing the stutter.

If I had the money I'd so bump my Mac Pro up to 32 GB and put D3 on a RAM disk. I already do that for playstation games (since I don't want to wear out my PSOne on games I know play flawlessly in PCSX-Reloaded). Mmm...Final Fantasy 7 with no load times.
Reply Quote
Thank You Maccus!!

simply turn off real time protection on your anti virus software. (microsoft security essentials).

Basically whenever the SDD was being accessed, real time protection was scanning them for viruses etc, and thus the game files were being accessed multiple times whilst they were trying to load in game.

Such a simple fix. Game is now 100% smooth with no stuttering at all.

Hope this helps some people, who like me, tried everything but the obvious.


If you have a PC setup that can run any other game on high/ultra settings, yet have trouble with D3(micro stuttering during scrolling, etc), then this is all you have to do. Compatibility mode (Windows 2000 worked best for me) smoothed things out a bit, but nothing came as close to this. I'm sure RAMdisk is the next best method, but takes some time and know-how.

Just put the diablo 3 executable and/or the diablo 3 folder into your exceptions for anti-virus and anti-malware protection. That way you can leave the real-time protection on for everything else.
Edited by Jinglinggggg#1289 on 9/1/2012 9:32 PM PDT
Reply Quote
I tried this, no success.
Reply Quote
I'm pretty sure this was my problem as well! I didn't have the exact same fix but basically I installed it on my C:/ drive instead of my External drive I use for most Applications and now the stuttering is gone. So McAfee must have been trying to scan the files or something on the External hard drive.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]