Diablo® III

Patch 1.02b - broken patch

I just uploaded the newest patch - launcher says that game is up to date Patch 1.02b.
Yet when i click on PLAY games is telling me that patch is required and illbe able to play after the patch is done. Game is shutting down and again same story - Game is up to date, click PLAY - patching required etc....

Is my game client broken or the patch is?

Dear Blizzard any chance for a quick replay? My friend, whom i asked on skype about this has the same issue.
Reply Quote
PS: just tried to log on and logging to American server is avilable.

The patch buggin concerns only European server for some reason.

How come i can log to American servers every time, even if european server returns error 37? Are we some second grade customers?
Reply Quote
same issue! Patch is broken and no clear information available!
Situation (iMac i7 3,4GHz, 27",12GB): Patch installed -> game started -> new patch available -> game quit -> launcher says 'up-to-date' -> game start -> new patch available...loop...

Thanks Blizzard for a statement, solution, or even for a short feedback.

P.S.: only european region impacted (for the time being)...
Edited by cerberus#2599 on 6/6/2012 3:05 PM PDT
Reply Quote
I HATE YOU BLIZZARD!
THE SAME !@#$ING ERROR FROM PATCH 1.02
PEOPLE COMPLAINED
YOU DID LESS THAN %^-*!
ALWAYS ON EUROPEAN SERVER
PLEASE FIX THIS !@#$!
D3 IS BUGGED FROM THE %^-*ING START!
BETA HAD LESS BUGS
!@#$ THIS!
Reply Quote
Same problem here. Except I get the patch message when I log onto Americas servers and nothing when I log onto European servers.
Reply Quote
85 Blood Elf Death Knight
1845
Still getting the patch looping problem guys. Tells me a new patch is available, closes the game, sends me right back to a window that states the game is already running. And I am NOT playing on a European or Asian server. Help?
Reply Quote
im stuck at the play launcher button.
Reply Quote
ive tried to download the patch for 2 days now and it says some files are corrupted. blizzard fix your god daum !@#$. you should of started fixing these problems long ago when you guys had the beta.
Reply Quote
I'm also stuck at the launch application. It attempts to download the patch but I get a ' "d3-0-9950-Win-final.MPQ" appears to be corrupt' message every time and it closes the launcher down! :(

Blizzard, please fix!
Reply Quote
55 Blood Elf Mage
6575
@cyberchicken
I had similar issue, turned off my antivirus and firewall and launcher updated properly. Try this if it fixes your issue
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]