Diablo® III

"patch required" message on attempted log in

Despite start menu informing me game is up to date and after downloading latest patch on starting game.
Reply Quote
I have the same issue
Reply Quote
same
Reply Quote
Ditto. I get a notice that my game needs to install a patch, then I get a crash message, and the Diablo 3 launcher tells me my game is up to date. I feel like Yakety Sax should be playing in the background.
Reply Quote
same here nothing we can do?
theres no manual patch or anything
Reply Quote
http://us.battle.net/d3/en/forum/topic/5573700590?page=1#3

Please do not repost things. On a lighter note, I would try to run the Blizzard Launcher from the directory and running it as admin. This has fixed this issue for a slight few, but it could work for you. Have you looked into Secondary Login? This was needed for a lot of people to even install the game, and you might have been able to slip by without it, but it may now be causing you issues. I would double check. Please post with any more details especially if the aforementioned works, as it would be great to have a known solution to this. God I feel like a Blizz employee..
Reply Quote
same here nothing we can do?
theres no manual patch or anything


check your region settings, try setting them to europe and back
Reply Quote
Ditto for me - "Game is up to date" then when I enter login details I get the message "Diablo 3 requires a patch. The game will now close and patch will be applied automatically" but it doesn't apply. I get a message saying "Diablo 3 is already running". I'm stuck in an infinity loop! Groundhog day - NOOOOO!
Edited by BasilFawlty#1899 on 5/31/2012 1:41 PM PDT
Reply Quote
i have the same problem i have the patch of 28 mai so he asking a new patch and he don't have ...
Reply Quote
DAMN
Reply Quote
Same OMG i hate this game lol
Reply Quote
I'm listening to this in the background, I highly recommend it because it's helping me laugh at the situation rather than being angry about it.

http://www.youtube.com/watch?v=ZnHmskwqCCQ
Reply Quote
same here, the endless patching roundabout...
Reply Quote
If you are trying to connect to EU servers with an English (US) client or vice versa, you will get this bug.

Uninstall and install a client for the correct region. Worked for me.
Reply Quote
...whats secondary login? iv never heard of this...
Reply Quote
Me neither
Reply Quote
Oh well, time to get ready for work - guess playing Diablo for 15 minutes before work is not gonna happen today. Should be resolved when I get home tonight.
Reply Quote
Same issue, my options are set to American servers, so it's not an issue with the EU servers
Reply Quote
it seems to be a problem, every time they apply a patch. Seems that with the money they brought in,before the game was even released that they could employ techs that could handle this problem. It should not be up to the consumer to try to figure out how to fix blizz"s mistakes
Reply Quote
Update: I can log in if I switch servers to European, but when I try to log onto the Americas, I have this problem. Please tell me there's a better fix than reinstalling the entire game...
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]