Diablo® III

Crazy D3-related computer crashes are afoot

I am dealing with this issue too.

It ran fine for a week or so, but now it crashes the display driver, or is extremely low res.

Running on a HD6850 on stock speeds.
Reply Quote
Yesterday i my game started freezing up. It freezes for about 20 sec, then i'm able to alt+tab out, and back in, only to play for few minutes before it happens again. I have been playing smoothly since release and i didn't change anything, it just suddenly startet happening. SERIOUSLY frustrating!
It might be related to OP's problem??
Reply Quote
Posts: 4
For those of you with a GTX 280 this is probably a hardware issue. Here are a number of threads around the internet documenting the same problem, the "pink snow of death":

http://hardforum.com/showthread.php?t=1682226
http://forums.nvidia.com/index.php?showtopic=226035
http://forums.nvidia.com/index.php?showtopic=160392
http://forums.nvidia.com/index.php?showtopic=209008
http://forums.nvidia.com/index.php?showtopic=226035

Some of these were posted way before before Diablo 3 came out. I have a GTX 280 myself that is doing this. I mean no offense if you have one when I say its just a bad video card and yours is broken. There is probably nothing blizzard can do to fix it. Every once in awhile Nvidia puts out a card that is a little ahead of its time and runs too hot. The 280 is one of those cards. It has run too hot and has been crash prone since it came out.
Edited by Ackerus#1177 on 6/24/2012 1:25 PM PDT
Reply Quote
tl; dr.

As i can say for picture in #4
100% info: your video card is dead
Reply Quote
Same here got the 5-10 minutes halt problem, starting 1 days ago, my display card is ATI 7750, It was playing smoothly for 3 weeks and suddenly the black screen happened yesterday!

Please help
Reply Quote
Hey!

I'm getting the same issues as you are, and a blue was trying to help me out.

http://us.battle.net/d3/en/forum/topic/5912294185

I haven't fixed the issue yet because it is irritating, but hope my thread helps a little. :)

EDIT: I see a lot of you posting your video cards, so mine is NVidia 9800 GT
Edited by Popinski#1208 on 7/1/2012 4:35 PM PDT
Reply Quote
Could it be possible that some sort of setting that was changed on Blizzard's end could have 'caused our video cards to overheat and/or be damaged?
Reply Quote
After a month of smooth playing now i have the exact same problem!

After a few Alt-Tabings i got a BSOD, after restarting my pc Diablo 3 have started to crashing every time, after 2-5 min it starts to glitch, there is some weird graphic artefacts and it freezing the game, sometimes i have - "nVidia Driver Stopped Working " message and 4-bit colors desktop :(

Even after exiting the game it continue to causing graphic glitches in any 3d application.
BUT, If I play ANY game without starting Diablo 3 first - I can play for hours without any glitches!!!

First I thought it was GPU overheating, i completely cleaned of dust my old GTX 260, checked everything with stress tests and a few temperature tools - everithing seems to be nominal.

So i tried to install new nvidia beta driver first - no success
(I did a clean install with Driver Sweeper)

Older driver - same thing

I deleted blizzard temp folder in Application Data - same thing

I deleted last patch and reinstalled it - same glitches

PLZ HELLLLPPPPP !!!!

GTX 260, Intell Core DUO E6600, Win xp
Edited by Symbiot#2707 on 8/5/2012 1:41 AM PDT
Reply Quote
your monitor or graphics could be getting over used/heated if your a heavy gamer like most of us are or honestly its more likely to just be diablo 3, ive had nothing but problems since i downladed the damn thing havent been on in weeks tho but i tried yesterday and today and sever is down
Reply Quote
08/05/2012 07:38 PMPosted by ObeyMEGA
your monitor or graphics could be getting over used/heated


HUGE FACEPALM !!! (some ppl can write, but can't read !)

First I thought it was GPU overheating, i completely cleaned of dust my old GTX 260, checked everything with stress tests and a few temperature tools - everithing seems to be nominal.



BUT, If I play ANY game without starting Diablo 3 first - I can play for hours without any glitches!!!


I did the stress tests with the tools and the games with realy recent graphics like Battelfield 3, Skyrim etc and i was able to play for hours without overheating, why Diablo 3 with 5-7 years outdated graphics should to overheat it ???? Sacred 2 released in 2008 has better graphics, physics and gameplay and it works like a charm !!!!

Honestly, I see it was a BIG mistake to pay 50 euros for nothing but a headache with ugly procedural generated levels, nothing to compare with the real Diablo 1 !!!
Edited by Symbiot#2707 on 8/6/2012 12:19 AM PDT
Reply Quote
its kind of funny how my radeon hd double d 6850 can play any game at max setting like crysis 2, sc2 and games similar, but when i try to play this one i now get a bsod due to my atiduag.dll driver. ridiculous! i played this game from launch without any problems till a little less than a month ago. lots of people are having the same issues. why cant they just check to see what they changed in the patch that is causing all the problems and roll it back? its very very frustrating
Reply Quote
i think i may have found a slight fix for it...i dropped the fps to 45 and i kept everything else on high and so far i have not had any errors for a few hours now (before it would have been hard going 20 min or so without an error). try that out guys and let me know how it went
Reply Quote
Its simple...change ur damn GPU....to a better one ofc... GTX 550Ti min ... FORGET RADEON!
Reply Quote
08/12/2012 04:24 PMPosted by Nethorash
Its simple...change ur damn GPU....to a better one ofc... GTX 550Ti min ... FORGET RADEON!


http://eu.battle.net/d3/en/forum/topic/5153865341

Look at the guy's computer specs... He has the same card you advising to buy and the same problem with the driver

Any other stupid advices to give ?
Reply Quote
I've been having this issue for the last 2 months. I can play Skyrim/BF3 for hours on end, no problems.

I launch D3 for 10 minutes and my screen goes black and i have to force restart. The music will keep playing, no looping. Just a black screen and my keyboard/mouse become unresponsive. I can't believe after all the millions this game has made that after 2 Months Blizzard hasn't even released a public statement to at least say theyre TRYING to fix this. Definitely never buying from them again.
Reply Quote
I am also still having this issue. It has been an issue for me for at least 3 months.

I am running an Nvidia 9600 GT

• ZOTAC GeForce® 9600GT Eco
• NVIDIA GeForce® 9600GT graphics processor
• Engine clock: 600 MHz
• 64 stream processors
• Shader clock: 1500 MHz
• 512MB GDDR3 memory
• Memory clock: 1800 MHz
• NVIDIA CUDA™, PhysX™ and PureVideo™ HD technologies
• SLI™ ready
• PCI Express 2.0 interface (Compatible with 1.1)
• DirectX 10 with Shader Model 4.0 compatible
• OpenGL 2.1 compatible
• Dual dual-link DVI – up to 2560x1600

with an Intel Core 2 Q8300, on an Asus P5Q3 standard mobo with a dual screen set-up.

My problem is as follows:

Gameplay is smooth, until for no apparent reason my computer will crash, blank black on both monitors with a sound loop coming from the speakers. Requires a full reset.

Blizzard, can we please get a response to this issue. Even "We are aware of the issue, and are unable to fix it due to ... reason ..." would be better to us than silence. This is a game breaking issue for any player wanting to play in hardcore mode, and I myself have personally lost my level 60 barb, who I spent over 40 hours gearing after 60. Any response would be better than no response. Let's see some blue in this thread.

EDIT: If you require further information about my system setup, please refer to the hardware profile associated with my account's beta opt-in.
Edited by Balah#1668 on 8/23/2012 10:48 AM PDT
Reply Quote
i have the same issue can play ok then after 20-30 mins boom
Reply Quote
I am a AMD Radeon user, and I have absolutely same issues as NVIDIA users has... what a coincidence ??? different cards same issues... blizzard fix ur damn game plz!
Edited by Зодиак#2539 on 8/25/2012 2:58 PM PDT
Reply Quote
For what it's worth, I just started having issues. I've only had the game for about 3 weeks and I bought the CD instead of downloading it. My entire box is new with the exception of my processor. This is what I've got:

Mainboard : Asus P5G41T-M LX3
Chipset : Intel G41
Processor : Intel Core 2 Duo E4500 @ 2200 MHz
Physical Memory : 16384 MB (4 x 4096 DDR3-SDRAM )
Video Card : NVIDIA GeForce GTX 460

At first, the only issues I had with the game is staying connected to it. Now, I get a pixelated screen, or it goes black with a lot of feedback, and I just now got the fuzzy pink snow crap people have been talking about and this is the first time it's happened while not in game. My card is barely 3 weeks old. I've updated all the drivers and it hasn't helped anything. I have not tried any other games with it yet because I just got D3 and I want to play it. Anyway, my card is different from what a lot of people are posting about so I thought I would add it to the list.
Reply Quote
I have and Ati Radeon 5770 and since yesterday Im having the same problem with the game freezing and looping sound. I test other games like Guild Wars 2 and League of Legends for hours and no problem at all.
Edited by Brugal1427#1409 on 10/27/2012 8:37 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]