Diablo® III

Cycling/spiking Frame Rate After Patch

(Locked)

Posts: 31
To people having this problem, try doing the following. I have this exact issue (on a MBP with the 9400M) and am able to solve it and get a steady frame rate (much higher than pre-patch) every time. Hope it helps someone.

1. Start the game. Do stuff until the fps cycling starts.
2. command-tab out of the game. let it sit for 10 to 15 seconds, then go back to the game.
3. If the fps has stabilized, continue playing. It will probably start cycling again soon.
4. If not, then repeat step 2.
5. When the cycling starts again, repeat steps 2 to 4.

In my experience, after three or four repetitions of the above steps, the cycling fps stops, not to return until the next time the game is played.
63 Tauren Death Knight
550
Posts: 6
I am running a macbook 2009, 2 ghz intel core 2 duo, 8 gb ddr3 nvidia geforce 9400m gpu.
updated drivers, did all the other stuff including deleting the cache and agent.db..
i run a solid 30fps for a 5-45is min window and then it will start going from 10-20-30-20-30-20-10 crazy fps jumps constantly.. if i minimize the window and click out of it for about 30 seconds and then go back on the application it will continue at 30fps for a few minutes and then go back to the fps choppy and jumpyness that it was at first. i think it was a step in the right direction i'd like to make sure blizzard see this and doesn't wash their hands of this problem quite yet. dont have a usb mic plugged in, no apps running in background. lowest settings including 800x600. Please reply.

I have also boot camped windows 8 consumer preview and it ran better than mac os side prior to 1.02. now it runs worse.
Posts: 43
Post contains spoilers, etc.

So it seems like overall framerate has increased. It has for me. Which is good.

But now the spikes are more frequent and worse than ever. Where before I could slog through and manage to play now its unplayable for the first time.

Best example is where I'm at right now. I'm just before Izual in Act IV. Whenever I approach his area, the cutscene gets skippy and then the game basically freezes, then unfreezes so I can see my now dead body.

Going to try and play it fresh when my computer's had a rest, and maybe the fps limiting even though mine's already limited.
Here's my info. Though FYI, I've had these problems since BEFORE the 1.02b patch

Model Name: MacBook Pro
Model Identifier: MacBookPro8,2
Processor Name: Intel Core i7
Processor Speed: 2.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.69f3
Serial Number (system): C02FD63QDF91
Hardware UUID: C1C65322-CC3D-54A0-A1AD-A4ADE468136E
Sudden Motion Sensor:
State: Enabled

AMD Radeon HD 6750M:

Chipset Model: AMD Radeon HD 6750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6741
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.23
EFI Driver Version: 01.00.573
Displays:
Color LCD:
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 1 day20:53
Confirmed. Same as the OP. 9600 though functioning at a higher fps now is still very unstable. Bouncing 50s to 20s to 8.
The issue seems to be heat related. I had the same FPS cycling issue just when the patch came out. Downloaded SMCFanControl and ran the game in Window mode showed FPS spike whenever temperature reached 80-85 C. I have a late 2008 unibody Macbook with 9400m.

I took out the fan and cleaned out the dust on the fan and on the heat sink, restarted the machine, set everything to low, and max foreground FPS to 20, max background FPS to 1, elevated the macbook on two cigarette cases(better air circulation) and that did the trick. No more FPS spike. I monitor the temperature and it seems to be stabilizing in the 70s C. The key is to set max foreground FPS to the most acceptable minimum, 20 sounds about right, so that your GPU doesn't heat as much.
85 Blood Elf Paladin
6715
Posts: 35
Last night I tried limiting my fps to 20 (i had it limited at 30 before), and also tried the tabbing fix someone posted above.

Neither did anything on my 8600m macbook pro :(

Mine seems to be dipping to 0 constantly

p.s. on my computer it is NOT heat related. My laptop will have been turned off, and completely cool, I enter the game, and it's just going nuts!!
Edited by Tean#1628 on 6/11/2012 8:44 AM PDT
MacBookPro5,5 with 4GB RAM and 9400M here, same issues as described in this thread.
Will try to reinstall my OS and upgrade to 8GB soon, but I hope one of the next patches addresses this problem
copy/paste from my thread:

I'm playing D3 on my early 2011 MBP, which is well above the recommended requirements to play.
However I get 23 FPS on the settings below and that's only in Town where nothing happens.
http://i46.tinypic.com/2iawtpg.png
I get ~34 FPS with shadows on medium
I get ~40 FPS with shadows on low
and ~46 FPS with shadows turned off.

When out of Town my FPS rate often jumps and it's something like (medium shadows) 40, 40, 38, 39, 40, 13, 15, 100, 41, which causes the game lag on a regularly basis.

UPDATE: After going for the default settings which are pretty much the lowest setting I'm getting ~70 FPS, however the lag persists! It's as if the game froze for a millisecond and in that split second time I can see the frame rate drops drastically. I think it mostly occurs right when a new animation stars (monster death, spell casting, etc.) And I don't mean only when then that animation is shown for the first time.

http://i48.tinypic.com/2sa1aw0.png


Here are my specs:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,2
Processor Name: Intel Core i7
Processor Speed: 2,2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.69f3
Serial Number (system): XXXXXXXXXXXX
Hardware UUID: XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX
Sudden Motion Sensor:
State: Enabled

AMD Radeon HD 6750M:

Chipset Model: AMD Radeon HD 6750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6741
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.23
EFI Driver Version: 01.00.573
Displays:
Color LCD:
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: XXXXXXX
User Name: XXXXXXXXXX
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 5:24

86 Blood Elf Paladin
5245
Posts: 142
For the record, my stuttering problems have all but gone away (I posted on the second page of this thread).

The game was stuttering constantly right after I patched, but in the subsequent days my performance now exceeds what I was getting pre-patch. Stuttering is only a problem in the first minute or so after logging into the game.

I'm basically running everything on low/off settings at 1280x800 resolution and getting 50-60 fps, and just a little bit lower during large battles. I changed my Hardware Class to "1" (from "2") and disabled Trilinear Filtering. I also force quit the Agent process whenever I play. I have a low-end graphics card so I am happy with my performance.

I'm not suggesting my case is typical-- it looks like there are still others with real problems, but this user is now doing much better.

My specs again:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i5
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.68f98
Serial Number (system): C1MH9DFYDV13
Hardware UUID: 0DB7AEB4-1F9B-52F7-9535-7611E3B0D26C
Sudden Motion Sensor:
State: Enabled

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Edited by Traumatic#1550 on 6/11/2012 2:03 PM PDT
Posts: 54
9600m user here just postin in, agree with people that after the patch there is better fps but frame spikes make it hard to play!

Glad blizz is actively trying to fix the issue though, and doing it in a timely manner.
Hey guys, have you tried disconnecting the power plug and any USB devices and then opening Diablo? After doing that just start a game and plug in your mouse/power/whatever.

I'm getting steady 31-32fps in town, lowering to 25-27fps during battles. That is, with every configuration set to high and AA on. I still do get some hiccups from the cycling/spiking issue, tho.

Running on early 2011 MBP base model.

Cheers!
Random note: Playing in windowed mode helps prevent the FPS dump for me.
Macbook 5,1
Spiking Reduced by upgrading memory from
4 GB 1066 to
8 GB 1333
Further tweaks like 1 Background fps to 15 Fourground fps made spiking unnoticeable.

However Cycling still occurs.
Cycling is periodic and using
OpenGL Driver Monitor from the XCode tools you can see CPU waiting for GPU and GPU spiking to 100% constant when the Cycling occurs. No correlation seen with spiking.

Periods are dependent on amount of memory in use. Clearing things up reduces the period the the Cycle. Activity Monitor can be used to terminate non essential applications like Finder. However, killing essential apps will result in needing to reboot.

I suspect something is striding though memory, and that most people who are having Cycling have shared VRam and not dedicated VRam. Macs seem to report all of the Memory unlike Windows that will subtract shared memory from the System memory. Cycling could be happening when this task hits the Shared VRam and performs memory locks as it scans.

Spiking I believe is related but is just System memory being locked briefly. Reducing the Background FPS if you have fast enough ram will reduce the impact.

Can someone confirm if they have Dedicated VRam and only Spiking and No Cycling, or if they are getting Cycling as well.

Spiking is where the FPS goes from 20 drops down for a second then right back up.
Cycling is where the FPS drops to 8 or less and stays their for a few mins before returning back to normal.
06/07/2012 11:19 AMPosted by Nalía
Just a heads up to you guys having trouble: booting in 64 bit mode helped me a little, the framerate cycling stopped. Still dropped to below 10 while fighting things, so it wasn't a good enough fix for me, but those of you with better machines, the fix may be as simple as holding 6 and 4 when booting up.


lion boots up as 64 bit by default, 10.6.8 can be chanegd to do it by default. some of the posters posting issues are already booted in 64 bit mode as seen by

64-bit Kernel and Extensions: Yes

as for it helping, probably a little. i do know 10.6.8 opengl behaves a little better in 64 bit mode.


Interesting.

I scanned though all the posts to confirm. It appears that people who have 64bit Kernels with over 4 Gigs of memory only report spiking and not Cycling when they report symptoms.

If I'm right about a task causing the problem because of a memory scan 64bit MIGHT help if MacOSX puts the Shared VRam into 64bit memory space(anything over 4 Gigs is 64bit memory space). Warden only can scan 32bit Memory space, and thus that would resolve the issue of Cycling if it is indeed Warden performing a Memory Lock.

I will have to See if I can get permission to Hack my Wifes Macbook 5,1 to get it into 64bit mode. It is unfortunately blacklisted from going into 64bit without a hack. I will post the results.
Edited by Vaux#1580 on 6/12/2012 9:27 AM PDT
Vaux
Macbook 5,1
Spiking Reduced by upgrading memory from
4 GB 1066 to
8 GB 1333
Further tweaks like 1 Background fps to 15 Fourground fps made spiking unnoticeable.


thats good news. I'll do that on Friday and see if it's playable then..
Funny thing is how I have the same issues (low fps+cycling) in 1280x800 and 800x600. Both on low everything obviously..
Vaux
Macbook 5,1
Spiking Reduced by upgrading memory from
4 GB 1066 to
8 GB 1333
Further tweaks like 1 Background fps to 15 Fourground fps made spiking unnoticeable.


thats good news. I'll do that on Friday and see if it's playable then..
Funny thing is how I have the same issues (low fps+cycling) in 1280x800 and 800x600. Both on low everything obviously..

Make sure your Mac supports it. The Macbook 5,1 only does if it received a secret firmware update.
90 Night Elf Druid
8480
Posts: 55
Hey guys, have you tried disconnecting the power plug and any USB devices and then opening Diablo? After doing that just start a game and plug in your mouse/power/whatever.

I'm getting steady 31-32fps in town, lowering to 25-27fps during battles. That is, with every configuration set to high and AA on. I still do get some hiccups from the cycling/spiking issue, tho.

Running on early 2011 MBP base model.

Cheers!


What res setting are you at? I have the same Macbook Pro and I am still having spiking issues in 1200x800. Runs fin between 25-40fps running around and in town the drops to 15 and lower during battles.
06/12/2012 12:23 PMPosted by Snertante
What res setting are you at? I have the same Macbook Pro and I am still having spiking issues in 1200x800. Runs fin between 25-40fps running around and in town the drops to 15 and lower during battles.


1440x900. It's weird. When I set everything to default - that means: changing res. to 1280x800, all confs. set to low - it gives me way more fps spikes/drops than everything on high + native res.

Also, I kept Max. Foreground FPS at default setting (150).

Make sure you set the correct video card before starting the game. Also, create a game and run around just to see if there was any improvement. Then connect your power adapter/mouse/etc.

Hope it works.
Pattern Change Since Patch

I had an exceptionally play session twice before the error kicked in. It's no longer cycling as far as I can tell. It ether was on constant at 8fps or it was normal at 15fps or 20fps depending on the setting I was using.

I can't say the 64bit Kernel did anything. The only time I've had the issue was in the 64bit kernel, but then I rebooted into 32 bit and it worked fine.

However, if this is Warden it maybe that all the the game servers haven't brought it back online yet.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]