Diablo® III

Diablo running slower than expected

Posts: 3
Hey all,

I made a graphics card and power supply purchase and was expecting it to run Diablo 3 smoothly, but it isn't working out too well. It is extremely slow when I first start playing, but about 5 minutes in, it runs decent on a smaller resolution, and all low/off effects etc. Two of my friends have equivalent graphics cards and power supplies (and relatively similar systems) and they run perfectly smooth on all the highest settings. Anyways, here is my specs and any help/recommendations would be greatly appreciated.

OS: Windows 7 Home Premium
System: HP Pavilion P6624Y
Processor: AMD Athlon(tm) II X4 635, 2900 Mhz
RAM: 8GB PC3-10600 DDR3 SDRAM
*UPGRADE* Graphics card: EVGA GeForce GTX560Ti
*UPGRADE* PSU: Corsair TX650 V2
Harddrive: 1TB (approx 700GB of free space)
Anti-Virus Norton software

Ran the "Windows Experience Index" and got the following results:
Processor - 7.3
Memory (RAM) - 7.3
Graphics - 7.6
Gaming Graphics 7.6
Primary Hard Disk transfer rate - 5.9

Side Question - Does anyone know how to permanently disable this 3D crap! It makes my screen look blurry, but it looks normal during Diablo/watching netflix.

Here is a link to the tower that I originally purchased:
http://www.bestbuy.com/site/olspage.jsp?type=product&id=1218251721702&AID=10597222&PID=2138476&SID=dl-659484&URL=http%3A%2F%2Fwww.bestbuy.com%2Fsite%2Folspage.jsp%3Ftype%3Dproduct%26id%3D1218251721702&ref=39&CJPID=2138476&loc=01

Any assistance would be awesome. If you need to know anything else about my specs, let me know.

Thanks!
Edited by TheDiddy#1175 on 6/5/2012 4:32 PM PDT
Reply Quote
100 Blood Elf Paladin
9210
Posts: 23,607
Did you make sure to connect both 6-pin PCI-E power plugs firmly into the graphics card?

I would check the CPU temperature.
Reply Quote
Norton is HORRRIBBBLEEEE. Turn off norton it should help out a lot. I use vipre...kaspersky is another good one. At the very least put some exceptions into norton to allow diablo/blizzard applications to run w/out being scanned.

Also, DO NOT PLAY IN WINDOWED MODE OF ANY KIND!!!! Play in fullscreen mode, if you play in any other mode besides fullscreen you will significantly hurt your gameplay.

Nvidia control panel should allow you to adjust the 3d settings as well.
Edited by Dro#1318 on 6/5/2012 5:34 PM PDT
Reply Quote
Posts: 3
GPU temp is running around 33 celcius regularly, then runs around 67 celcius while playing diablo, same as my friends GTX560Ti.

Both 6pin plugs are in firm, just double checked.

I just turned off all the Norton protections, lets see if that helps! I thought that may have to do with it, considering that is one of the main differences between me and my friend's setup.

The Nvidia control panel didn't seem to have any way to completely shutoff the 3D.

Also, I am running fullscreen mode, just had to reduce the resolution.

Time to give it a shot, thanks for the advice so far
Reply Quote
19 Blood Elf Paladin
4805
Posts: 333
Make sure drivers are up to date. Make sure Card isnt somehow malfunctioning. Make sure computer is turned on............
Reply Quote
06/06/2012 09:48 PMPosted by Anxiêty
Make sure drivers are up to date. Make sure Card isnt somehow malfunctioning. Make sure computer is turned on............


Your computer needs to be turned on?! OMG my computer can run D3 after all!!!
Reply Quote
Posts: 3
After playing last night for a couple hours, it appears Norton was definitely the major issue. I just turned off all the Norton protections for 5 hours and it was running 2-3 times better.

Thanks for the help.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]