Diablo® III

error 3007 every 10 minutes since last patch

same problem.
haven't been able to play after the patch.
Reply Quote
I am also experiencing this exact issue!

I can play any other multiplayer game just fine.
Reply Quote
I've been getting this problem consistently over the past few weeks too. It seems to be more frequent than usual since the 1.03 patch. This is extremely annoying. Trying to get some 5 stack going on A2 inferno for item farming. Get dc'ed after getting 2 stack. Logon again, get dc'ed with 2 stack. Logon again, get dc'ed with 3 stack . . . it is extremely challenging to even make 5 stack and this has nothing to do with the difficulty of elite packs, it's getting error 3007 every 10 mins. My connection to everything else is pretty good - never had these problems with other applications.

*Vista 64 bit
* Windows Firewall. Microsoft Security Essentials AV
* Atheros AR8121/AR8113 PCI-E Ethernet Controller
* Netgear DG834G Router
* ISP - iinet (australian ISP)
* WIred connection
* Location Perth, Western Australia
Reply Quote
lets hope this patch will fix this stupid problem!
Reply Quote
Posts: 13
My problem has intensified to where I disconnect after mere seconds.

In the future will I tell people that I quit this game because of something as lame as errors/bugs?

I hope not.
Reply Quote
I'm trying to kill Diablo in nightmare since yesterday but error 3007 makes it impossible. I experienced too many disconnections while I was so close to kill Diablo and now I'm here because of another disconnection. Also I have too much graphical lag. I don't have any problem with other games, It's only D3.

* MSI Laptop, i7-2630QM, GTX460M, 8G RAM
* Windows 7 64 bit
* Windows Firewall. Microsoft Security Essentials
* Network adapter: Realtek PCIe GBE Family Controller (Up to date)
* DSL Modem: E-CON MC8000UE-S1C
* Wired connection
* ISP - Turk Telekom (Turkish ISP)
* Location - Istanbul, Turkey

By the way, some days I can play for hours without any disconnection. It changes every day.
Edited by Cihan#1980 on 6/25/2012 7:45 AM PDT
Reply Quote
Please Blizzard this is obviously nothing to do with our hardware or software setup. This error 3007 occur to me only after the 1.0.3 patch. NOW I HAVE TO RUSH TO EVERY CHECK POINT TO AVOID GETTING KICK, PLEASE FIX THIS!!!!!!!!!!!!!!!!!!!!!!!
Reply Quote
Windows 7 64 bit
No firewall/antivirus
Realtek PCIe GBE Family Controller 6/10/2011 ( update stated best driver is already installed) version 7.46.610.2011
digital signer:Microsoft Windows Hardware Compatibility Publisher
Wired directly through to my Router:
Netgear WNDR 4500 (also updated to latest firmware)
Ports forwarded: 80, 1119, 6881-6999
Modem:
Motorolla SurfBoard SB6121
Charter Communications
Decatur, AL

Tracing route to attens.net [192.215.8.15]
over a maximum of 30 hops:

Tracing route to attens.net [192.215.8.15]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.1.1
2 11 ms 9 ms 7 ms 10.237.192.1
3 11 ms 8 ms 8 ms dtr02dctral-tge-0-7-0-6.dctr.al.charter.com [96.34.74.2]
4 13 ms 12 ms 11 ms crr02ledsal-tge-0-0-0-1.leds.al.charter.com [96.34.74.90]
5 10 ms 12 ms 14 ms crr01ledsal-tge-0-4-0-0.leds.al.charter.com [96.34.79.116]
6 20 ms 25 ms 20 ms crr01sghlga-tge-0-0-0-7.sghl.ga.charter.com [96.34.78.18]
7 30 ms 23 ms 24 ms bbr01atlnga-tge-0-2-0-10.atln.ga.charter.com [96.34.2.134]
8 21 ms 34 ms 22 ms atl-bb1-link.telia.net [213.248.99.149]
9 22 ms 23 ms 21 ms 192.205.33.41
10 81 ms 80 ms 84 ms cr1.attga.ip.att.net [12.122.84.22]
11 79 ms 74 ms 76 ms cr2.dlstx.ip.att.net [12.122.28.174]
12 82 ms 76 ms 76 ms cr1.dlstx.ip.att.net [12.122.1.209]
13 75 ms 80 ms 76 ms cr1.phmaz.ip.att.net [12.122.28.182]
14 80 ms 80 ms 78 ms cr1.sd2ca.ip.att.net [12.122.31.233]
15 80 ms 76 ms 76 ms gar3.sd2ca.ip.att.net [12.122.109.9]
16 77 ms 78 ms 78 ms 12.122.255.30
17 75 ms 75 ms 73 ms mdf2-bi8k-2-eth-2-1.san2.attens.net [63.241.1.214]
18 80 ms 74 ms 76 ms www0.attens.com [192.215.8.15]

Trace complete.

I'm also available for one on one troubleshooting. PM me if you want my phone number/skype etc

After posting this I feel that I need a firewall LOL
Edited by AhdDib#1386 on 6/25/2012 1:50 PM PDT
Reply Quote
YEP fix your !@#$ blizzard i just had a stormshield drop and as i was going to pick it up i get dropped that just crosses the line for me

i was even on a wired connection go %^-* your selves i am done with this game
Reply Quote
Posts: 17
I too had been plauged by 3007 errors. I finally got sick of trying to use a wireless connection and plugged straight into the router, and "Presto!!!" Playing for hours without a single DC. My only problem now is my wife is mad cuz I got addicted to the game, lol. Oh, and I occasionally end up suddenlt and without warning on my desktop with a window containing 20-sompn character long alphanumeric code to copy and paste into a message box to send to Blizz, and a button to restart the game. Kinda pain in the a** but, long stry short, the better your connection, the better your gaming experience (DON'T USE WIRELESS!!!)

p.s. I apologize to Blizzard for being such a *%*! before I solved my problem, however, some adjustments perhaos should be made on your end to help ppl with poor connections, just sayon'
Reply Quote
got same problem too with 3007 errors since new patch cant play the
the game anymore with my wireless connection
Edited by lindien74#1306 on 6/25/2012 2:49 PM PDT
Reply Quote
Posts: 1
this is crazy, keep getting into error 3007 since last patch too
Reply Quote
i still get error 3007 if i am on wired connection.... wtf?

when i first got d3 it never dropped me when i use wireless, what changed? :/
Reply Quote
Issue is still there, is getting worse now, closest I got to use a 5 stack was 5 min. Yay.

Got dced again with 5 stacks at the Butcher, dropped only blues, after that, duh.

It's a wired connection straight into the router, 50Mbs connection speed.

Getting worse as in more errors, errors switching heroes, have to close the game from task manager, etc.

BLIZZARD please read this:

IT WAS WORKING FINE BEFORE LAST PATCH ! 1.03 !

SAME COMPUTER SAME CONNECTION ETC !

IT'S NOT ME ( US) IT'S YOU !

Thank you .
Reply Quote
i havent been having any problems, :)

but using a wirless router shouldnt make any difference as to plugging a ethner cable straight into it, as long as the internet is running straight to your house, and then to your PC i dont see how there can be a problem unless you have just stragith up saterlight internet

ALSO AHDIB
isent this info from your DXdiag, like your IP adress and and other vitall information about your PC and all that sort of stuff, i mean i could be wrong but if it is, i think you should be deletting it or you will get HACKED !!!

Edited by AhdDib#1386 on 6/25/12 1:50 PM (PDT)

Windows 7 64 bitNo firewall/antivirusRealtek PCIe GBE Family Controller 6/10/2011 ( update stated best driver is already installed) version 7.46.610.2011digital signer:Microsoft Windows Hardware Compatibility PublisherWired directly through to my Router:Netgear WNDR 4500 (also updated to latest firmware)Ports forwarded: 80, 1119, 6881-6999Modem:Motorolla SurfBoard SB6121Charter CommunicationsDecatur, ALTracing route to attens.net [192.215.8.15]over a maximum of 30 hops:Tracing route to attens.net [192.215.8.15]over a maximum of 30 hops: 1 <1 ms <1 ms <1 ms 192.168.1.1 2 11 ms 9 ms 7 ms 10.237.192.1 3 11 ms 8 ms 8 ms dtr02dctral-tge-0-7-0-6.dctr.al.charter.com [96.34.74.2] 4 13 ms 12 ms 11 ms crr02ledsal-tge-0-0-0-1.leds.al.charter.com [96.34.74.90] 5 10 ms 12 ms 14 ms crr01ledsal-tge-0-4-0-0.leds.al.charter.com [96.34.79.116] 6 20 ms 25 ms 20 ms crr01sghlga-tge-0-0-0-7.sghl.ga.charter.com [96.34.78.18] 7 30 ms 23 ms 24 ms bbr01atlnga-tge-0-2-0-10.atln.ga.charter.com [96.34.2.134] 8 21 ms 34 ms 22 ms atl-bb1-link.telia.net [213.248.99.149] 9 22 ms 23 ms 21 ms 192.205.33.41 10 81 ms 80 ms 84 ms cr1.attga.ip.att.net [12.122.84.22] 11 79 ms 74 ms 76 ms cr2.dlstx.ip.att.net [12.122.28.174] 12 82 ms 76 ms 76 ms cr1.dlstx.ip.att.net [12.122.1.209] 13 75 ms 80 ms 76 ms cr1.phmaz.ip.att.net [12.122.28.182] 14 80 ms 80 ms 78 ms cr1.sd2ca.ip.att.net [12.122.31.233] 15 80 ms 76 ms 76 ms gar3.sd2ca.ip.att.net [12.122.109.9] 16 77 ms 78 ms 78 ms 12.122.255.30 17 75 ms 75 ms 73 ms mdf2-bi8k-2-eth-2-1.san2.attens.net [63.241.1.214] 18 80 ms 74 ms 76 ms www0.attens.com [192.215.8.15] Trace complete.I'm also available for one on one troubleshooting. PM me if you want my phone number/skype etcAfter posting this I feel that I need a firewall LOL
Reply Quote
I kept getting error 3007 all the time too. I tried getting 2 new wireless routers and even ran wired without the wireless and none of that worked so I called my cable company and told them I kept getting DC while playing an online game. They came out and checked my connections and told me my splitter and coax wire going to the modem were bad and old. Ever since then I never got 3007 again so if you have a splitter or maybe an old coax wire try changing those out first.
Edited by Grindin#1318 on 6/26/2012 12:50 PM PDT
Reply Quote
Powercyle done.
Ports opened.

never played this long in a while...4 hours in fact.
and then horror.. got disconnected again...and again.
network disconnection error 3007. ;/
Reply Quote
I've tried everything that has been suggested, reset ports, moved to DMZ, tried wired and wireless, tried different computers, completely bypassed router, disabled all virus/firewalls, updated my drivers on day 1, all other online games work fine including shooters so I'm not buying the "its on my end" company line. Very disappointing and I'm glad to see CNET give this game a 2.5 score. When the game works its fun, at least what I have seen of it...
Reply Quote
Posts: 11
Same issue, error 3007 after patch 1.03a. I can barely stay in a game for more than 10 minutes and i get removed, while getting disconnected from b.net with error 3007.

Power cycled modem + router, flushed dns, reinstalled/repatched diablo 3, port forwarded/opened and on a permanent wired connection. Traceroute showed NO missed hops.
Reply Quote
Windows 7 Ultimate 64 bit

No firewall/antivirus

Atheros L1 Gigabit Ethernet 10/100/1000Base-T Controller

Wired directly through to my Router

Manufacturer: 2Wire, Inc.
Model: 2701HGV-E Gateway
Ports forwarded: 80, 1119, 6881-6999

Tracing route to 12.129.209.68 over a maximum of 30 hops

1 <1 ms 2 ms <1 ms homeportal [192.168.1.254]
2 23 ms 23 ms 23 ms bb116-14-188-1.singnet.com.sg [116.14.188.1]
3 24 ms 23 ms 23 ms 202.166.119.97
4 25 ms 23 ms 24 ms xe-2-0-0-3600.tp-ar09.singnet.com.sg [202.166.124.149]
5 32 ms 22 ms 23 ms xe-10-0-0.budwesier.singnet.com.sg [202.166.126.1]
6 24 ms 106 ms 23 ms ae3-0.pepsi.singnet.com.sg [202.166.126.125]
7 23 ms 22 ms 23 ms 203.208.191.42
8 25 ms 23 ms 22 ms 203.208.152.209
9 212 ms 197 ms 203 ms so-3-0-0-0.plapx-cr2.ix.singtel.com [203.208.172.54]
10 221 ms 216 ms 213 ms 203.208.171.154
11 216 ms 220 ms 220 ms 67.17.192.141
12 225 ms 224 ms 223 ms 192.205.37.93
13 233 ms 240 ms 227 ms cr2.la2ca.ip.att.net [12.122.129.98]
14 204 ms 208 ms 212 ms gar29.la2ca.ip.att.net [12.122.129.241]
15 213 ms 208 ms 213 ms 12-122-254-234.attens.net [12.122.254.234]
16 216 ms 211 ms 224 ms mdf001c7613r0003-gig-12-1.lax1.attens.net [12.129.193.254]
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]