Diablo® III

error 3007 every 10 minutes since last patch

I have never had this issue since last patch . I also have a 40 Mb connection. The reason I know it is a Blizzard issue is this. I started streaming music as well as having a simple web page up to isolate the connection issue. I get no delay or skip in the streaming music and I do not lose the web page that I currently have open. I also play HON and I never disconnect during games.I check my connection through my service provider and I constantly run at 35 + Mb. This is clearly your problem Blizzard. Fix it. I'm tired of these non stop problems with your product . For all you trolls that will say " Leave the game' or whatever, how about this ," Fix the game I paid for, this is complete trash that a company such as this have so many issues with a game , first it's that, then it's that, then its that. The worse part is the monkeys at Blizzard just pass the blame onto the customers and pretty much tell them to eat it. If I bought a car or anything for that matter, and I had to constantly take it back for repairs or etc then I would receive a new product or a refund. Welcome to the real world Blizzard, where you have to actually back what you sell. Its not like I bought a wrench set from the dollar store and expect the quality of a Craftsmen tool set. This is Blizzard for crying out loud. Fix this issue , have some pride in your work."
/rage off


Did the exact same thing..
Reply Quote
Dear Blizzard,

I have no problem with the connection until the last patch.. I am so sick of repeating playing the same quest over and over again... I have no problem with my XBOX 360 online game for past 10 hours and here I got disconnect every 10 minute.. WTF!
Reply Quote
This is still happening Blizzard! Do you still go with the router problem? c'mon you want us all to replace our router when there is no problem when we use it on other internet related games?
Reply Quote
I have the same problem happening since last patch too... lost 5 stack twice now
Reply Quote
DCed 2 times yesterday, 1st time DC, group numbers re invite me back, i lost 5 buffs;
2nd DC, killing Diablo, the final stage, boss only has 10% life. they re-invite again. we won but i didnt get the !@#$ing boss killing.

system: win 7 ult 64 bit.
wire connect to cable model.
Reply Quote
This is still happening to me as well. Every 30 mins 3007. So frustrating. Happens when I am connected to the cable modem directly, happens when I am connecting through a router, happens when I am wireless. It doesn't matter how I am connected, it happens. No other online game has this problem. Is there any new info about this?
Reply Quote
I am having the same issue. I started a game the other night with a friend at Act1 and by the time the game "Starts" and you get to the gate to enter town, I would DC. It took me 15 minutes to just get into town---I get 3007 constantly. I am having DC issues as frequently as 30 seconds to 3 minutes.

I run a Toshiba Satellite on Win 7 64 bit. I don't lose skype calls, get browser errors, or DC from any other game that I play. Just like for Gozerajl, I have issues every way that I connect my pc to internet. I also have a new router, a cleaned system, and have tried accessing my game on different internet providers. I haven't been able to play this piece of crap game in almost a month without having issues. It's getting old.
Reply Quote
Tried all methods but to no avail
- portforward on router n firewall
- run game as adminstrator
- join chats
- set to dmz
- bought new computer and a new d3 copy (omg)

used my new computer at fren's place only experienced 1 dropout even though i sat right next to him. used my new computer at home = dc dc dc dc dc. Any clue there?

Com setup as follows:
Windows 7 64 bit
Windows firewall Ports forwarded: 80, 1119, 6881-6999 (same for router)

Realtek PCIe GBE Family Controller version 7.49.927.2011
Wired directly through to my Router:
2wire 2701HGV-E Gateway software: 5.29.133.25
Singtel, Singapore

Tracing route to 12.129.209.68 over a maximum of 30 hops

1 1 ms 3 ms 1 ms menu [192.168.1.254]
2 309 ms 34 ms 23 ms bb116-15-165-1.singnet.com.sg [116.15.165.1]
3 66 ms 29 ms 21 ms 202.166.121.249
4 396 ms 679 ms 740 ms xe-0-0-0-3500.tp-ar09.singnet.com.sg [202.166.124.153]
5 284 ms 389 ms 377 ms ae1-0.singha.singnet.com.sg [202.166.126.250]
6 23 ms 102 ms 285 ms ae6-0.pepsi.singnet.com.sg [202.166.126.97]
7 276 ms 66 ms 28 ms 203.208.191.42
8 201 ms 135 ms 21 ms ge-1-1-0-0.sngtp-ar6.ix.singtel.com [203.208.183.81]
9 269 ms 496 ms 188 ms so-2-0-0-0.plapx-cr3.ix.singtel.com [203.208.151.74]
10 687 ms 444 ms 455 ms 203.208.171.113
11 195 ms 214 ms 466 ms xe-7-1-1.sjc10.ip4.tinet.net [216.221.157.201]
12 340 ms 368 ms 412 ms xe-7-2-0.sjc12.ip4.tinet.net [89.149.187.46]
13 432 ms 202 ms 220 ms as7018.ip4.tinet.net [77.67.78.94]
14 577 ms 437 ms 393 ms cr1.sffca.ip.att.net [12.122.86.198]
15 247 ms 310 ms 275 ms cr1.la2ca.ip.att.net [12.122.3.122]
16 212 ms 230 ms 307 ms gar20.la2ca.ip.att.net [12.122.128.181]
17 340 ms 230 ms 235 ms 12-122-254-238.attens.net [12.122.254.238]
18 227 ms 218 ms 243 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.129.193.250]
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.
Reply Quote
Im having the problem too since patch. Have worked since release , tryed disable firewall on both windows and avast . tryed local port 80, 1119 etc on all d3 app. tryed with cable directly in com... still i get dc.. I´m so stuck right now.... anyone have a sulution or is this really Blizz end thats the problem?
Reply Quote
I'm having the same problem too since the last patch only. I have a wizard lv 60 paragon 15. If I log with a other e-mail where I have a wizard lv5, I have no problem. Soo : your server cannot suport the new patch with a hero lv60 with paragon ? I try to log on for already more then 2 hours now. And he still try to retrieve my hero for minutes until he kick me off, saying error 3007 or 3006. Yesterday, it was the only day that it was just working fine for 2 weeks now. Solution ? Going back to Diablo or Diablo 2 ???????
Reply Quote
85 Human Paladin
4070
Please save us this is hardly playable for us!!!!
i had feedback that this problem happen alot in canada quebec maybe due to our connection provider. You know how losing a game in d3 is realyy infuriating due to nephalim stack and others... please at least respond
Reply Quote
Same problem, unable to connect with my level 60 + 3 paragon wizard, but when i try on a different server like asia and europe, i am able to log in... weird.

I'm getting error 3006, with the north american server, fix this!
Reply Quote
ArcadianDS View profile

2 weeks without any problems and then after the latest patch, Ive been constantly getting error 3007 to the point that the game is no longer playable.

Blizzard suggests that I should replace my router? But its working on all the other games I own. Generally, you shouldn't buy replacement hardware for a single product that isn't working, when all others do. right?

Given the fact that I didnt have this problem until the patch, Im rather unconvinced. Also, port forwarding isn't an option as I have more than 1 gaming system, and while they both arent using Diablo3, some of the ports overlap other game titles.

We need a serious fix.

I wonder if its my authenticator.

#1
6/7/2012
Dankorii
Support Forum Agent

ArcadianDS

The error 3007 is being looked into. However, this is still an error that for the most part, would normally show up on poor connections. I'm not saying that's the case with your error 3007, but we should still make sure that everything is OK on your end.

Can you post some network information?

* Windows Xp, Vista, or 7 (also include if it's a 32 or 64 bit version)
* Firewall (McAfee, Norton, ZoneAlarm, etc.)
* Network Adapter brand, model, driver date, and driver version number (Steps below)

1. Click Start.
2. Click Control Panel.
3. Double-click on the System icon (in Windows XP, you may need to click Switch to Classic 4. View on the left hand side of the screen).
5. Select the Hardware tab.
6. Click on Device Manager
7. Expand the section labeled Network Adapters.
8. Right-click on your network card and select Properties.
9. Click on the "Driver" tab at the top

* Router brand and model # (this should be printed somewhere on the front or back or bottom)
* Cable or DSL Modem brand and model #(this should be printed somewhere on the front or back or bottom)
* ISP (Internet Provider)
* Is the connection wired or wireless
* Location (City, State)
* Traceroute ( http://us.battle.net/support/en/article/performing-a-traceroute )
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


Here is your problem blizzard and dont deny it.

whats happening is the battlenet server is redirecting us to a ip range that belongs to cerfnet.
when this happens go to your firewall log and the last few ips, do a whois ip and you will see,i dc every time i redirect to the blizz.cerfnet.richardson. richardson,tx.
I have added the ip to my whitelist to ensure it does not get blocked, but i still dc every time i get directed to a cerfnet server.

Its blizzards way to lighten there load, sorta like surfing the web, u are directed to the nearest server to avoid as many hops to get there. Blizz should rethink this stratagy. they cant control cerfnets load and lag like they can there own servers.
Reply Quote
Ever since Sunday, all games I play on D3 after 8pm eastern are unplayable. 350-800ms with anywhere from 2-6 seconds delay.
Reply Quote
yeah i get error 3007 and dc every 20 mins or somthign hear at my work , but at home its seems fine.
Reply Quote
Come on man, this !@#$ is getting ridiculous. Can't even get 5 stacks into a game before these RANDOM "TIME OUTS" happen. Bull%^-* it's a timeout, I WAS JUST HITTING A MOB, AND GETTING HIT. There was NO TIME for it to TIME OUT. It's bull!@#$, and it's YOUR problem. FIX IT.
Reply Quote
I'm also having the same issue with error 3007. It happens constantly, I even had the ISP come out and check out everything this morning...nothing wrong. I can get around 15 mins of playtime tops, most of the time i get an error 3007 within the first 5 minutes and have to re-log back in.
This is ridiculous...with all the $1 transaction fees + the 15% cuts you guys get from all the RMAH transactions this stuff should not be going on!!
Reply Quote
IT

IS

LAGGING

AGAIN
Reply Quote
I have not seen that error in along time. I went to walmart and bought me a new router and bam fixed.
Reply Quote
IT

IS

LAGGING

AGAIN
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]