Diablo® III

HDD Major-Stuttering Solved (Second Thread)

This worked for me until 1.04 and now D3 won't start if I use a link to a USB stick for the MPQ assets. Anyone else found this?
Reply Quote
90 Draenei Paladin
12250
I installed the full game to my flash drive. Since the new 1.04 patch i seem to have a stutter every so often and can't figure out why .
Reply Quote
mm, might try with the whole game on a stick.
Reply Quote
It does work if the game is on a usb stick but as others have noted, since 1.04, random fps drops still occur.
Reply Quote
If you want to try something a little simpler, but seemed to work out most if not all the stuttering i was getting.. try this. It might help, since it seems the OP's method doesn't work with the new version.

http://us.battle.net/d3/en/forum/topic/5596255489?page=1#16

i5 760, gtx 560ti, 8gb RAM, 1tb HDD - only game i've had problems with.
Edited by Jinglinggggg#1289 on 9/1/2012 9:29 PM PDT
Reply Quote
hey guys,i really wanna try this out but i do not have a 16g usb drive...is it possible to use a 8g and a 4g to solve this? thanks
Reply Quote
game doesn't open when i did these things
Reply Quote
I did something similar. Copied entire D3 folder to my slave HDD and the stuttering is now gone.

Edit: Isn't gone... still some little stuttering...
Edited by Fockink#1577 on 10/9/2012 1:25 PM PDT
Reply Quote
bump
Reply Quote
This didnt solve my stuttering though i guess I would call it more of a minor stutter...like a blip that occurs every 10-15 seconds. Ive tried just about everything to get rid of it yet it persists. Im done with this game.
Edited by Fusrodah#1817 on 10/10/2012 5:17 PM PDT
Reply Quote
Just wanted to say thanks! Copying the whole game to a 16GB flash drive worked for me :D
Reply Quote
I copied the MPQs folder onto my Seagate Backup Plus drive. For people that have backup drives, you can use them instead of a flash drive in the event that you do not have a ~16 GB flash drive. And since my backup drive is always connected via USB in the back of my desktop, it works very well.

Anyway, this worked for me, and pretty much got rid of any really noticeable stutter. The game is so smooth now; I've never seen it like this before. Most of the stuttering issues happened after patch 1.0.5, though I recall a bit of stutter in the previous patches. My particular stutter usually happened at the beginning of the game, when first encountering enemies, though as I encountered different enemies with different spells, etc., some of the stutter would return. It happened in sharp spikes, and sometimes caused me to die when playing with a high monster power.

I bet that this can also be done in StarCraft II instead of loading that custom preloading map every time, so I will give it a try a bit later.

Everyone should try this method. Thanks!
Edited by booseek#1655 on 10/18/2012 9:52 PM PDT
Reply Quote
I have a crucial m4 ssd. Its nothing to do with anyones HDD, its blizzards programming. Games shouldn't require you do any of this.
Reply Quote
I'd like to try this, but I don't want to go buy a flash drive only to have it mess up my computer or not even work..
What the hell.
Reply Quote
I may be asking something that's already been answered. I'm just not prepared to read through all the 20 pages of this thread and the initial one :(
Why does it have to be a flash drive? Does it matter if i'd made the link to just different partition? I have all my Blizz games on partition D, so i could make the copy on my system drive and link it there. Would that be enough? Thanx a bunch
Reply Quote
06/18/2012 10:46 AMPosted by Edstroyer
I am afraid that if i do buy a usb flash drive i will still have the same problem :(


The Flash drive solution has worked for every single person.

If you want to be absolutely sure before you purchase a Flash drive, you need to check your RRT in resource monitor. Put the game in windowed mode, and open resource monitor (or type "res" in windows start menu). You will need to monitor the read response time (RRT) under HDD-tab. If your RRT is above 10ms, then the flash drive will help you. If your RRT is below 5ms, then you have a different problem.


I have lauched resource monitor in Vista there is nothing saying RRT. Here is screenshot:
http://www.flickr.com/photos/86950836@N05/8124573560/
Just want to be sure . Is it 'response time (ms)' in the last column?
Would be thankful for help.
Reply Quote
anyone notice the asset loading never was a problem until one the first official patchs went live? so what changed anyways ^_^
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]