Diablo® III

HDD Major-Stuttering Solved (Second Thread)

SOLUTION (Windows XP) also works for windows 7/Vista (no command-line involved):

Follow steps 1 through 3 from windows 7 solution above
***Note: in windows XP, the "C:\Program Files\...." will not have the (x86) part.

4) Download a free program called "Link Shell Extension" from download.cnet website. This comes in two versions 32bit and 64bit. You have to install the right version depending on which windows XP you are using (most likely 32bit). After you install it, restart your computer.

5) Browse to the folder you created in step 3, for me it was "D:\MPQs", and righ-click on the "MPQs" folder, and select >"Pick Link Source".

6) Go to the original folder location on your hard drive:
"C:\Program Files\Diablo III\Data_D3\PC"

right-click anywhere inside the "PC" folder and select > Drop As ..> Symbolic Link ( or Junction).

Thats it! your done!

Anyone knows how to do it only for audio and textures? From what i heard you don't actually need to link whole folder. Those 2 files are essential. I don't have that big pendrive so I'm looking for a way to link only those 2 files, can't get it done for now... Need detailed tutorial for this one.
Reply Quote
IF I try to run the game on my 350GB Hard disc drive. I get constant freeze ups for about 1-10 seconds on elite mobs or when anything intensive happens.

When I put the game on my 20GB solid state drive it plays perfectly.

I'm just wondering why Blizzard wont fix this.

Could a blizzard employee please explain why you won't fix a known broken aspect of your game

2 threads full of 40+ pages should be more than enough to get your act together.

Let us consumers know whats going on and when this problem will be fixed.

I don't like to be forced to run the game from my SSD. THANKS.


Never thought a hacker who stole my account would log on and complain about a free game, LOL. Thanks bro your are hilarious.
Reply Quote
bump
Reply Quote
does this work for windows 8??
Reply Quote
i tried this with a 16gb stick and i was surprised that it actually works, the game runs a lot smoother, considering to buy an ssd in the future, when prices are a bit reasonable

ps: would it have the same effect if i would intall the entire game on the stick?
Edited by Giordax#1591 on 7/13/2013 8:59 AM PDT
Reply Quote
for those who wants to change the path back to where it was before:

as the command just add a shortcut folder to a specified path, all you have to do is, just delete the shortcut folder in C:\Program Files (x86)\Diablo III\Data_D3\PC, in this case, "MPQs", and rename the original folder to the original name which is "MPQs"

hope this helps
regards
Reply Quote
Sounds like you should run a chkdsk on your drive and repair whatever broken sectors you have, and backup your drive and get a new one because yours is on its way out if the read time is getting that bad. Splurge for a ssd and a couple tb external drive to make up for the difference and you will notice a world of difference.
Reply Quote
I don't know whether its coincidence. After using this method to solve the stuttering issue, I have been unabled to use the RMAH. I can't sell in RMAH and I can't buy in RMAH. All I get is a transaction error. Anybody else having this problem?
Reply Quote
I bought a 16gb MicroSDHC Class 4 yesterday and when I was going to put the MPQs folder in it I realized the folder weighs 14,8gb , my card has 14,6gb so It doesn't fit it... are there any files you don't need here? I don't want to waste it for 200mb

Do you have to do something else? Here's my screenshot: http://s7.postimg.org/rjz976zrf/Sin_t_tulo.png

Thanks for your help
Reply Quote
I bought a 16gb MicroSDHC Class 4 yesterday and when I was going to put the MPQs folder in it I realized the folder weighs 14,8gb , my card has 14,6gb so It doesn't fit it... are there any files you don't need here? I don't want to waste it for 200mb

Do you have to do something else? Here's my screenshot: http://s7.postimg.org/rjz976zrf/Sin_t_tulo.png

Thanks for your help


damn man you shoulda got a better SDHC. I just got a 32GB sdhc with a speed of UHS-1 which is faster than class 10. the game runs so smoothly now.
Edited by Legendary#1566 on 8/2/2013 4:37 PM PDT
Reply Quote
I bought a 16gb MicroSDHC Class 4 yesterday and when I was going to put the MPQs folder in it I realized the folder weighs 14,8gb , my card has 14,6gb so It doesn't fit it... are there any files you don't need here? I don't want to waste it for 200mb

Do you have to do something else? Here's my screenshot: http://s7.postimg.org/rjz976zrf/Sin_t_tulo.png

Thanks for your help


very odd. my MPQ is only 12gb if i look at its total.
try this..
go to MPQ folder. then delete cache.
after you do that load the game back up and it should reload the files. if it still ends up being too large then just dont copy over the cache folder. its not as important.
Reply Quote
This fix worked wonders for my game. In Retrospect, I can't believe I played the entire game with the stutter (it wasn't as bad when I started because it was a fresh OS install and on a formatted, barely used hard drive) I noticed the stutter getting bad over the months until I just gave up, thought it was the latency online, and uninstalled the game, until last night.

Thanks Edstroyer- you just made my day :D
Reply Quote
If you get a message that says something like: "a symbolic link has been created .." then you did it right. Your done!

I did all the steps correctly but how do I confirm that it is done? I do not see a symbolic link. I do see a new folder of MPQs in my C folder on top of the renamed file of old MPQ

Have I done it correctly?
Reply Quote
How can you tell the difference between this and the Vsync stutter people are experiencing? I know I have one of them, but can't tell which one.
Reply Quote
holy crap thanks a lot. nothing else worked. all these useless videos that claim to fix it by deleting the text file are rubbish. it's a shame this is the only viable option for now though, because it took up the last 12gb on my SSD.
Reply Quote
thank you for the fix

I figured when I checked v-sync , fps is kept maximum at 60 I still got the fps lag problem, so I put it to default settings which is vsync off and anti-aliasing on, max out the fps and put everything in high, including shadow quality in high(smooth), now I get 150fps that drops down to 40-50 but without any lag and the quality is so much better!
Reply Quote
Has Blizzard ever released anything official on this issue or are they just neglecting their clients as usual?
Reply Quote
09/15/2013 10:45 AMPosted by Eggochiggo
Has Blizzard ever released anything official on this issue or are they just neglecting their clients as usual?


Yes they acknowlidged the issue over a year ago, and even suggested doing this solution as one of their suggestions.
Reply Quote
Is there a bare minimum speed required for a thumb drive? I am going to purchase one to try this out, but I don't want to get a slow one and have the same thing happen.
Reply Quote
MVP - Technical Support
View profile
If you can get one that is faster, do it, but most people get an improvement even off the USB 2.0 drives and those are not expensive. Even if it does not work, they end up being useful anyway so it is a fairly safe/efficient thing to try.

Keep in mind, it only helps if the issue is related to your hard drive access speed. You can try defragging first. You can also try running in selective startup mode to eliminate the possibility that other programs are stealing resources. https://us.battle.net/support/en/search?q=selective%20startup

If those don't work, then try the USB option.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]