Diablo® III

Patch Required

I tried to log in today a few times after my game was already "Up to date" after installing some minor updates and I constantly get this message :
"A new patch for Diablo III is available. THe game will now close and apply the patch automatically. You will be able to continue playing after the patch has been applied. "
Then the game minimizes and I get some troubleshooter that suggests to either close Diablo III or look for online solutions... Please tell me how to fix that ,
Thanks

P.S. I tried restarting my computer and trying again afterwards but still nothing happened.
Reply Quote
Support Forum Agent
Posts: 29,255
Vanguard, I would try right-clicking on the shortcut, and choosing "Run as administrator" first, and follow up with these steps.
________________________________________________
Support Information
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Hello Velnrak, I tried what you said and I followed exactly the steps given, yet I still have the problem, after the game minimizes/closes the window that says "Diablo III has stopped working" still appears and I have to either look for online solution or terminate the program ...
Reply Quote
Support Forum Agent
Posts: 29,255
Can you post some computer information from the Direct X Diagnostic Tool (dxdiag)?

  • Hit the Windows key, and type:
  • dxdiag
  • Hit Enter or OK

Click on the Save All Information button at the bottom, and Save a DxDiag text file.
Copy and paste everything, except for the last section:
------------------
DirectShow Filters
------------------

After you paste everything into a post, highlight everything, and hit the "pre" button (It says "Code Blocks" when you hover your mouse over it).
________________________________________________
Support Information
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
------------------
System Information
------------------
Time of this report: 6/13/2012, 04:12:30
Machine name: gorilla-84
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_qfe.101209-1646)
Language: Korean (Regional Setting: Korean)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10
Processor: Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz (4 CPUs)
Memory: 3574MB RAM
Page File: 752MB used, 6231MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: NVIDIA GeForce GTX 560 Ti
Manufacturer: NVIDIA
Chip type: GeForce GTX 560 Ti
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_1200&SUBSYS_83BF1043&REV_A1
Display Memory: 1024.0 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor: Monitor Max Res: 1600,1200
Driver Name: nv4_disp.dll
Driver Version: 6.14.0012.8026 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 8/3/2011 20:49:00, 4210816 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: N/A
Mini VDD: nv4_mini.sys
Mini VDD Date: 8/3/2011 20:49:00, 12542592 bytes
Device Identifier: {D7B71E3E-5140-11CF-A96C-B3A300C2CB35}
Vendor ID: 0x10DE
Device ID: 0x1200
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

-------------
Sound Devices
-------------
Description: Realtek HD Audio output
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_10438445&REV_1003
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: RtkHDAud.sys
Driver Version: 5.10.0000.6251 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 11/23/2010 19:16:56, 6203496 bytes
Other Files:
Driver Provider: Realtek Semiconductor Corp.
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 8000, 192000
Static/Strm HW Mix Bufs: 33, 32
Static/Strm HW 3D Bufs: 33, 32
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
Description: Realtek HD Audio Input
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: RtkHDAud.sys
Driver Version: 5.10.0000.6251 (English)
Driver Attributes: Final Retail
Date and Size: 11/23/2010 19:16:56, 6203496 bytes
Cap Flags: 0x41
Format Flags: 0xFFF

-----------
DirectMusic
-----------
DLS Path: C:\WINDOWS\SYSTEM32\drivers\GM.DLS
DLS Version: 1.00.0016.0002
Acceleration: n/a
Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port
Microsoft MIDI Microsoft GS Wavetable SW Synth [ Registry: OK
Test Result: Not run

-------------------
DirectInput Devices
-------------------
Device Name: Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Poll w/ Interrupt: No
Registry: OK

-----------
USB Devices
-----------
+ USB | Vendor/Product ID: 0x8086, 0x1C2D
| Matching Device ID: usb\root_hub20
| Service: usbhub
| Driver: usbhub.sys, 4/13/2008 15:15:38, 59520 bytes
| Driver: usbd.sys, 8/29/2001 20:00:00, 4736 bytes
|
+-+ | | Vendor/Product ID: 0x8087, 0x0024
| | Location: USB Device
| | Matching Device ID: usb\class_09
| | Service: usbhub
| | Driver: usbhub.sys, 4/13/2008 15:15:38, 59520 bytes

----------------
Gameport Devices
----------------

------------
PS/2 Devices
------------
+ PS/2 Keyboard
| Matching Device ID: *pnp0303
| Upper Filters: L8042Kbd
| Service: i8042prt
| Driver: i8042prt.sys, 4/13/2008 22:27:00, 48896 bytes
| Driver: kbdclass.sys, 4/13/2008 22:30:24, 23680 bytes
| Driver: kbdkor.dll, 8/29/2001 11:00:00, 8192 bytes
| Driver: kbd101a.dll, 8/29/2001 11:00:00, 6144 bytes
| Driver: L8042Kbd.sys, 8/25/2010 02:30:06, 20304 bytes
|
+ | Matching Device ID: root\rdp_kbd
| Upper Filters: kbdclass
| Service: TermDD
| Driver: termdd.sys, 4/13/2008 22:58:00, 40840 bytes
| Driver: kbdclass.sys, 4/13/2008 22:30:24, 23680 bytes
|
+ Logitech HID-compliant G1 Optical Mouse
| Vendor/Product ID: 0x046D, 0xC01F
| Matching Device ID: hid\vid_046d&pid_c01f
| Upper Filters: LMouFilt
| Lower Filters: LHidFilt
| Service: mouhid
| OEMData: 00 00 00 00 00 00 00 00
| Driver: mouhid.sys, 8/27/2001 06:09:50, 12160 bytes
| Driver: mouclass.sys, 3/3/2010 18:29:21, 22144 bytes
| Driver: LHidFilt.Sys, 8/25/2010 02:30:52, 38864 bytes
| Driver: LMouFilt.Sys, 8/25/2010 02:31:02, 37328 bytes
| Driver: LkmdfCoInst.dll, 8/25/2010 02:31:02, 1581136 bytes
| Driver: LMouFiltCoInst.dll, 8/25/2010 02:31:14, 53328 bytes
|
+ | Matching Device ID: root\rdp_mou
| Upper Filters: mouclass
| Service: TermDD
| Driver: termdd.sys, 4/13/2008 22:58:00, 40840 bytes
| Driver: mouclass.sys, 3/3/2010 18:29:21, 22144 bytes

----------------------------
DirectPlay Service Providers
----------------------------
DirectPlay8 Modem Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 Serial Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 IPX Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 TCP/IP Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
Internet TCP/IP Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.2600.5512)
IPX Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.2600.5512)
Modem Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.2600.5512)
Serial Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.2600.5512)

DirectPlay Voice Wizard Tests: Full Duplex: Not run, Half Duplex: Not run, Mic: Not run
DirectPlay Test Result: Not run
Registry: OK

-------------------
DirectPlay Adapters
-------------------
DirectPlay8 Serial Service Provider: COM1
DirectPlay8 IPX Service Provider: IPX Adapter 1 - (00000000,14DAE9E9B6BE)
DirectPlay8 TCP/IP Service Provider:
-----------------------
DirectPlay Voice Codecs
-----------------------
Voxware VR12 1.4Voxware SC06 6.4Voxware SC03 3.2MS-PCM 64MS-ADPCM 32.8Microsoft GSM 6.10 13TrueSpeech(TM) 8.6
-------------------------
DirectPlay Lobbyable Apps
-------------------------

------------------------
Disk & DVD/CD-ROM Drives
------------------------
Drive: C:
Free Space: 17.6 GB
Total Space: 53.7 GB
File System: NTFS
Model: ST31000524AS

Drive: D:
Free Space: 364.5 GB
Total Space: 900.2 GB
File System: NTFS
Model: ST31000524AS

--------------
System Devices
--------------
Name: Intel(R) 82801 PCI Bridge - 244E
Device ID: PCI\VEN_8086&DEV_244E&SUBSYS_00000000&REV_B5\3&11583659&0&E4
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) H61 Express Chipset Family LPC Interface Controller - 1C5C
Device ID: PCI\VEN_8086&DEV_1C5C&SUBSYS_00000000&REV_05\3&11583659&0&F8
Driver: C:\WINDOWS\system32\DRIVERS\isapnp.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:29:52, 36480 bytes

Name: Intel(R) Management Engine Interface
Device ID: PCI\VEN_8086&DEV_1C3A&SUBSYS_844D1043&REV_04\3&11583659&0&B0
Driver: C:\WINDOWS\system32\DRIVERS\HECI.sys, 7.00.0000.1144 (English), 10/19/2010 16:33:40, 41088 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D
Device ID: PCI\VEN_8086&DEV_1C2D&SUBSYS_844D1043&REV_05\3&11583659&0&D0
Driver: C:\WINDOWS\system32\drivers\usbehci.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:36, 30208 bytes
Driver: C:\WINDOWS\system32\drivers\usbport.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:38, 143872 bytes
Driver: C:\WINDOWS\system32\usbui.dll, 5.01.2600.5512 (Korean), 4/13/2008 22:57:04, 68096 bytes
Driver: C:\WINDOWS\system32\drivers\usbhub.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:38, 59520 bytes
Driver: C:\WINDOWS\system32\hccoin.dll, 5.01.2600.5512 (English), 4/14/2008 06:56:44, 7168 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26
Device ID: PCI\VEN_8086&DEV_1C26&SUBSYS_844D1043&REV_05\3&11583659&0&E8
Driver: C:\WINDOWS\system32\drivers\usbehci.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:36, 30208 bytes
Driver: C:\WINDOWS\system32\drivers\usbport.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:38, 143872 bytes
Driver: C:\WINDOWS\system32\usbui.dll, 5.01.2600.5512 (Korean), 4/13/2008 22:57:04, 68096 bytes
Driver: C:\WINDOWS\system32\drivers\usbhub.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:38, 59520 bytes
Driver: C:\WINDOWS\system32\hccoin.dll, 5.01.2600.5512 (English), 4/14/2008 06:56:44, 7168 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family SMBus Controller - 1C22
Device ID: PCI\VEN_8086&DEV_1C22&SUBSYS_844D1043&REV_05\3&11583659&0&FB
Driver: n/a

Name: High Definition AudioDevice ID: PCI\VEN_8086&DEV_1C20&SUBSYS_84451043&REV_05\3&11583659&0&D8
Driver: C:\WINDOWS\system32\DRIVERS\hdaudbus.sys, 5.10.0001.5013 (English), 4/13/2008 21:06:06, 144384 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family PCI Express Root Port 6 - 1C1A
Device ID: PCI\VEN_8086&DEV_1C1A&SUBSYS_00000000&REV_B5\3&11583659&0&E5
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family PCI Express Root Port 4 - 1C16
Device ID: PCI\VEN_8086&DEV_1C16&SUBSYS_00000000&REV_B5\3&11583659&0&E3
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family PCI Express Root Port 3 - 1C14
Device ID: PCI\VEN_8086&DEV_1C14&SUBSYS_00000000&REV_B5\3&11583659&0&E2
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family PCI Express Root Port 2 - 1C12
Device ID: PCI\VEN_8086&DEV_1C12&SUBSYS_00000000&REV_B5\3&11583659&0&E1
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family PCI Express Root Port 1 - 1C10
Device ID: PCI\VEN_8086&DEV_1C10&SUBSYS_00000000&REV_B5\3&11583659&0&E0
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family 2 port Serial ATA Storage Controller - 1C08
Device ID: PCI\VEN_8086&DEV_1C08&SUBSYS_844D1043&REV_05\3&11583659&0&FD
Driver: C:\WINDOWS\system32\DRIVERS\intelide.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:29:08, 5504 bytes
Driver: C:\WINDOWS\system32\DRIVERS\pciidex.sys, 5.01.2600.5512 (Korean), 4/13/2008 15:10:30, 24960 bytes
Driver: C:\WINDOWS\system32\DRIVERS\atapi.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:32, 96512 bytes

Name: Intel(R) 6 Series/C200 Series Chipset Family 4 port Serial ATA Storage Controller - 1C00
Device ID: PCI\VEN_8086&DEV_1C00&SUBSYS_844D1043&REV_05\3&11583659&0&FA
Driver: C:\WINDOWS\system32\DRIVERS\intelide.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:29:08, 5504 bytes
Driver: C:\WINDOWS\system32\DRIVERS\pciidex.sys, 5.01.2600.5512 (Korean), 4/13/2008 15:10:30, 24960 bytes
Driver: C:\WINDOWS\system32\DRIVERS\atapi.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:32, 96512 bytes

Name: Xeon E3-1200/2nd Generation Intel(R) Core(TM) Processor Family PCI Express Root Port - 0101
Device ID: PCI\VEN_8086&DEV_0101&SUBSYS_00000000&REV_09\3&11583659&0&08
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: 2nd Generation Intel(R) Core(TM) Processor Family DRAM Controller - 0100
Device ID: PCI\VEN_8086&DEV_0100&SUBSYS_00000000&REV_09\3&11583659&0&00
Driver: n/a

Name: PCI Device ID: PCI\VEN_1B21&DEV_1080&SUBSYS_00000000&REV_01\4&26E44130&0&00E4
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (Korean), 4/13/2008 22:32:58, 66688 bytes

Name: Realtek PCIe GBE Family Controller #3
Device ID: PCI\VEN_10EC&DEV_8168&SUBSYS_84321043&REV_06\4&C702080&0&00E2
Driver: n/a

Name: NVIDIA GeForce GTX 560 Ti
Device ID: PCI\VEN_10DE&DEV_1200&SUBSYS_83BF1043&REV_A1\4&8F789FD&0&0008
Driver: C:\Program Files\NVIDIA Corporation\Drs\dbInstaller.exe, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 174592 bytes
Driver: C:\Program Files\NVIDIA Corporation\Drs\nvdrsdb.bin, 8/3/2011 20:49:00, 280276 bytes
Driver: C:\Program Files\NVIDIA Corporation\license.txt, 8/3/2011 20:49:00, 15511 bytes
Driver: C:\WINDOWS\system32\DRIVERS\nv4_mini.sys, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 12542592 bytes
Driver: C:\WINDOWS\system32\OpenCL.dll, 1.00.0000.0000 (English), 8/3/2011 20:49:00, 61440 bytes
Driver: C:\WINDOWS\system32\nv4_disp.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 4210816 bytes
Driver: C:\WINDOWS\system32\nvapi.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 2404864 bytes
Driver: C:\WINDOWS\system32\nvcompiler.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 17186816 bytes
Driver: C:\WINDOWS\system32\nvcuda.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 5427200 bytes
Driver: C:\WINDOWS\system32\nvcuvenc.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 2090088 bytes
Driver: C:\WINDOWS\system32\nvcuvid.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 2387560 bytes
Driver: C:\WINDOWS\system32\nvdata.data, 8/3/2011 20:49:00, 2128778 bytes
Driver: C:\WINDOWS\system32\nvinfo.pb, 8/3/2011 20:49:00, 3249 bytes
Driver: C:\WINDOWS\system32\nvoglnt.dll, 6.14.0012.8026 (English), 8/3/2011 20:49:00, 16191488 bytes
Driver: C:\WINDOWS\system32\nvdispco32.dll, 2.00.0017.0000 (English), 8/3/2011 20:49:00, 914024 bytes
Driver: C:\WINDOWS\system32\nvgenco32.dll, 2.00.0012.0000 (English), 8/3/2011 20:49:00, 875112 bytes

Name: High Definition AudioDevice ID: PCI\VEN_10DE&DEV_0E0C&SUBSYS_83BF1043&REV_A1\4&8F789FD&0&0108
Driver: C:\WINDOWS\system32\DRIVERS\hdaudbus.sys, 5.10.0001.5013 (English), 4/13/2008 21:06:06, 144384 bytes
Edited by Velnrak on 6/12/2012 12:19 PM PDT
Reply Quote
what to do from here i dont understand. what is the "pre" button?
Reply Quote
Support Forum Agent
Posts: 29,255
Do you have all of the latest Windows Updates?

06/12/2012 11:59 AMPosted by Vanguard
after the game minimizes/closes the window that says "Diablo III has stopped working"

Is there anything more to this error?
________________________________________________
Support Information
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Posts: 2
I have the exact same problem. It has occured to me earlier, but got fixed the next day for some reason, I guess the game actually patched or something.

I've tried all the standard reasons for this to happen, but it occurs even if I don't use my normal login info. It seems to be something happening in the game itself, I can log onto the US and SEA servers FYI. Made a ticket but no1 replied until the problem fixed itself. its weird though, all of my friends can still play as we speak.
Reply Quote
Velnrak, its not only him its alot of people that have this issue, nothing wrong with our computers or hard drive...
Reply Quote
I have the same/similar issue. I opened the Launcher and it began to install the patch. Once done, I clicked play. I typed in my E-mail and Password and clicked enter. Then as it comes up with the screen which says "Connecting to Diablo 3 servers" blah, it said that I need the latest patch and closes with the same message said by the guys above.
Reply Quote
It is the famous patch-loop thingy. there are few stickied thread already, but, i tried everything, nothing helped me. Im playing US version of game in Europe servers.
1. I can join to US server and play
2. If i switch region to Europe - i get infinite patch loop
3. Found a way to play a game - thats an easy way out. If nothing helps - uninstall d3 and start installing it again. When the game is playable - from 30% or something to 99% - freeze the downloading every time. If u install game to 100% - u get patch loop again. Hope this helps for ppl who cant play the game.
Reply Quote
been there done that, does not work!
Reply Quote
ive tried the run as admin thing. now it still ask for an update patch, and when i click on, it gives me an error 740
Reply Quote
Posts: 1
Same thing is happening to me

""I tried to log in today a few times after my game was already "Up to date" after installing some minor updates and I constantly get this message :
"A new patch for Diablo III is available. THe game will now close and apply the patch automatically. You will be able to continue playing after the patch has been applied. "
Then the game minimizes and I get some troubleshooter that suggests to either close Diablo III or look for online solutions... Please tell me how to fix that ""

please help
Reply Quote
yeah after the game tells me that i need a new patch, it minimize, then tells me i have already another d3 open, and then closes.
Reply Quote
90 Tauren Warrior
6870
Posts: 44
Do you have all of the latest http://www.windowsupdate.com/" class="bml-link-url2">Windows Updates</a>?

after the game minimizes/closes the window that says "Diablo III has stopped working"

Is there anything more to this error?
________________________________________________
Support Information
<a href="http://us.battle.net/support
'Constant change is here to stay.'


Velnrak,
I have had this problem both with this patch AND the previous patch a week ago.

Last time, I was able to play the next day. But not until then.

I'm a bit aggravated that both myself AND hundreds, if not thousands, of other people have had this same problem. And, neither last week, since last week, nor apparently TODAY has ANYBODY, blue or not, been aware of the issue.

Could you please talk to your supervisors about this. It's sad that there has not been a fix yet. I am in America. I can switch to Europe and play just fine. I just cant play on my own server without it saying "there is a patch, diablo 3 will now restart and apply it" and then D3 crashes.

Blizz NEEDS to get off their butts and fix this. If it only happened once, then oh well. But again the very next week???? Lazy. Who knows how many more patches will cause this problem???????!
Reply Quote
Same thing is happening to me

""I tried to log in today a few times after my game was already "Up to date" after installing some minor updates and I constantly get this message :
"A new patch for Diablo III is available. THe game will now close and apply the patch automatically. You will be able to continue playing after the patch has been applied. "
Then the game minimizes and I get some troubleshooter that suggests to either close Diablo III or look for online solutions... Please tell me how to fix that ""

please help


reinstall the game and dont let it to download 100% while waiting for a fix. every time you doubleclick d3 icon spam play button. I had my game downloaded to 70% played teh game for a week. today i forgot about patch loop, letting game fully download - got the problem again.
Reply Quote
yeah i had the same prob last week too. coudnt play till next day too.
Reply Quote
Have the same problem.. Have not switched from US to EU or the other way around.

It seems like the first time you start the game, the initializer on the launcher takes for ever to load (patching something?). Then I get the login screen, trying to log in and get the 704 error (the requested operation requires elevation).

Now I'm stuck in this loop.. Must be something the patcher is doing, not our systems.
Running on win 7 with Nividia Geforce 8800 GTS, DX 11

Edit: It seems like I can start a new character on US server, where I normally play on EU.
The EU server seems to be broken for me.
Edited by Iritia#2272 on 6/12/2012 1:11 PM PDT
Reply Quote
Getting this error at the moment as well.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]