Diablo® III

Broken framerate limits on AMD Radeon HD 7850

Originally posted this in the bug report section, but also bringing it here. As the title says. This issue is reproduced by limiting the framerate. Image can be seen at http://i.imgur.com/QekUH.jpg

In section 1 I show that the issue happens in fullscreen mode when I limit the framerate. Up until 99, it limits it to 50FPS.

In section 2, I show the issue persists into windowed mode (this is the mode I enjoy playing, too). Up until about 154, it never lets it pass 100FPS.

In section 3, I show how messed up v-sync is. 30FPS? Come on...

In section 4, I show my FPS without any limitation.

Please fix this, I would prefer to limit my framerate to 121 so I can have the least amount of screen tearing without the laggy input and obviously bugged v-sync. All my DX binaries and drivers are up to date.

Specifications (and these are 100% stable 24/7):
OS: Windows 7 Enterprise 64-bit
CPU: Intel Core i5 2500K @ 4.5GHz
GPU: AMD Radeon HD 7850 @ 1150MHz Core, 1405MHz Memory
RAM: 8GB 1600MHz DDR3
HDD: 120GB OCZ Agility 3
Reply Quote
No help?
Reply Quote
Blizzard quality tech support, I suppose.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]