Diablo® III

Crazy High Latency

Since the new patch was released my latency has jumped from 50-80 msec to 300-1600 msec. Nothing has changed on my end but every game im in now the lowest my latency is at is 300 and it never stays at 300 for more then a minute or two. When entering WP's or other players banners the lag is so bad that the entire game freezes. Im still able to chat real time but my screen completely freezes up.

Anyone have any suggestions/solutions? :(
Reply Quote
Support Forum Agent
Posts: 36,017
DrunknSticky

Can you post some network information?

* Windows Xp, Vista, or 7 (also include if it's a 32 or 64 bit version)
* Firewall (McAfee, Norton, ZoneAlarm, etc.)
* Network Adapter brand, model, driver date, and driver version number (Steps below)

1. Click Start.
2. Click Control Panel.
3. Double-click on the System icon (in Windows XP, you may need to click Switch to Classic 4. View on the left hand side of the screen).
5. Select the Hardware tab.
6. Click on Device Manager
7. Expand the section labeled Network Adapters.
8. Right-click on your network card and select Properties.
9. Click on the "Driver" tab at the top


* Router brand and model # (this should be printed somewhere on the front or back or bottom)
* Cable or DSL Modem brand and model #(this should be printed somewhere on the front or back or bottom)
* ISP (Internet Provider)
* Is the connection wired or wireless
* Location (City, State)
* Traceroute ( http://us.battle.net/support/en/article/performing-a-traceroute )
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Reply Quote
DrunknSticky

Can you post some network information?

* Windows Xp, Vista, or 7 (also include if it's a 32 or 64 bit version)
* Firewall (McAfee, Norton, ZoneAlarm, etc.)
* Network Adapter brand, model, driver date, and driver version number (Steps below)

1. Click Start.
2. Click Control Panel.
3. Double-click on the System icon (in Windows XP, you may need to click Switch to Classic 4. View on the left hand side of the screen).
5. Select the Hardware tab.
6. Click on Device Manager
7. Expand the section labeled Network Adapters.
8. Right-click on your network card and select Properties.
9. Click on the "Driver" tab at the top


* Router brand and model # (this should be printed somewhere on the front or back or bottom)
* Cable or DSL Modem brand and model #(this should be printed somewhere on the front or back or bottom)
* ISP (Internet Provider)
* Is the connection wired or wireless
* Location (City, State)
* Traceroute ( http://us.battle.net/support/en/article/performing-a-traceroute )
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


Windows 7 64 bit
Windows Firewall
ASUS PCE-N15 11n Wireless LAN PCI-E Card, 6/15/2011, 1005.22.615.2011
2Wire Gateway 2701HG-G
Cable
Bell Canada
Wireless
Toronto, ON
I tried the traceroute but it said access denied
Reply Quote
I have "crazy high latency" as well, but it's my ISP who's generously allowing someone on our end circuit run some crazy server (or possible botnet) during prime time hours. I have no issues playing the game outside of 7:30-11:30pm EDT.
Reply Quote
Support Forum Agent
Posts: 36,017
DrunknSticky

Some players with your type of router have had success in resolving this issue by changing the wireless mode to B instead of the default which is usually both B and G.

Try this:

- Browse to http://gateway.2wire.net
- Click on the Home Network button at the top of the page
- In the gray bar across the top, click on Wireless Settings
- under Additional Settings (defaults recommended)
- change the wireless to Wireless Mode: 802.11b
- Click the Save button at the bottom to save the settings
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Reply Quote
Yeah, so I have the same issue and I'm on land line. I'm from EU and until the last patch I had no issues whatsoever until now. I didn't installed new programs or stuff. I can't figure out why it goes to 1500 latency and the game dies. I can't use any skills. A friend who was In my game said I was doing the stuff I tried to do but at my end nothing happened.
Reply Quote
Support Forum Agent
Posts: 36,017
Player

1. Make sure that the ports that Diablo III uses are allowed in the Windows Firewall.

Here's a link with the port information: http://us.battle.net/support/en/article/firewall-configuration-for-blizzard-games#2

2. Make sure that your network card is running on the most current driver.

Here's a link where that download can be found: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

3. You didn't post any router information. Your router should have a built in firewall. You may need to go in and allow the ports that Diablo III uses in the router's firewall.

Here's a link where you should be able to find a router/game specific guide on how to open the ports in the router. You will just need to get the router's brand and model number.

http://portforward.com/english/routers/port_forwarding/routerindex.htm

4.
Tracing route to 12.129.209.68 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms router.kaiserdave [192.168.2.1]
2 1157 ms 508 ms 627 ms cpe-075-190-128-001.carolina.res.rr.com [75.190.128.1]
3 282 ms 363 ms 438 ms cpe-024-074-253-117.carolina.res.rr.com [24.74.253.117]
4 604 ms 424 ms 356 ms ae18.rlghncpop-rtr1.southeast.rr.com [24.93.64.4]
5 323 ms 430 ms 487 ms 107.14.19.42
6 416 ms 486 ms 395 ms ae-0-0.pr0.dca20.tbone.rr.com [66.109.6.183]
7 281 ms 445 ms 449 ms 216.156.116.213.ptr.us.xo.net [216.156.116.213]
8 677 ms 587 ms 625 ms 206.111.0.90.ptr.us.xo.net [206.111.0.90]
9 536 ms 533 ms 556 ms cr2.wswdc.ip.att.net [12.122.81.250]
10 657 ms 732 ms 645 ms cr1.cgcil.ip.att.net [12.122.18.21]
11 * 598 ms 644 ms cr2.dvmco.ip.att.net [12.122.31.85]
12 672 ms 751 ms 621 ms cr1.slkut.ip.att.net [12.122.30.25]
13 729 ms 675 ms 764 ms cr2.la2ca.ip.att.net [12.122.30.30]
14 699 ms 605 ms 660 ms gar29.la2ca.ip.att.net [12.122.129.241]
15 375 ms 579 ms 566 ms 12-122-254-238.attens.net [12.122.254.238]
16 509 ms 476 ms 502 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.129.193.250]


Lastly, I know you feel that the issue is on our end, but the tracert that you posted shows otherwise. Line 1 represents your router, and line 2 represents your modem. Look how high the latency spiked when it reached line 2. This spike could indicate that there is a problem with the modem. The high latency then continues in every line after line 2. This tells us that the issue is most likely with your ISP, not us. You'll want to contact your ISP to have them look into this issue.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Reply Quote
bump since this is the only blue i've seen respond on this issue...
Reply Quote
Bump

i tred diffrent solution but im still at 1000ms.......
Reply Quote
Bump as well. Everyone I know in real life has experienced high latency since launch, to the point of the game being unplayable at peak hours when the servers have high traffic. Why can't Blizzard work to fix this? If it's that the minimum system requirements listed for the game are incorrect, that's a pretty big legal issue and they really should correct it. There is no reason that millions of players that meet all the game's system requirements for a game they paid $60+ for, should have to suffer through lag for a month. This absolutely needs to be fixed and Blizzard needs to stop blaming players for their own poor tech support
Reply Quote
85 Draenei Paladin
10140
Posts: 382
My game was fine before the 1.02 patch a few weeks ago. Now my connection goes green to red on a constant basis, lots of rubberbanding, etc. I'm on wireless, however, when I direct connected, my router blows up when I try playing D3.

I opened all the ports on my router and disabled Windows firewall, no Avast, anything, and I still lag. Again, though, everything was working fine with all of my firewall stuff up just a few weeks ago.

Windows 7 64-bit
ATT UVerse
2wire 3801HGV
Fresno, CA

Tracing route to 12.129.209.68 over a maximum of 30 hops

1 1 ms 1 ms 1 ms homeportal [192.168.1.254]
2 31 ms 27 ms 24 ms 99-120-204-3.lightspeed.frsnca.sbcglobal.net [99.120.204.3]
3 * * * Request timed out.
4 * 25 ms 22 ms 75.56.90.17
5 23 ms 23 ms 23 ms 12.83.71.141
6 41 ms 40 ms 40 ms gar20.la2ca.ip.att.net [12.122.128.181]
7 42 ms 42 ms 41 ms 12-122-254-238.attens.net [12.122.254.238]
8 42 ms 42 ms 41 ms 12.129.193.254
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
Reply Quote
hmm i have high latency as well. But when i change to 802.11b the ping some how stable to 200-300. But i tink its not a solution. If im not wrong, even though it change to 802.11b, it will pull down by overall internet speed isnt it? correct mi if im wrong :D
Reply Quote
85 Blood Elf Rogue
6970
Posts: 57
Over the past 4-6 days D3 has has latency problems. The game is not playable. I log in at 196 latency then 30 secs later I cant move and it is at 1200latency 45 secs later at 200 and 1 min later frozen. It is not my connection. My connection is perfect. I log into WOW and have 200 latency for hours then I try to log back into D3 and Boom same problem. This is nuts and many friends are going through the same thing. I have read posts Aussies and people in the U.S. are having the problem. I have run traces and like I said every thing is FINE but D3. I am not QQing Blizz but I ask that you respond and fix it as it is not playable at all because I die due to lag (1kplus) and freezes but WOW runs like a charm.
Reply Quote
im from sg most of them has no problem except mi >.>
Reply Quote
DrunknSticky

Some players with your type of router have had success in resolving this issue by changing the wireless mode to B instead of the default which is usually both B and G.


This worked for me (Linksys WRT320N). I changed the setting from "Mixed" (B/G/N) to "N-only". Since then I've been playing for 2 hours with no lag spikes (I had spikes every few minutes before, up to 4000ms) but my base latency has been reduced from 130-140ms to 90ms.

Those with wireless routers, do try this solution.

And thank you, Dankorii!
Reply Quote
85 Draenei Paladin
10140
Posts: 382
bump
Reply Quote
bump
Reply Quote
I am using gigabit wired, and latency is a problem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]