Diablo® III

A new patch is available - Workaround

Okay, after trying the walkthorugh another 2 times, I still have this problem. same situation here as with BlackBart213, US (well, Aus) version, playing in the EU.
i did what was told. and daym it couldnt be solved. was prompted to reinstall d3. da%*%qqqsss =/
Thank you Barthus, this just worked for me!
Edited by Enelra#1554 on 6/26/2012 7:21 PM PDT
59 Undead Death Knight
9320
Hasn't worked for me either. I have the US version, and I play in EU. Tried everything, triple checked to make sure that I'm doing it right, and I still get the infinite loop.

I can, however, play on my US account, but my primary characters are in EU, so I'm kind of feeling desperate here. Any help would be very much appreciated.

Your client is at version 1.0.3a then. You'd have to downgrade and repatch by following the instructions on the second part of the step by step. But EU maintenance begins in 30min...

06/26/2012 07:07 PMPosted by AHTEE
i did what was told. and daym it couldnt be solved. was prompted to reinstall d3. da%*%qqqsss =/

You cannot and should not remove or add any quote, coma, bracket, brace, etc... You simply replace the patch_url with another one without modifying anything else. And, if you get the error: "An unexpected error occurred while trying to install", just keep following the instructions and your client will be patched to the correct version.
Edited by e1D#1473 on 6/26/2012 7:34 PM PDT
you can play in europe realm but not americas.this patch problems occur every 3 days now.idk wat u talking about but you can play in eu realm i really have no idea wat u talkin.i assure u ucan play in eu real.seriously i have no idea what u taling about but u can play in eu now b ut not jut americas ok?to do this go option and change ur realm to euro[e.do u undertand?

i think u still dont get it; you can play in eu realm with no problem do u unndertand
I'm using mac, any idea how to solve this? can't even find the .agent.db file.
90 Human Warrior
6535
Barthus I love you, your fix works perfectly, thank you so much for posting this.

For anyone else, just ignore the blue posts they dont work at all, just crap about running as admin and other useless junk

Also for people who cant find agent.db:

1. its just called agent for me not agent.db, maybe for you too

and 2. some of the folders/files in this fix are hidden, so go to Start->Control Panel->Appearnace and Personalisation->Folder Options->Show Hidden Files and Folders and Click the circle saying "Show Hidden Files, Folders and Drives"

Edit: this is for windows 7, for other OS's google "how to show hidden files"
Edited by Vadla#1228 on 7/3/2012 8:54 PM PDT
OK, I fixed it this way, I uninstalled the new fresh install on my SSD, then wasted all the directories that the uninstall (via add remove programs) didn't get rid of....

SET my Secondary Login service to AUTOMATIC (didnt even reboot, it started).

Used my old HD's installed copy and viola I am in the game at the sign in even after 3 more restarts just to be sure.

So perhaps that Secondary Login service was to blame.... found that after a short search.

I never did see AGENT.EXE run, my firewall never asked for permission, either, so confusing, but glad it is working again.

This is too much for a normal user to have to deal with though, fortunately, I am not one.
Edited by Badfinger#1431 on 7/3/2012 10:12 PM PDT
same issue in MAC client
now im getting a error message about not being able to install and should try again or contact customer service
This is bull!@#$ I'm terrible with computers so I don't even understand the post. Just a whole bunch of text.

Fix the damn game before I cash it in for a refund

Edit: Did it and it still does the loop after 'updating the patch', wtf is wrong with you blizzard?
Edited by Fuuton#6583 on 7/10/2012 10:31 AM PDT
works great!!
Thanks Barthus!!
thanks Barthus, it works...
my game is in french i play in us server i have windows xp and i cant file the agent db folder
worked for 1.0.3b!
Thanks for the info! Works perfectly!
my agent file was correct so i deleted the one in battlenet folder and it came up with patchin etc etc, so i proceeded to start the game and it did the same loop over..however if i change my region to EU it works..US (where i play) will bring up the 'new patch avail for download' message and go to client where it will say 'game is upto date' and keeep loopin like that

any help pls?

ps
im in australia but i play on US (if that has anythin to do with anythin)
Edited by Jibs#6774 on 7/10/2012 10:51 AM PDT
I'm from EU
if i do apply the url http://enGB.patch.battle.net:1119/patch (behind all the suggested fix)
won't work it give me "an error occurs please contact the support center" and i'm able to play just in US server changing the in game setting from EU to US.

The only url my client accept (to work) indeed is http://enUS.patch.battle.net:1119/patch
and so when a patch is available in US my client update and the loop in my EU account begin.
It will last till tomorrow when the EU patch will be applied in EU too, as seen before.
This to me means i can't play my main character from when the patch is installed in US till it will be in EU too. Almost 24hrs between two days, and occurred each time a patch is out.

I am unable also to change my client, downloading my region one, cause when i bought the digital copy i installed unconsciously the US one.
Indeed, if i do, it give me: "an error occurs please contact the support center"

Dear support, please fix this extremely annoying issue. It's from the first patch this is happening.
Edited by Kajuan#2923 on 7/10/2012 10:54 AM PDT
Thanks for the infor, really helpful.
@Barthus Thank you so much for posting this. Good Job Bro :)
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]