Diablo® III

MouseOvers Causing HUGE FPS Drop Since 1.0.3

80 Tauren Hunter
0
Posts: 85
First, let me voice my extreme displeasure.

I spent 10+ hours over the past month trying all the fixes people came up with to fix or alleviate the pre-existing stuttering problems that are very well known. A couple weeks ago I was finally able to get the game running smooth. Very smooth, no stuttering and constant 60 FPS.

Now comes patch 1.0.3......

EVERY SINGLE TIME my mouse hovers over a selectable item or character, the FPS gets absolutely crushed. Like 10-15 FPS. It makes the game totally unplayable. If I accidentally move my mouse over an item on the ground in the middle of the fight, the stutter is so bad that I can't play properly. I've already died 5 times tonight because of this and I've had enough.

HOW ON EARTH DID BLIZZARD LET THIS PATCH OUT IN THIS STATE
Edited by MyKillK#1335 on 6/20/2012 12:47 AM PDT
Reply Quote
80 Tauren Hunter
0
Posts: 85
Well, it looks like the problem is somehow related to the shadow setting. I would love to hear how blizzard managed to make the shadow option screw up mouseover popup boxes, which do not have shadows. Not a performance issue on my end either, I get a totally smooth 60 fps in everything including large fights. But a simple mouseover drops me down to like 15-20.

Turning shadows to low stopped it but now the game looks like crap. Thanks Blizzard, keep up the great work. =\
Edited by MyKillK#1335 on 6/20/2012 1:20 AM PDT
Reply Quote
Yea this patch should have never made it past QA. If they even have a QA dept. Too many bugs.
Reply Quote
Posts: 34
I experience the same problem with shadowed mouse overs.
Reply Quote
I found the mouse over problem pre 1.0.3 Patch. I noticed it in towns. I would go from a steady 60 FPS and when I hovered over a NPC (or anything selectable, like the stash) it would crash to a steady 30 FPS.

And if I turned off shadows all together, this issue stopped. I have since stop using shadows because of that crashing of FPS. I did notice that it mostly happened in towns only (at the time). But with the new patch there looks to be new options for shadows. Which could be the reason people are now experiencing the issue outside of towns now.

All I can say for now is turn off your shadows till they can fix it.
Reply Quote
I have turn off Vertical sync in option, its looks pretty good but the graphic are some how like !@#$ again but not so frequently than turn on Vertical sync... Sorry for my poor English.
Reply Quote
80 Tauren Hunter
0
Posts: 85
I found the mouse over problem pre 1.0.3 Patch. I noticed it in towns. I would go from a steady 60 FPS and when I hovered over a NPC (or anything selectable, like the stash) it would crash to a steady 30 FPS.

And if I turned off shadows all together, this issue stopped. I have since stop using shadows because of that crashing of FPS. I did notice that it mostly happened in towns only (at the time). But with the new patch there looks to be new options for shadows. Which could be the reason people are now experiencing the issue outside of towns now.

All I can say for now is turn off your shadows till they can fix it.


Turning shadows off, actually even to low, fixed the problem for me as well but IMO that's not an acceptable solution.
Reply Quote
80 Tauren Hunter
0
Posts: 85
I was able to solve this issue by changing the HardwareClass in the d3prefs file down to "2". It was originally "3".
Reply Quote
Just started having the exact same issue. Honestly, the game is unplayable. Shadows on High/Off, Vsync On/Off, Nothing has changed the fact that I get about 8 frames a second mousing over a waypoint, chest, or NPC.
Reply Quote
80 Tauren Hunter
0
Posts: 85
Well hopefully the HardwareClass setting will fix it like it did for me.
Reply Quote
Same issues here, tried hardwareclass change, vsync, etc and still have same issue..Putting the mouse over an NPC or entrance and it lags to hell. I'm suprised this hasn't made it on the known bugs list yet...Started happening after 1.0.3

Running under Wine 1.5.7 - 64-bit OS..
Edited by brenix#1491 on 6/25/2012 6:31 PM PDT
Reply Quote
Hey guys... been following this thread with baited breath for the next patch- here it is, 1.06, and nothing doing.

I've tried every possible combination of shadows, vsync, and hardwareclass settings in the d3prefs config file. Lucky to those whose issue was solved by changing those, but that's certainly not the case for me. 30-60FPS normally, but on mouseover drops to 3-4 FPS. Brutal. Nothing like trying to run away from a mob, then having some stupid thing in the way mouse-over before watching your FPS drop as you get lag-killed.

I've also tried running the game with the default settings after my install (Fullscreen 1900x1080) and in a window. No effect. Currently I'm running in a window at 1280x1024. Makes it easier to edit the config file in one of my alternate desktops :)

Config:

Wine 1.5.8
Gentoo Linux, kernel 3.4.9
GeForece GTX 260 w/ nvidia binaries 310.19
16GB RAM
Intel i5 750 @ 2.67GHz
2x 250GB SSD in RAID1

I'm going to submit a bug report to blizzard and reference this thread. Until this is fixed, I'm better off running the pit with my necro in D2 ... :(

~g
Edited by gr0x0rd#1274 on 11/27/2012 6:36 PM PST
Reply Quote
Support Forum Agent
Posts: 33,542
gr0x0rd,

Wine 1.5.8
Gentoo Linux, kernel 3.4.9


We won't be able to accept a bug report when you're using a non-supported operating system.

If you have the same problem when using a system meeting the minimum requirements, please start a new thread with a complete description, including the dxdiag info.

There aren't any current "mouse-over" issues right now other than possibly one causing items to "flicker", but that doesn't cause a frame rate loss.
Reply Quote
Upgrading to wine 1.5.18 solved the issue :) :) :)

Happy gaming!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]