Diablo® III

Network Disconnect problems

I keep getting disconnected which is very frustrating because I normally have 5 stacks of nephalem valor.

I reinstalled Diablo 3. Made sure router firmware is up to date.

There are 2 other computers on my router and it doesn't happen to them.

What else can I do to try to fix it?
Reply Quote
Just sitting in town does not not disconnect me, only when fighting monsters.
Reply Quote
I was just standing in town for 1hr and 30 mins. I go out to fight some mobs and I get this message.

"Network Disconnect"

"The game connection has been lost: your client has been disconnected from the server."
Reply Quote
I'm continuing to have the same problem... (http://us.battle.net/d3/en/forum/topic/5960196267) mabye if I keep replying to multiple similar posts it'll get some attention...
Reply Quote
This right here http://i.imgur.com/jDTtT.jpg
Reply Quote
06/27/2012 04:12 AMPosted by Faxanadu
This right here http://i.imgur.com/jDTtT.jpg


A lot of us seem to be having this exact same problem -_-. The game was working fine a few hours ago but this damn error making the game unplayable for me at the moment.
Reply Quote
flush your dns i posted on other threads regarding this should solve some of your issues if not wait till it gets fixed blizz is busy..... : )
Reply Quote
- Technical Support
View profile
This one is very hard to troubleshoot because it is caused by MANY things.

Some other player solutions/discoveries:
-Don't run torrents anywhere on the same network
-Someone found his cell phone being on the same wireless caused an issue
-Someone found that the building internet was shared so he got disconnected during high traffic times
-Tracert shows packet loss issues with their ISP
-Modem and router issues
-Bugs with some skills were doing it at release
Reply Quote
66 Draenei Shaman
555
I just started having this problem a few days a go and I'm close to unistalling Diablo 3 because of how frustrating it is! It loves to happen when I have 5 stacks of valor and/or gold items on the ground which substantially increases the frustration level of the problem. I get random disconnects from game in both solo and multiplayer modes. Anywhere from 20 minutes into a session to 90 minutes. Sometimes I have to restart Diablo to get back in, other times I can get back in from character screens. Once it required a full system restart. The messages are either you have been disconnected from the client, or you have been removed from the game (both solo and multiplayer). I had a problem free gaming experience from beta until just this last week, so I feel confident it has something to do with one of the recent patches :(
Reply Quote
This one is very hard to troubleshoot because it is caused by MANY things.

Some other player solutions/discoveries:
-Don't run torrents anywhere on the same network
-Someone found his cell phone being on the same wireless caused an issue
-Someone found that the building internet was shared so he got disconnected during high traffic times
-Tracert shows packet loss issues with their ISP
-Modem and router issues
-Bugs with some skills were doing it at release


None of these apply for me.
I believe this all began with the new patch.
Whatever ya did, Blizzard, it seems to have backfired for many of us. Help!
Reply Quote
I Just started getting this an hour ago. Keeps Dc'ing within 1-2 minutes. Never dc'd since i got the game in 300 hours of play.
Reply Quote
I tried all the suggestions including flushing dns and so on but it's still happening. It only started since the recent patch 1.0.3. I really can't even play the game anymore since I can't get 5 stacks of nephlam valor before I get the disconnect message.
Reply Quote
Could this be a bug with barbarians? What class are you guys playing?
Reply Quote
i'm having the same issue, playing either my barbarian or demon hunter, haven't tried others. my network connection is good, i think it's server lag. my ping times are good but i start lagging then soon after it says disconnected.
Reply Quote
I also play a barbarian, but it never happened to me before patch 1.0.3... So dunno.
Reply Quote
Seems like every time it happens i'm using whirlwind, could this have anything to do with it?
Reply Quote
When I first bought the game it ran smooth and no D/C's but lately I get constant jumpy movment, studdering, and now D/C's. Doesn't matter what class I use a monk mostly. I'm not sure if its my ISP or this game at the moment.
Reply Quote
Yes, it's WW causing it. Happens more frequently (at least to me) in Act 2. Doesn't happen to everyone though.
Reply Quote
Does anybody have an Xbox360 on their network? Could this be the problem?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]