Diablo® III

Keep disconnecting

(Locked)

I am experiencing the exact same issue. It's worrisome considering I play hardcore characters occasionally, and annoying when I'm stacking valor and getting disconnected. At first it seemed to be associated with more people joining my game, then it seemed to happen every time I got to the purple dude in defiled crypt lv2 mid-fight... I'm currently pretty sure it's neither since it happens anywhere from 1-10 minutes after I start a game..

The popup says "NETWORK DISCONNECT... The game connection has been lost: your client has been disconnected from the server"

Interestingly, I'm not prompted to login again.

What is going on here?

addendum:
It's not my connection.
I'm downloading and streaming music without interruption, and it happens even when I'm not doing either of those things.
Edited by LordPoohbear#1770 on 6/26/2012 10:31 PM PDT
86 Human Mage
4240
Same exact thing happening to me. My internet connection is quite nice, and I can gladly login to WoW without problem. Once I disconnect, I'm not prompted to login once again.
Edited by Monstruo#1572 on 6/27/2012 11:10 AM PDT
I'm having the exact same problem. I've run a tracert and it can't even connect to battle.net. This has only been happening since 1.0.3a.


Tracing route to 12.129.209.68 over a maximum of 30 hops

1 2 ms 1 ms 1 ms 192.168.1.254
2 44 ms 25 ms 38 ms 99-127-4-3.lightspeed.irvnca.sbcglobal.net [99.127.4.3]
3 * 35 ms 25 ms 75.20.0.120
4 * * * Request timed out.
5 * * * Request timed out.
6 217 ms 337 ms 107 ms 12.83.38.149
7 346 ms 354 ms 411 ms gar29.la2ca.ip.att.net [12.122.129.241]
8 215 ms 199 ms 126 ms 12-122-254-234.attens.net [12.122.254.234]
9 69 ms 67 ms 27 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.129.193.250]
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.


EDIT for if blue reads

Please don't tell me to contact my ISP. I already have, they say the problem isn't on their end, and no other games or websites are experiencing connection issues AND this problem has only been happening since yesterday. It's clearly related to the patch.
Edited by Dennis#1787 on 6/27/2012 12:01 PM PDT
im having the same issue. i keep getting kicked from games and have to log back in.
same here as well wtf blizz why do you hate us
Hello, same issue here. Do you have a "Network Disconnect" pop-up while in game ?
Regards,
Hello, same issue here. Do you have a "Network Disconnect" pop-up while in game ?


Yeah, I do. 3003 error. Sometimes I stay connected for a few minutes with hideous lag spikes (1600+ ping).
Any answers from blizzard tickets?
Edited by Jens#1657 on 6/27/2012 4:12 PM PDT
89 Tauren Hunter
SCH
6435
I am also experiancing this problem my internet is apparently perfactily fine and boom i lose connection with the game. Would really like this to stop as i spend time to get stacks and then they reset because of retarded disconnecting.
Blizzard please address this. I'd like to add that I use At&T Uverse and that this topic:

http://us.battle.net/d3/en/forum/topic/5837015026 and the one here are probably related.
90 Night Elf Druid
5860
I am currently not playing the game. I'm staring at this message board waiting for this problem to at least be acknowledged. Several other problems are being addressed but this one seems to keep being past up. Please help.
Same sh1t happening to me too..
1. i delete battle.net folder but it was keep giveing me Patch loop so i took it back where it belongs..
2. i changed my routher ip setup. and nothing happends
3. i add required ports to my windows firewall and guest what ?!! nothing happends still haveing the same sh1tty error..
06/27/2012 05:39 PMPosted by Complexities
I am currently not playing the game. I'm staring at this message board waiting for this problem to at least be acknowledged. Several other problems are being addressed but this one seems to keep being past up. Please help.


Same for me. Getting disconnected all the time isnt enjoyable.
same here, getting disconnected all the time and i have to redo my router settings...not fun at all :( even then i am still being disconnected
Same here - def related to blizz servers. If I play early in the a.m. its not bad ,in the afternoon/evening it boots me off. Upgrade your servers blizz!!!
Yesterday i just buy this amazing game..today turn out to be xuck game with annyoing stupid connection lost server. constantly "The game connection has been lost: your client has been disconnect from the server. click start game 10 times and 10 times lost connection. WTH blizzard!! security my arsesss..
Bump.. we need a blue post there's like 5 of these in main page....
Please help Blizz, this issue is beyond a joke, just about ready to bin this game as it just causes so much frustration, was running fine 2 days ago and then bam "Client disconnected from server" wtf is going on?? been searching and searching for a fix but seems ppl are just banging their heads against a wall with this...
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]