Diablo® III

Keep disconnecting

(Locked)

ok, so what the hell has happened here - same problem appearing for me as well, I get to play for 10minutes max, and then it says disconnected. I have full bars on my WIFI and this problem started occurring just a couple of days after the new 1.07 patch. are there too many players that the servers can't handle or why does this keep happening? ALL other online games work perfectly fine, such as PoE, which I'm actually headed to play right now after I just got disconnected twice.

And no, I have no warez running (they work perfectly too), no other computers turned on, secure wi-fi with a crazyass password, etc. etc. etc. everything USED to work, but recently this game has turned into total hell (and that is not because of the difficulty level).

I feel like I've been fooled by purchasing this game. Seriously. If this stuff doesn't get fixed, I'm going to boycot Blizzard for whole my life from now on, and ask all of my friends to do the same.
I am having the exact same problem.

This thread is 19 pages long now, you would think a blue would at least comment.

Only in the last few days I have been getting constantly bumped. Not logged out, just disconnected.
I wait a few seconds and can restart the game. A little annoying when you just get to 5 stack.
Holy !@#$! Are we back to the START AGAIN??? The same disease I got since I first pre-order D3?? WTF man!!

These are ERRORS IM FACING OFF RIGHT NOW!! PLEASE F(U)CKIN FIX IT!

1) Lost Connection: Your connection to the Battle.net service has timed out. Please log in again (Error 3007)

2) Auction House: Cannot get your payment info. (Error 3005)

3) Error: There was an error creating the game. (Error 316704)

4) Network Disconnect: The game connection has been lost: your client has been disconnected from the server.

How many more should I go thru? Besides, you just had my Barb killed while trying to kill a whole bunch of elite mobs. There goes my gold and fun!
Yep agree with all the same errors as JordacheWee posted - doesnt matter if i try the Europe, Asia or America servers tonight, can't access my Auction (had some SWEET one-off items being bid on bet i lose them CHEERS GUYS) - 3005, 3006, 3007 & 316704 errors...

Like this is the worst ive seen it... this can't go on if you expect ppl to actually be able to play - two days & i cant even bring up my player stats?
Seriously Blizz, 30 mins of gameplay and two disconnects:

Lost Connection: Your connection to the Battle.net service has timed out. Please log in again (Error 3007).

This is really becoming annoying. What gets me even more is that I need to build my NV again. Surely in the next patch you can fix this or manage to allow NV to remain for a few minutes following a disconnect.
bump,

Ever since 1.07A, I to have been experiancing the same exact thing. I literally cannot play this game with how many times I am disconnecting from game, error 3007.

Seems that a lot of people are affected. A blue post saying "We will look into this" would be nice right about now.
Same problem here... 5-10 mins of playing and boom disconnect and quit to main menu.. On Russian forum i didnt get answers...
Seriously,

I am having the exact same problem.

This thread is 19 pages long now, you would think a blue would at least comment.

Only in the last few days I have been getting constantly bumped. Not logged out, just disconnected.
I wait a few seconds and can restart the game. A little annoying when you just get to 5 stack.


I know alot of people have given upp and stopped playing, But thank you for this post Romulus
http://www.diablofans.com/blizz-tracker/topic/257361-can-a-blue-please-read-constant-disconnect/
It really shows their true colors and how much they care about Diablo in general. We are the step-children of Blizzard. I cant believe they would even tell you to contact customer service and report the Tech support FOR NOT DOING THEIR JOB. But if it has to be done it will!
Same problem here!!!!
Keep disconnecting!!!!!!!!!!!!!!!
WTF
Blade,

I see you have a Barbarian and it's using Whirlwind. Disconnections when using this combination are currently under investigation. I've no workarounds at this time.


The problem was not localized on Barbs Only.
Monks also having the same issue.
We are getting frequent disconnection.
Completing the whole Alkaizer run is now extremely rare.
I only got 1:12 complete RUN on Alkaizer.
While the 11:12 of every run i make ends up being disconnected.
And its discouraging.
Im not even on the dense place and i already looses Nephilim stack...
I use a Wizard most of the time and I usually disconnect every few hours. Doesn't happen when I play COD on my PS3.
Seriously...
I just got Disconnected about 1 minute ago..
AGAIN....
Today ratio is 2:2
with 100% disconnected rate...
Those nephalem Valors....
Im tired farming those nephalem valors again and again.

IM using Monk, Not barb....
Currently using tempest rush...
Edited by WhiteBootz#6395 on 3/22/2013 5:20 PM PDT
Yo!

I'm back.. getting DISCONNECTED AGAIN AND AGAIN for today. What's happening?
I can't even log in, error 3005 over and over again.

I can log in to Starcraft tho.
Here is my D3Debug log. I get Network Disconnect: The game connection has been lost: your client has been disconnected from the server every few minutes. WW barb. It has been happening for over a week. http://pastebin.com/5pBbUeSb
Edited by Sapien#1344 on 3/31/2013 12:22 PM PDT
Same thing happening here. Just started about an hour or so ago. Was fine last night :/ Argh.
cocopup,

As I've already mentioned in this thread, it's an issue our QA Team is looking into. We'll have to wait until they're done and have passed on their findings to the developers so it can be resolved. There are no workarounds that I'm aware of at this time.


Did we ever get a solution? This was originally posted in October...it is now March 2013.
Easy fix: Make the !@#$ing single player playable offline, problem solved.
Just to add my name to the list. 3 disconnects today at random times. The last simply ID items at the blacksmith.
I have made many posts about this months ago and nobody cared enough to even give a reply
how many more pages do we have to add here before somebody decides this is a real problem
Also have had 2 system crashes in 2 days, ONLY W/D3 ALL other games run perfectly


Easy fix: Make the single player playable offline, problem solved.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]