Diablo® III

Keep disconnecting

(Locked)

This is really starting to get annoying, it has gotten so bad that I can't even play the game because of the disconnecting. And its not even disconnecting me from the entire game, only when I try to play on a character. It just keeps bringing me back to the character screen. Can we please do something about this, i would very much enjoy being able to play....

06/26/2012 10:30 PMPosted by LordPoohbear
The popup says "NETWORK DISCONNECT... The game connection has been lost: your client has been disconnected from the server"


I get the exact same message
Edited by Trojan#1496 on 4/1/2013 6:13 AM PDT
04/01/2013 05:59 AMPosted by Trojan
This is really starting to get annoying, it has gotten so bad that I can't even play the game because of the disconnecting. And its not even disconnecting me from the entire game, only when I try to play on a character. It just keeps bringing me back to the character screen. Can we please do something about this, i would very much enjoy being able to play....


Sir, read this I just posted in a similar thread:

03/30/2013 11:19 PMPosted by Morogoth
I've done the tracert tests suggested in several related threads, but analyzing them is beyond me. Though just looking at them I have gathered there definitely seems to be a problem since every tracert I perform, on both my wired and wifi connections, hits "Request timed out" at hop 15 and every hop thereafter.


i think you have misunderstood the meaning of the tracert.

here is the last section of a tracert i just did.
12 83 ms 84 ms 84 ms cr2.dlstx.ip.att.net [12.122.212.14]
13 85 ms 83 ms 83 ms cr2.la2ca.ip.att.net [12.122.28.178]
14 118 ms 79 ms 81 ms gar29.la2ca.ip.att.net [12.122.129.241]
15 82 ms 81 ms 82 ms 12-122-254-238.attens.net [12.122.254.238]
16 82 ms 81 ms 82 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.129.193.250]
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.

Trace complete.


now normally "*" means a drop in the connection. however, in this case its just because the bliz servers dont respont to this kind of network request. so you will always get "timed out" when it hits the bliz servers.

aside from that its not too hard to read. number on the left is the hop count, the middle 3 are the latency in milliseconds, and the right is the IP being routed through.


This gentleman is correct.

Guys, I now think that these issues are SPEC related.

Need more time to test - but I realized that the disconnects didn't start with the latest server maintenance - they started when I changed my spec most recently!

Blizzard has admitted to some certain skill combinations causing these disconnects (Barb WW), but I believe there are some Monk combinations as well that do this.

Try changing your spec back to something that you used to run with, and see if the issues don't stop. Like I said, I have only tested this minimally thus far, but was able to get my first full run in yesterday after like 4-5 days of pounding my head against the wall with these disconnects.
Try changing your spec back to something that you used to run with, and see if the issues don't stop. Like I said, I have only tested this minimally thus far, but was able to get my first full run in yesterday after like 4-5 days of pounding my head against the wall with these disconnects.


I have recently just started playing again...my spec hasn't changed since I last logged in, and the last time i logged in it worked perfectly. So there is a way to change your spec at the character select screen? Because that's as far as I get....
The game connection has been lost: your client has been disconnect from the server.
two days
And thanks you blizard i lost Hardcore Char thanks very much
I'm getting tired of playing. I keep getting disconnected even before I get to the KW. I even respec'ed and I still get disconnected.
Same here today I get disconnected a lot more than usual....
Try changing your spec back to something that you used to run with, and see if the issues don't stop. Like I said, I have only tested this minimally thus far, but was able to get my first full run in yesterday after like 4-5 days of pounding my head against the wall with these disconnects.


People need to get it out of their heads that this is a class/spec isolated issue. I understand why some might think that, but it just isn't so. One reason people could think it's Barbarian related is because of the current popularity of the class. With more people playing it, and also experiencing this issue, it could seem like that class is disproportionally affected. I'm not saying there isn't something about them that causes them to disconnect, only that it isn't isolated to this specific class or specs thereof.

Morogoth quoted part of a statement I made about this in another thread, regarding my understanding of the tracert analysis. Fair enough, as I said in that comment networking isn't my strong suit and I was apparently misinterpreting the results. That's good to know, at least.

That being said, in the same thread Morogoth quoted me from, you'll note that I did not mention class or spec. That's because it happens to me regardless of the class I'm playing. It's happened most often while on my Wizard, since I play him the most. However, it's also occurred while playing my Demon Hunter, and my Witch Doctor. I get disconnected regardless of spec as well, since I experience this issue just as frequently now as an SNS Wizard as I did when I was doing Archon. The same is true across several different Demon Hunter builds.

I also mentioned in my thread that I experience this when I'm not even actively playing. I can be digging through the auction house, or sitting at the character selection screen chatting in general chat, when out of nowhere I get dumped back to the log in screen with "Error 3007." Another example is sitting at the gem combiner (Since I do that a lot), and hooray, "Error 3007."

Finally, I do apologize if I sound a bit venomous. I know people are just trying to help isolate this issue and provide data to hopefully arrive at a resolution, even if we have to find it ourselves. My frustration is not directed at anyone here, and comes only from the fact that I have effectively quit playing this game due to the frequency of my disconnects and I really didn't want to have to do that.

PS. To anyone convinced this is a geographically isolated event that doesn't affect people on the west coast of the U.S.A (I've seen that mentioned a few times), I live in San Diego.
Starting from one week ago, I got so many disconnections that practically I could not play at all. I have uninstall/reinstalled a few times, cleaned my system, power cycled my modem and router, and nothing works.

Usually I had no problem to log in and browse auction house, but could get into the game with the disconnection, or when I got into the game, I would get a disconnection as soon as I tried to teleport to the town.

It is a shame for Blizzard! First you forced everyone to play it online and then you cannot even do the job. I had no problem with my system playing D3 for a few months, and suddenly, not long after the most recent update I got this issue. On the same time, I have had no problem with SC2.
On the second thought, probably I need to thank Blizzard to produce this error so I've got a really good reason to quit D3.
Giving this a bump, just got tired of being disconnected every other damn run. It has been rampant the last 2 weeks, and its pissing me off.

Don't understand why it seems to happen to us WW barbs the most.
why no answers yet??

can we get some sort of logical update??
I feel like I have done everything and still get disconnected. I even changed ISP. It's dumb that people that have been flagging this issue almost since release and nothing adequate has been done. I am done with this game for now, I have other games that will fill the void, though it wasn't that big a hole to fill anyway. May try to give tech a chat to see if they have anything else to say...
Same here this is becoming more then annoying !
yup started for me now too keep getting disconnected and brought back to char selection, but somtimes tho getting 3007 and having to log all the way back in. and yes happens in game and just in auction house as well its happening on all my chars not just one what the heck is going on????? cant even play the game anymore. I love Diablo 3 it made me put all my other games on the back burner not to be finished, i guess its time to go back to those other games now.
I have a suggestion for hardcore mutliplayer.... and to fix death because of lag.

Why not make it so when someone has a latency jump to 500 or something auto kick them in the first second without waiting 10 seconds?
how about an offline mode that is on the PC?

how can Blizz not respond to this post, it's 20 pages.
Add at least 3 disconnects per night all week plus 7 on Sunday.

Every time, completely out of the blue. No lag, no latency. Just bam, disconnected. Click resume and start over again (with no NV of course)

Starting to get really old.
WOW REALLY?! I have been disconnected over 10 times this morning.
and again.
90 Blood Elf Paladin
7655
same issue but ya get used to it being an online game blizzard needs mega servers
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]