Diablo® III

New Stuttering Workaround!

I never experienced this crap before 1.0.4 and now is unplayable, I used to play with max setting, tried lowering every setting and still not working, WTF blizzard do something this game is doomed.
Reply Quote
Didn't work for me, please post a REAL solution, damn today was the only day I could play and is impossible, this crap is frustrating
Reply Quote
Bump ^^^
Reply Quote
well, i have a very nice 2 TB HDD that stuttered, so i reinstalled on a brand new seagate 2tb external USB drive, stuttering is gone, microstutter remains, but it smoothed out. i had this problem start with patch 1.0.3, not 1.0.4. Regardless, dropping 110$ on a drive is unreasonable. This game shipped flawed, they keep changing it so all the hours i put in are worthless, then the actualy problems they DO have, they make US workaround it while they nerf stuff and make class changes. THIS GAME DOESNT WORK PROPERLY AND BLIZZARD IS NOT FIXING WHAT PEOPLE HAVE BEEN COMPLAINING ABOUT FOR 3 MONTHS.
Reply Quote
This doesn't work for me. Please, fix.
I was a beta tester and had stuttering issues, but you've told us it would be fixed for release. For me, it actually was, the game worked smoothly in the first days, which proves the cause is not on my end. Then the very first patch broke it again and I've had this problem since. I can't even play hardcore because of the freezing, and I'm getting tired of softcore. I'm sorry, but I don't see myself playing this game for much longer if the stuttering persists.
Reply Quote
^^^ Same Story For Me.... This is complete bull, they make new items and a paragon system but they cant fix the stuttering that TONS of people are suffering from... Way to show that you care blizz... They will just fix it under our noses and act like it was always on our end. Stop worrying about Jay facebook drama and new content and fix your game that I (And Many Others) PAID FOR.

If Jay can Admit to acting immature and childish why can't he admit that the game is broken???
Edited by TriggerSaint#1450 on 8/26/2012 6:33 AM PDT
Reply Quote
Last night I loaded D3 on my new rig, with every setting maxed. The game looked really, really good, but I noticed the environment studdering. My character was fine, but it was like the surroundings were trying to catch up. The text for the items on the ground would jitter when I was moving, but were totally fine when I stood still. It was kinda aggravating since I spent so much on this machine to pretty much just play D3.

When I was playing on my laptop, with all settings as low as possible, this jittering never happened. I messed around with the in-game video settings a little bit, but nothing seemed to help. Since I just built the machine, I have the latest non beta drivers, so I think I am good there. I will try this "fix" and see what happens.
Reply Quote
When playing I use Ctrl + R to view the framerate. Whenever I get the stuttering the framerate drops to 10fps. Is the stuttering you guys are talkiing about? Or do I have a different problem?
Reply Quote
Considering I already do this, this doesn't really help much. >.>
Reply Quote
This fix didn't work for me. Its a server issue, not a PC issue. I really wish these programmers would learn a tad about how operating systems and computer worked in general before saying the problem is with a users computer. Remember, hundreds of thousands of players are having the same issue, across multiple operating systems and hardware configurations. The only thing in common is the patch itself and The Americas servers.

Nobody is having a single problem on EU or Asia servers, so fix it and quit telling us its our systems.
Reply Quote
85 Undead Priest
Eka
8710
Posts: 322
08/26/2012 06:38 PMPosted by GhostGunner
When playing I use Ctrl + R to view the framerate. Whenever I get the stuttering the framerate drops to 10fps. Is the stuttering you guys are talkiing about? Or do I have a different problem?


Same problem. The catastrophic drop in fps is just a symptom of the real problem; the game is taking too long to read your hard drive to create the environment. That's why you see people with systems new and old, high and and low end having the same problems. And that's also why changing your video card settings to low doesn't fix it either, because it's not your video card. It's the game and Blizzard needs to fix it. They already announced this was a problem for the game months ago, as to why they haven't fixed it yet, no one has any idea why.
Edited by Gör#1270 on 8/28/2012 11:45 AM PDT
Reply Quote
I have the Asus G53SW laptop which also experiences these issues after trying every trick I've read about on these forums. Processor affinity, changing graphics settings, etc. I think the last thing to try would be installing a different hard drive but I keep reading replies about that not helping either so I am skeptical.
Reply Quote
08/26/2012 06:38 PMPosted by GhostGunner
When playing I use Ctrl + R to view the framerate. Whenever I get the stuttering the framerate drops to 10fps. Is the stuttering you guys are talkiing about? Or do I have a different problem?


Same problem for me, I've tried almost every possible fix, nothing works
Reply Quote
Well, I thought I fixed it with the D3prefs but it's back with vengeance 1.04. It seems more frequent on my DH where I use shift+shoot.

560 ti
SSD
170-200ms

my frame rate shows 59/60 constantly.

It's like http://www.youtube.com/watch?v=qgO23A-0798 but not as bad.

Any suggestions?

Edit: Not sure if I have stuttering or micro-rubber banding/desyncing? are they the same thing?
Edited by Luigieee#1567 on 8/28/2012 6:18 PM PDT
Reply Quote
08/28/2012 11:42 AMPosted by Stighmata
When playing I use Ctrl + R to view the framerate. Whenever I get the stuttering the framerate drops to 10fps. Is the stuttering you guys are talkiing about? Or do I have a different problem?


Same problem. The catastrophic drop in fps is just a symptom of the real problem; the game is taking too long to read your hard drive to create the environment. That's why you see people with systems new and old, high and and low end having the same problems. And that's also why changing your video card settings to low doesn't fix it either, because it's not your video card. It's the game and Blizzard needs to fix it. They already announced this was a problem for the game months ago, as to why they haven't fixed it yet, no one has any idea why.


Simple.... Because they don't care....
Reply Quote
Blizz WE NEED an UPDATE on this issue. Blues too busy enjoying Diablo 3 I'm guessing...
Reply Quote
does not work.
Reply Quote
What up fellow stutter folks, I have an update for yall on the issue. Might work might not, give it a try, takes ten seconds of your time...

http://us.battle.net/d3/en/forum/topic/6412494524?page=1#3

Read last update in post. Peace Homies
Reply Quote
I'm seeing this since patch 1.0.4. Never saw this before the patch. Have been running the game at the same settings (pretty sure max) the whole time with out any problems

ATI Radeon HD 5850
2.6GHZ Quad Core
8 GB Ram,
10k RPM drive.
Windows 7
Turning of indexing did not work.

Latest drivers on everything
Edited by Mordikye#1921 on 8/29/2012 4:54 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]