Diablo® III

New Stuttering Workaround!

Why hasn't Blizzard fixed this yet? It's been goin on since beta ffs
Reply Quote
08/29/2012 06:32 PMPosted by Diabeastus
Why hasn't Blizzard fixed this yet? It's been goin on since beta ffs


Because they don't care... That's why people from the community need to step in and try to help...
Reply Quote
Stuttering Updates: http://us.battle.net/d3/en/forum/topic/6412494524?page=1#7

^^^ More updates on my adventures into Diablo 3 (Stutter Land) Troubleshooting ...
Reply Quote
Went to play my monk just now and it's stutter central. I have no idea what is going on... I take that apology back.... Fix your game before it destroys my card...

Update: In order for me to play with no stutter now my core clock needs to be overclocked by 50-100. I shouldn't need to overclock to play diablo 3.
Edited by TriggerSaint#1450 on 8/29/2012 11:39 PM PDT
Reply Quote
I'm done trying. Fix your game. Very unprofessional...
Reply Quote
Posts: 64
(╯°□°)╯︵ ┻━┻ <--- i love this meme

I'm not a developer; I'm a computer tech. I can't change the game's code, but I can search for ways to alleviate symptoms so that people can enjoy the game more. Workarounds are not solutions by definition. Our devs are experimenting with performance boosts in almost every patch; I'm sure they'll get it eventually. In the meanwhile I'll keep investigating workarounds. :)


Thx for the workarounds.
Reply Quote
An update for me: Stuttering got WORSE after I disabled indexing.
Reply Quote
I fixed stuttering by moving some of the mpq files (Sound and clientData) to other hdd (physical) and symlinked them.

Give it a try if you have at least 2 hdd.
Reply Quote
the higher the write speed the better, but it isn't a guaranteed fix
Reply Quote
73 Goblin Shaman
8100
Posts: 2,079
I still think adding loading screens for each act would fix this issue.
Reply Quote
Fixed issue for me, I have i7 and 2 ssd drives. I still very rarely stutters for blink, but it's playable now.
Reply Quote
Make a ram drive.. toss the game into it.. bye bye shutter

btw.. i have noted amoungst the people i play with, the more powerful the machine. the more likely it is to shutter. Like striped SSD Drives, high end processors, 64bit with high mz, quad channel.. etc..
Reply Quote
didnt work...
Reply Quote
I turned off drive indexing for C:, subfolders, and files in addition to completely disabling Aero. The stuttering and extremely low fps improved a bit but I still have the problem - which means I cannot play hardcore right now.

I suspect there is something else occurring that is specific to my computer system. I will try to remember to update this post if/when I discover the source of the problem.

Edit: Re-enabled drive indexing and turned on Aero. I then uninstalled & re-installed my graphics driver. Problem disappeared entirely. I'm glad it worked, but... I'd love to know why.
Edited by Medea#1937 on 9/5/2012 10:34 PM PDT
Reply Quote
Update: Game running pretty smooth now.

My settings:
-Nvid driver 296.10
-Force on vsync in Nvid settings.
-Vsync on in game.
-Max FPS bars unchecked.
-Hardware class set at 4
-Underclocked from 900 to 775

Diablo seems to use more of my card with these settings...
Reply Quote
08/29/2012 08:41 PMPosted by TriggerSaint
Why hasn't Blizzard fixed this yet? It's been goin on since beta ffs


Because they don't care... That's why people from the community need to step in and try to help...


there is NOTHING the community can do to help. this is a development problem in the game. it is beyond what anyone can do outside of game coding can do about it. blizz needs to fix their dam game.

a "solution" which isnt a solution at all, is u can run the game from a flash drive or sd card. this isn't a solution, just a patch up for what blizzard broke. FIX THE GAME!
Reply Quote
What happened in the last week or so maintenance wise? It seems to have *mostly* fixed my asset loading issues. I am seeing spikes to orange latency more often, but they arent bad enough to drop FPS too much.
Reply Quote
While the following isn't guaranteed to resolve all stutter symptoms on all systems, we have seen significant improvements on several computers using this method. This workaround involves partially disabling Windows Drive Indexing, a tool that speeds up Windows searches.

Disable Drive Indexing

1. Click Start
2. Click Computer*
3. Right Click your Hard Drive (typically C:) and select Properties
4. Select the General tab
5. Uncheck Allow files on this drive to have contents indexed...**
6. Click Apply
7. Select Apply changes to drive C:\ only
8. Click Ok, and then Ok again
9. Load up Diablo III and see if your performance has improved!

* = My Computer on Windows XP
** = Allow Indexing Service to index... on Windows XP

Turning off indexing to the "drive only" will still enable your Windows' searches to be quick. If you still have stuttering after this workaround, you may wish to experiment with turning off indexing to subfolders and files as well. Once you've turned indexing off for everything, the option will change to one that lets you re-enable it if need be.

In the meanwhile, I'll pass this information on to the devs so that hopefully more changes can be made on our end to reduce stuttering. Thank you!


I have a 5400rpm HDD. Using this method to disable indexing starts a progress bar when I click apply that seems to never end. I left it running for half an hour and it didn't even make 5% progress through the hard drive.

I figured there would be an easier way to do it. After a bit of searching, I found these instructions:

winkey+R – type services.msc and hit enter
double click the indexing service
stop it, and set startup type to disabled

Instead of a progress bar that would take hours to finish, this change was completed immediately.
I'm not sure if this will achieve the same thing, but I'm assuming it will. Can anyone confirm?
Edited by Aeed#2733 on 9/10/2012 8:58 AM PDT
Reply Quote
Instead of a progress bar that would take hours to finish, this change was completed immediately.
I'm not sure if this will achieve the same thing, but I'm assuming it will. Can anyone confirm?


yes what you did achieves the same thing. ive turned windows indexing off months ago, even before d3 was released just because it was hogging so much of my CPU and i used the method u did by jus disabling it in windows services so it no longer runs. blizzard prolly posted it this way because they dont want to be responsible for people have problems with their system for messing around in windows services if they dont know what they're doing.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]