Diablo® III

New Stuttering Workaround!

Edited by Raven#11760 on 9/11/2012 6:22 PM PDT
Reply Quote
09/10/2012 05:46 AMPosted by Gör

Because they don't care... That's why people from the community need to step in and try to help...

there is NOTHING the community can do to help. this is a development problem in the game. it is beyond what anyone can do outside of game coding can do about it. blizz needs to fix their dam game.

a "solution" which isnt a solution at all, is u can run the game from a flash drive or sd card. this isn't a solution, just a patch up for what blizzard broke. FIX THE GAME!

The whole flash drive fix you speak of came from the "community" there is nothing the community can do to help? there are plenty of working fixes that HAVE COME from the community... I'm not just going to sit around and wait for blizzard... They need to fix this game... otherwise I'm moving on...
Reply Quote
^^ Speaking of...


I Need testers.
Reply Quote
I'd really like to know if Blizzard is adressing this Issue in 1.0.5

I don't know about the rest of you, but I think it's messed up to change you're whole PC-setup just so you can play a game that is supposed to be running like the flash with high-end hardware a lot of troubled customers have.

I can't play properly(every 1-2 minutes my FPS drops from 60 to 2-10 FPS) since 1.0.3 and it is just angering me and I think alot of other customers as well, that you are just giving us these workarounds where you're not even sure that it will fix the problems the users are having.

Sorry for grammar/spelling mistakes - english is not my first language.^^
Edited by Hulk#2490 on 9/15/2012 4:23 AM PDT
Reply Quote
Yea. I was blazing through this game prior to 1.0.4.
Now? Micro stutter, lag, & building anger.

We need to get the word out so people stop breaking their machines to try and fix this.
It's not you, it's them.
Reply Quote
ok. i've been having this stuttering problem for months and i've finaly got it all worked out thanks to some players i ran into on youtube and in d3 forums. turns out the stuttering is from a few problems in the game so it took me multiple changes to both my computer and the game to resolve it. and i got this resolved all without having to buy a usb flash drive or anything like that.
blizzard will prolly flame me for this because everytime i've seen this mentioned in forums, blizz always told the person to undo the changes. but hey it worked for me, so i'ma do what works.

when i bought this game the day before launch, it was smooth and fast running but came patch 1.0.2 the bottom dropped out and i could no longer run the game smoothly. there was stuttering and lagging to kingdom come so i had to turn all video settings to off and low but nothing seemed to change. then came patch 1.0.3, the stuttering got worse. then came patch 1.0.4 the game became unplayable because i could only run at 9 frames so i stopped playing. i began doing some research trying all kinds of things but nothing worked. but then i finally got it working after weeks of frustration. hopefully this helps someone else. i had to do this entire combo of things to get the game back to running fps.

1. edit the d3pref file
- go to Documents\Diablo III folder and open file D3Prefs.txt
- look further down and u'll see a line that says:
HardwareClass "3"
- the number inside the quotes can be any number, mine jus happend to be "3"
- change whatever number is there to "1"
- so it should now read HardwareClass "1"
- next look for a line that says
DisableTrilinearFiltering "0"
- change the "0" to "1"
- so it should now read DisableTrilinearFiltering "1"
- save the D3Pref file and close it

2. change d3 to run on 2 CPUs.
i have a quad core i5 laptop and apparently D3 has a problem on my computer with running on 4 processors (hard to believe i know you would think it would run better) but i'm guessing D3 doesn't support hyper-threading, at least it seems so on my laptop, and therefore having 4 processors causes the game to run slow instead of faster. i guess because D3 doesn't know how to run on 4 processors. so i had to disable 2 of the processors so i only have it running on 2 processors instead of 4. u have to have diablo running to do this part so startup D3.

- do ctrl+alt+del and click "start task manager"
- click the processes tab and look for Diablo III.exe
- right-click on it and select Set Affinity
- if u have a quad you'll see 4 processors listed, CPU 0, 1, 2 & 3
- uncheck 2 & 3 and click OK
- close task manager

*note about this step: u have to do this everytime u start D3 because it resets it back to all CPUs when u close the game. there are programs out there u can use that can have it permanently open D3 on 2 cpus everytime but u can google that. i'm not going to endorse a program here.

3. disable any programs running in the background that use internet connection.
i had to disable all programs in the background that uses internet connection which included my messenger program trillian, pandora, google music manager and skype. i now only run steam while playing D3 and it doesn't seem to be causing much a problem. i had disabled these in the past anyway but still had the lag and stutter so jus disabling background programs wasn't enough to stop the stutter. not sure if they are listening on the same ports as D3 or not but they seemed to cause a problem too.

now try playing and check the performance.

dont know if this will work for everyone but it worked for me. i now can run the game at all max settings again with a consistant 70-80 frames and all stuttering and lag is gone after many months. i still have occasional rubberbanding tho but that's jus blizzard server lag i can do nothing about. i also do still have the lag problem where i have to cast spells first and somewhat lagging still sometimes when moving forward on undiscovered areas on the map but that's manageable; not really a problem altho it is still something blizzard needs to fix rather than bloating the game down with more eye candy.

i have now been running the game for two days now and there has not been not one stutter problem other than the small issues i jus mentioned above but thats only when i start the game. after that it's smooth gaming and i love it. i've even been able to run co-op games again with my friends in a full group with not much lag. the lag i do get i suspect is jus server lag because all my friends say its happening to all of them at the same time.

Blizzard i love you long time but come on ... it all seems to be a problem on your end because i shouldn't have to go thru all this JUST to play a game and my laptop is new, i jus bought this thing in april and it has a midgrade video chip that can more than handle this type of game; its not like D3 is video intense. i have not had any problems with running WoW, SC2, GW2, Torchlight or any other game on my PC; its limited to only D3. the problems i had with D3 spans from not only a network problem causing lag, but also a video problem causing lag and CPU problem causing even MOAR lag. please fix this.

hope this helps anyone out there

put D3 on a regular 16gb usb flash drive, $10 from wally world (walmart) in conjunction to what i put above and noticed a significant decrease in stuttering from moving forward on undiscovered areas on the map, primarily in fields of slaughter since that stuttered the most. it still twitches a lil bit kinda like its skipping a frame or something but my frames still are between 70-80 fps, but its barely noticeable, prolly cuz i'm lookin for it, i guess this is what u guys were calling micro-stutter? also the drop in frames to 0 from first run animations from spells and narrations are completely gone, however, i did get a few times for no apparent reason a drop in frames to 0 from jus running but i think that was jus rubberbanding maybe as there was nothing on my screen to even cause this; not even an animation. i dont know. but out of playing for about 2 hours, i only saw it happen twice. also the severe lag when inspecting heros from my friend's list is 100% gone as well as the drop to 0 frames on toast windows and leveling splashes. so i guess this is step 4 -_-

again. shouldn't have to do all this jus to run a game.

ty D3 community and fellow players with no help from blizz except more grief.
Edited by Gör#1270 on 9/16/2012 12:39 PM PDT
Reply Quote
At this point it's ridiculous, I haven't played for a few weeks now and it's probably going to stay that way, there are other games that actually work that I would rather play, If D3 didn't stutter I would love to play it. This issue should come first on their list, right now it sits dead last...

Bye D3 Hello BL2
Reply Quote
Posts: 3
This completely resolved my issue!
Reply Quote
09/15/2012 10:45 PMPosted by Bluey
This completely resolved my issue!

what resolved it? turning off windows indexing or what i posted about editing the d3pref file and stuff?
Reply Quote
So it`s not gonna be fixed in 1.05?
Reply Quote
Just wanted to chime in to say that i just got my new computer (GTX 660 ti, 8GB RAM, i5 3570K, Windows 7 64-bit)

...and Diablo 3 still stutters like hell the first ten minutes of playing while Guild Wars 2 for example runs between 50-60 fps maxed out and v-synced AT ANY GIVEN TIME regardless of how much is going on in WvW-PvP.

You gotta be kidding me, Blizzard.
Reply Quote
Every ATI user must try this. I have an HD 7350(Not really good at all), and I am currently playing diablo 3 at 1600x900 with high textures, medium shadows, high particles, and high physics. The difference in performance i'm getting now compared to then is night and day. You have to try this. Here it is step by step.

-First off, download RadeonPro from the official website.
-Now create a profile for Diablo 3(make sure you pick the actual exe, not a shortcut)
-Now once the profile has been created, go to the tweaks tab.
-Once here, set "VSync control" to "always on".
-Now this is the big one, enable "triple buffering" and "Force agressive API detection level"
-Right click Diablo III in Radeon Pro's list on the left and click "apply now".
-Right click Diablo III again in the list and click play.
-From here login to Diablo 3 as you usually do and start a game with whatever character.
-Once the game starts, open up your video settings and disable VSync and Max foreground fps.
-Select what resolution you want to play at(trust me), and any other options you like.
-Now start playing the game and hold ctrl and press r to see your fps at the top left screen. Pay attention to how low the fps gets.
-Open up your video options again, and set max foreground fps on. Set it to the lowest your fps went to.
-Go back to your game and WAAAAAAAAALLLLAAAAAAA, you should have perfect performance and excellent graphics with a low-end gpu.

Make sure to set the max foreground fps as high as you can until your fps starts to drop even a frame. Try to set it until it pretty much stays at that set number. This method worked perfectly for me and I no longer have any stuttering issues or rubberbanding. Hope it works for you guys. Blizzard needs to fix there vsync as it doesn't have triple buffering. Because of that if you use there vsync, it automatically set your fps to half of what its trying to go for. With triple buffering on, the fps will go as far as your gpu can push it. That's where max foreground fps comes into play. Kinda weird blizzard hasn't come up with a workaround for this yet. Oh well that's what forums and all you good people are for. Sorry if this method has already been mentioned by someone else. I just wanted to post this before I forgot. Thank you.
Reply Quote
nice!!!!!!!!!!! im so happy now!!!! its fixed alot better much! but not 100% but waaaaaay better than before! thanks you!
Reply Quote
Ok, so I did almost everything suggested posted on the forums and deactivating Virtualization in BIOS and disabling CPU 2&3 in the task manager with activated virtual sync in the nvidia-driver setup actually did fix it - so far(I thought a few times it was fixed until it reappeared).

But since the stuttering stopped mostly since I turned of VT and disabled the cores I guess it is a problem regarding the CPU.

Had no stuttering yesterday, but more rubberbanding(which, compared to the stuttering is really not as bad).

Hope it works for some of you too and that it will be fixed nevertheless.

My PC-setup:

AMD Phenom X4 3,2ghz
Geforce GTX 260
8gb ram
Edited by Hulk#2490 on 9/19/2012 1:42 AM PDT
Reply Quote
Yeah, It's not perfect because you are setting the max frames down(mines at 23 at all times except for the sewers and a few other areas) you will notice the background is not smooth in movement, but this method has fixed the stuttering problem where my character used to randomly pop around the screen as your playing. Remember to try and set the max fps foreground as low as you have to until you notice your frames are pretty much stuck at that max frame rate. It will still be slow in like four or five different areas in the game(especially when the camera zooms out like when you fight belial), but if you want you could temporaraly set your max foreground fps down again just for that area. Again, this isn't perfect but it will rid of stuttering and even make your game much more playable at as low as 20 fps. Its the perfect workaround for people like me who don't have the top of the line gpu and want to play in a better resolution other than 800x600 just so you can get somewhat smooth gameplay and have the crappiest looking graphics. Also check out Torchlight 2. Tommorow is the release day! Can't wait!
Reply Quote
100 Human Rogue
Posts: 68
Thank you...:)
Reply Quote
omg. this helped me a lot. thx to kaltonis.
Reply Quote
Setting processor affinity to cores 0 and 1 eliminated most of the jitter for me.

The program, Prio, will retain your affinity and priority changes through exits and reboots; Link: http://www.prnwatch.com/prio.html

However, setting vsynch ON in the game and ON in the nVidia driver also eliminated most jitter, even after resetting CPU affinity back to all cores.
Reply Quote
Looking at the patch notes for 1.0.5, there is still no mention of a possible fix for stuttering or loading assets.

Reply Quote
You're not alone Nobby. The greatest fear for everyone should be that micro-stuttering, 5-step-stuttering, rubberbanding, & graphics lag has gotten worse and/or affected more with each patch.
The better your machine the greater chance you are infected with the stutter-flu.
We should be posting threads on how to build circa 2005 machines to run D3.

....or start a SA forum....."stuttering anonymous"....so we can all cope with it.

Hi my name is Greg and I started stuttering after patch 1.0.4.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)