Diablo® III

New Stuttering Workaround!

This did not work for me.
Reply Quote
This still isn't fixed yet? yet another patch is about to roll around and there is still NO news on fixing the stuttering. Really Blizz? This is a joke, before adding anymore new content you should FIX YOUR GAME. Haven't played in a while and it will stay that way until you get rid of this HUGE issue.
Reply Quote
indexing on ssd = stupid so cant do this
Reply Quote
its didnt work perfect... im so tired of it. i stopped play when stuttering is annoying to me. i dont understand why u cant fix it yet. other games with no shutting. And my computer is highest for gaming.
Reply Quote
FIX STUTTERING!!!!!!!!!!!
Reply Quote
The stuttering was so bad on my gaming desktop that I've been playing on my much inferior laptop lately. I installed updates to Java and Adobe Flash tonight, and now I have stuttering on the laptop too. Maybe they're related?

Very disappointed I can run Borderlands 2 on the gaming PC but not D3.
Reply Quote
Just got a 680 gtx, upgraded from a 460...now I have the same stuttering problem. The fix in the first post helps a little, but not completely. Guess I won't be playing this for a while, if it's been this long I doubt there's a fix coming soon.
Reply Quote
09/25/2012 09:26 PMPosted by Beave
The stuttering was so bad on my gaming desktop that I've been playing on my much inferior laptop lately. I installed updates to Java and Adobe Flash tonight, and now I have stuttering on the laptop too. Maybe they're related?

Have you uninstalled them to see if the problem clears?

09/26/2012 02:49 AMPosted by Clandestino
Just got a 680 gtx, upgraded from a 460...now I have the same stuttering problem.

Did you update your drivers when you installed the 680? If so, do you remember which version you ran before the upgrade and try it?
Edited by Rolo#1588 on 9/26/2012 5:17 AM PDT
Reply Quote
I think I am having the same issue. I have an i5 2500K processor and a 2.5 GB GTX570 EVGA graphics card. I also have an SSD. Enabling Vsync helped alot of the tearing and text jittering I was getting, but I still have an issue when there is alot going on. With Vsync on, the FPS is limited to 60, but the number is constantly flickering between 59 and 60. I dont know if this has anything to do with it or not, but it does seem strange.

When I built the rig, I went with the latest non-beta drivers from Nvidia, and I wonder if the latest beta drivers would help anything? I am not having any issues whatsoever with the computer since I built it about a month ago.
Reply Quote
There are no "latest beta" drivers as 306.23 is WHQL as of 2 weeks ago.

Check your refresh rate in Windows display advanced settings; for some reason, my monitor has a 59Hz and 60Hz option.
Reply Quote
Kind of sad that a lot people including myself have been putting up with this crap since the game was released and there's still not an official fix just dozens of "try this" fixes that have mixed results.

This should of been a priority issue to deal with.
Reply Quote
I was certain when I looked on EVGA's site a few days ago it said 306.23 was beta, but now it is just listed as driver. The driver I am currently using is 301.42, so I wonder if getting the newest driver would help anything? Sorry for being such a noob, but this was my first build, and I am still learning. I checked the refresh rate options, and there is 60, 59, 50, 30, 29, and 20.

With the FPS number showing up in the corner while playing, I notice the number going all over the place. I have noticed it taking up a third number sometimes, as in its going over 100. When I switch to fullscreen windowed, the number almost stops flickering at 60, but there still is a little movement between 59 and 60. But, the graphics still get whacky. I will probably just download the 306.23 driver and see if it helps anything.
Reply Quote
Tried this, actually made it WORSE!!

My FPS number is also doing a dance, unreadable as it jumps around, only time it is readable is when changing location or exiting the game.
Reply Quote
09/29/2012 02:07 PMPosted by Hub
I was certain when I looked on EVGA's site a few days ago it said 306.23 was beta, but now it is just listed as driver.

eVGA doesn't make drivers, nVidia does; eliminate the middle-man.

Turn on Vsynch to keep FPS from exceeding your refresh rate and to eliminate tearing. I get less jitter with Vsynch in the game ON ("Let app decide" in the driver) and FPS limiters in the game disabled.

59-60 FPS bounce is typical.
Reply Quote
I realize EVGA does not make the drivers, but when I put the rig together, that is where I downloaded the driver I am currently using. If I do get the 306.23 driver it will be from Nvidia's site.

I had to turn on Vsync right off the bat to keep the tearing issue at bay, and also the text from items on the ground jittering. I have tried the FPS limiters in the game disabled as well, and tried adjusting the slider to different amounts to no avail. I have been checking temps on CPU and GPU and they are not running hot at all, so that is not an issue. I guess all I can hope for is the 1.05 patch somehow fixes the issue, I doubt it, but there is a chance.
Reply Quote
Hi! I was running the game with the same problem till yesterday. Try this:

Ati Catalyst > Preferences >Standard View (I couldn't find this option in advance view)

Then:

Ati Catalyst > Gaming > Gaming Performance > Standard 3D Settings > UNCHECK: Use Custom Settings > Scroll to Optimal Performances

Give it a try. DO NOT activate Triple Buffer in OpenGL Settings or the Standard 3D settings will turn back to custom settings once more.

If is not good, I'll post the rest of my settings.
Reply Quote
Per someone else's suggestion, I lowered my audio channels to Low (32 IIRC) and its helped much.

I'm starting to think its several different settings that contribute to screen jitter; the smattering of results posted and my experience suggest this. Additionally, its inconsistent with no readily apparent pattern.
Reply Quote
I'm on a NVIDIA 660m. Ever since updating to the new 306.23 driver and putting D3 on my SSD I've been getting absolutely no stuttering.
Reply Quote
Well, that's a new thing, blizzard ignoring first class issues...

I'm playing at 5 fps when encounting mobs, without sounds, everything to low. once in a while, everything is fine, but most of the time, your game is just unplayable. And no, it's not a driver issue. Hopefully they're gonna be smart and fix it with 1.05. Otherwise this is just a crappy BETA game that can't work properly..
Reply Quote
42 Pandaren Monk
10740
Posts: 746
Wat? lol.... not like that... its YOUR ENGINE! DUMBASS! this didnt work very well... wat r u think... stupid
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]